CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-4154

IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, and 11.1 is vulnerable to a buffer overflow, which could allow an authenticated local attacker to execute arbitrary code on the system as root. IBM X-Force ID: 158519.
Publish Date : 2019-07-01 Last Update Date : 2019-07-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Products Affected By CVE-2019-4154

# Product Type Vendor Product Version Update Edition Language
1 Application IBM DB2 9.7.0.0 Version Details Vulnerabilities
2 Application IBM DB2 9.7.0.1 Version Details Vulnerabilities
3 Application IBM DB2 9.7.0.2 Version Details Vulnerabilities
4 Application IBM DB2 9.7.0.3 Version Details Vulnerabilities
5 Application IBM DB2 9.7.0.4 Version Details Vulnerabilities
6 Application IBM DB2 9.7.0.5 Version Details Vulnerabilities
7 Application IBM DB2 9.7.0.6 Version Details Vulnerabilities
8 Application IBM DB2 9.7.0.7 Version Details Vulnerabilities
9 Application IBM DB2 9.7.0.8 Version Details Vulnerabilities
10 Application IBM DB2 9.7.0.9 Version Details Vulnerabilities
11 Application IBM DB2 9.7.0.10 Version Details Vulnerabilities
12 Application IBM DB2 9.7.0.11 Version Details Vulnerabilities
13 Application IBM DB2 10.1.0.0 Version Details Vulnerabilities
14 Application IBM DB2 10.1.0.1 Version Details Vulnerabilities
15 Application IBM DB2 10.1.0.2 Version Details Vulnerabilities
16 Application IBM DB2 10.1.0.3 Version Details Vulnerabilities
17 Application IBM DB2 10.1.0.4 Version Details Vulnerabilities
18 Application IBM DB2 10.1.0.5 Version Details Vulnerabilities
19 Application IBM DB2 10.1.0.6 Version Details Vulnerabilities
20 Application IBM DB2 10.5.0.0 Version Details Vulnerabilities
21 Application IBM DB2 10.5.0.1 Version Details Vulnerabilities
22 Application IBM DB2 10.5.0.2 Version Details Vulnerabilities
23 Application IBM DB2 10.5.0.3 Version Details Vulnerabilities
24 Application IBM DB2 10.5.0.4 Version Details Vulnerabilities
25 Application IBM DB2 10.5.0.5 Version Details Vulnerabilities
26 Application IBM DB2 10.5.0.6 Version Details Vulnerabilities
27 Application IBM DB2 10.5.0.7 Version Details Vulnerabilities
28 Application IBM DB2 10.5.0.8 Version Details Vulnerabilities
29 Application IBM DB2 10.5.0.9 Version Details Vulnerabilities
30 Application IBM DB2 10.5.0.10 Version Details Vulnerabilities
31 Application IBM DB2 11.1.0.0 Version Details Vulnerabilities
32 Application IBM DB2 11.1.1.1 Version Details Vulnerabilities
33 Application IBM DB2 11.1.2.2 Version Details Vulnerabilities
34 Application IBM DB2 11.1.3.3 Version Details Vulnerabilities
35 Application IBM DB2 11.1.4.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
IBM DB2 35

- References For CVE-2019-4154

http://www.securityfocus.com/bid/109024
BID 109024 IBM DB2 CVE-2019-4154 Local Buffer Overflow Vulnerability Release Date:2019-06-27
https://exchange.xforce.ibmcloud.com/vulnerabilities/158519
XF ibm-db2-cve20194154-bo (158519)
https://www.ibm.com/support/docview.wss?uid=ibm10880737 CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2019-4154

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.