CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-3855

An integer overflow flaw which could lead to an out of bounds write was discovered in libssh2 before 1.8.1 in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to execute code on the client system when a user connects to the server.
Publish Date : 2019-03-21 Last Update Date : 2020-10-15
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID 787

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:0679: libssh2 security update (Important) oval:com.redhat.rhsa:def:20190679 unix
RHSA-2019:1175: virt:rhel security update (Important) oval:com.redhat.rhsa:def:20191175 unix
RHSA-2019:1652: libssh2 security update (Important) oval:com.redhat.rhsa:def:20191652 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2019-3855

# Product Type Vendor Product Version Update Edition Language
1 Application Apple Xcode * * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
3 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
4 OS Fedoraproject Fedora 28 * * * Version Details Vulnerabilities
5 OS Fedoraproject Fedora 29 * * * Version Details Vulnerabilities
6 OS Fedoraproject Fedora 30 * * * Version Details Vulnerabilities
7 Application Libssh2 Libssh2 * * * * Version Details Vulnerabilities
8 Application Netapp Ontap Select Deploy Administration Utility - * * * Version Details Vulnerabilities
9 OS Opensuse Leap 42.3 * * * Version Details Vulnerabilities
10 Application Oracle Peoplesoft Enterprise Peopletools 8.56 * * * Version Details Vulnerabilities
11 Application Oracle Peoplesoft Enterprise Peopletools 8.57 * * * Version Details Vulnerabilities
12 OS Redhat Enterprise Linux 8.0 * * * Version Details Vulnerabilities
13 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Server Aus 7.6 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Server Eus 7.6 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Server Tus 7.6 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apple Xcode 1
Debian Debian Linux 2
Fedoraproject Fedora 3
Libssh2 Libssh2 1
Netapp Ontap Select Deploy Administration Utility 1
Opensuse Leap 1
Oracle Peoplesoft Enterprise Peopletools 2
Redhat Enterprise Linux 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server Eus 1
Redhat Enterprise Linux Server Tus 1
Redhat Enterprise Linux Workstation 1

- References For CVE-2019-3855

http://seclists.org/fulldisclosure/2019/Sep/42
FULLDISC 20190927 APPLE-SA-2019-9-26-7 Xcode 11.0
https://support.apple.com/kb/HT210609 CONFIRM
https://seclists.org/bugtraq/2019/Sep/49
BUGTRAQ 20190927 APPLE-SA-2019-9-26-7 Xcode 11.0
https://lists.fedoraproject.org/archives/list/[email protected]/message/M7IF3LNHOA75O4WZWIHJLIRMA5LJUED3/
FEDORA FEDORA-2019-5885663621
https://access.redhat.com/errata/RHSA-2019:2399
REDHAT RHSA-2019:2399
https://lists.fedoraproject.org/archives/list/[email protected]/message/6LUNHPW64IGCASZ4JQ2J5KDXNZN53DWW/
FEDORA FEDORA-2019-9d85600fc7
https://access.redhat.com/errata/RHSA-2019:1943
REDHAT RHSA-2019:1943
https://access.redhat.com/errata/RHSA-2019:1791
REDHAT RHSA-2019:1791
https://access.redhat.com/errata/RHSA-2019:1652
REDHAT RHSA-2019:1652
https://www.debian.org/security/2019/dsa-4431
DEBIAN DSA-4431
https://security.netapp.com/advisory/ntap-20190327-0005/ CONFIRM
https://seclists.org/bugtraq/2019/Apr/25
BUGTRAQ 20190415 [SECURITY] [DSA 4431-1] libssh2 security update
https://access.redhat.com/errata/RHSA-2019:1175
REDHAT RHSA-2019:1175
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00003.html
SUSE openSUSE-SU-2019:1109
https://lists.fedoraproject.org/archives/list/[email protected]/message/5DK6VO2CEUTAJFYIKWNZKEKYMYR3NO2O/
FEDORA FEDORA-2019-3348cb4934
http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00040.html
SUSE openSUSE-SU-2019:1075
https://access.redhat.com/errata/RHSA-2019:0679
REDHAT RHSA-2019:0679
https://lists.debian.org/debian-lts-announce/2019/03/msg00032.html
MLIST [debian-lts-announce] 20190326 [SECURITY] [DLA 1730-1] libssh2 security update
https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2019-767 CONFIRM
https://lists.fedoraproject.org/archives/list/[email protected]/message/XCWEA5ZCLKRDUK62QVVYMFWLWKOPX3LO/
FEDORA FEDORA-2019-f31c14682f
http://packetstormsecurity.com/files/152136/Slackware-Security-Advisory-libssh2-Updates.html
http://www.openwall.com/lists/oss-security/2019/03/18/3
MLIST [oss-security] 20190318 [SECURITY ADVISORIES] libssh2
http://www.securityfocus.com/bid/107485
BID 107485 libssh2 Multiple Security Vulnerabilities Release Date:2019-04-19
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3855 CONFIRM
https://www.libssh2.org/CVE-2019-3855.html
https://seclists.org/bugtraq/2019/Mar/25
BUGTRAQ 20190319 [slackware-security] libssh2 (SSA:2019-077-01)
https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html

- Metasploit Modules Related To CVE-2019-3855

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.