CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-3812

QEMU, through version 2.10 and through version 3.1.0, is vulnerable to an out-of-bounds read of up to 128 bytes in the hw/i2c/i2c-ddc.c:i2c_ddc() function. A local attacker with permission to execute i2c commands could exploit this to read stack memory of the qemu process on the host.
Publish Date : 2019-02-19 Last Update Date : 2019-05-31
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 125

- Products Affected By CVE-2019-3812

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 18.04 ~~lts~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 18.10 Version Details Vulnerabilities
3 OS Fedoraproject Fedora 29 Version Details Vulnerabilities
4 OS Fedoraproject Fedora 30 Version Details Vulnerabilities
5 OS Opensuse Leap 42.3 Version Details Vulnerabilities
6 Application Qemu Qemu 2.10.0 Version Details Vulnerabilities
7 Application Qemu Qemu 2.10.1 Version Details Vulnerabilities
8 Application Qemu Qemu 2.10.2 Version Details Vulnerabilities
9 Application Qemu Qemu 2.11.0 RC1 Version Details Vulnerabilities
10 Application Qemu Qemu 2.11.0 RC2 Version Details Vulnerabilities
11 Application Qemu Qemu 2.11.0 RC3 Version Details Vulnerabilities
12 Application Qemu Qemu 2.11.0 RC4 Version Details Vulnerabilities
13 Application Qemu Qemu 2.11.0 Version Details Vulnerabilities
14 Application Qemu Qemu 2.11.0 RC5 Version Details Vulnerabilities
15 Application Qemu Qemu 2.11.0 RC0 Version Details Vulnerabilities
16 Application Qemu Qemu 2.11.1 Version Details Vulnerabilities
17 Application Qemu Qemu 2.11.2 Version Details Vulnerabilities
18 Application Qemu Qemu 2.12.0 RC3 Version Details Vulnerabilities
19 Application Qemu Qemu 2.12.0 RC4 Version Details Vulnerabilities
20 Application Qemu Qemu 2.12.0 Version Details Vulnerabilities
21 Application Qemu Qemu 2.12.0 RC0 Version Details Vulnerabilities
22 Application Qemu Qemu 2.12.0 RC1 Version Details Vulnerabilities
23 Application Qemu Qemu 2.12.0 RC2 Version Details Vulnerabilities
24 Application Qemu Qemu 2.12.1 Version Details Vulnerabilities
25 Application Qemu Qemu 2.12.50 Version Details Vulnerabilities
26 Application Qemu Qemu 3.0.0 RC1 Version Details Vulnerabilities
27 Application Qemu Qemu 3.0.0 RC2 Version Details Vulnerabilities
28 Application Qemu Qemu 3.0.0 RC3 Version Details Vulnerabilities
29 Application Qemu Qemu 3.0.0 RC4 Version Details Vulnerabilities
30 Application Qemu Qemu 3.0.0 Version Details Vulnerabilities
31 Application Qemu Qemu 3.1 Version Details Vulnerabilities
32 Application Qemu Qemu 3.1.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 2
Fedoraproject Fedora 2
Opensuse Leap 1
Qemu Qemu 27

- References For CVE-2019-3812

https://www.debian.org/security/2019/dsa-4454
DEBIAN DSA-4454
https://seclists.org/bugtraq/2019/May/76
BUGTRAQ 20190531 [SECURITY] [DSA 4454-1] qemu security update
https://lists.fedoraproject.org/archives/list/[email protected]/message/KJMTVGDLA654HNCDGLCUEIP36SNJEKK7/
FEDORA FEDORA-2019-0664c7724d
http://www.securityfocus.com/bid/107059
BID 107059 QEMU CVE-2019-3812 Out-Of-Bounds Read Local Information Disclosure Vulnerability Release Date:2019-02-18
https://lists.fedoraproject.org/archives/list/[email protected]/message/CGCFIFSIWUREEQQOZDZFBYKWZHXCWBZN/
FEDORA FEDORA-2019-88a98ce795
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3812 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00094.html
SUSE openSUSE-SU-2019:1274
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00040.html
SUSE openSUSE-SU-2019:1405
https://usn.ubuntu.com/3923-1/
UBUNTU USN-3923-1

- Metasploit Modules Related To CVE-2019-3812

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.