CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-2301

Possibility of out-of-bound read if id received from SPI is not in range of FIFO in Snapdragon Auto, Snapdragon Compute, Snapdragon Consumer IOT, Snapdragon Industrial IOT, Snapdragon Mobile, Snapdragon Wearables, Snapdragon Wired Infrastructure and Networking in IPQ4019, IPQ8064, MSM8909W, MSM8996AU, QCA9980, QCS605, Qualcomm 215, SD 425, SD 439 / SD 429, SD 450, SD 625, SD 632, SD 636, SD 712 / SD 710 / SD 670, SD 820A, SD 845 / SD 850, SD 855, SDM439, SDM660, SDX24
Publish Date : 2019-07-25 Last Update Date : 2019-07-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.6
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Overflow
CWE ID 119

- Products Affected By CVE-2019-2301

# Product Type Vendor Product Version Update Edition Language
1 OS Qualcomm Ipq4019 Firmware - Version Details Vulnerabilities
2 OS Qualcomm Ipq8064 Firmware - Version Details Vulnerabilities
3 OS Qualcomm Msm8909w Firmware - Version Details Vulnerabilities
4 OS Qualcomm Msm8996au Firmware - Version Details Vulnerabilities
5 OS Qualcomm Qca9980 Firmware - Version Details Vulnerabilities
6 OS Qualcomm Qcs605 Firmware - Version Details Vulnerabilities
7 OS Qualcomm Qualcomm 215 Firmware - Version Details Vulnerabilities
8 OS Qualcomm Sd 425 Firmware - Version Details Vulnerabilities
9 OS Qualcomm Sd 429 Firmware - Version Details Vulnerabilities
10 OS Qualcomm Sd 439 Firmware - Version Details Vulnerabilities
11 OS Qualcomm Sd 450 Firmware - Version Details Vulnerabilities
12 OS Qualcomm Sd 625 Firmware - Version Details Vulnerabilities
13 OS Qualcomm Sd 632 Firmware - Version Details Vulnerabilities
14 OS Qualcomm Sd 636 Firmware - Version Details Vulnerabilities
15 OS Qualcomm Sd 670 Firmware - Version Details Vulnerabilities
16 OS Qualcomm Sd 710 Firmware - Version Details Vulnerabilities
17 OS Qualcomm Sd 712 Firmware - Version Details Vulnerabilities
18 OS Qualcomm Sd 820a Firmware - Version Details Vulnerabilities
19 OS Qualcomm Sd 845 Firmware - Version Details Vulnerabilities
20 OS Qualcomm Sd 850 Firmware - Version Details Vulnerabilities
21 OS Qualcomm Sd 855 Firmware - Version Details Vulnerabilities
22 OS Qualcomm Sdm439 Firmware - Version Details Vulnerabilities
23 OS Qualcomm Sdm660 Firmware - Version Details Vulnerabilities
24 OS Qualcomm Sdx24 Firmware - Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Qualcomm Ipq4019 Firmware 1
Qualcomm Ipq8064 Firmware 1
Qualcomm Msm8909w Firmware 1
Qualcomm Msm8996au Firmware 1
Qualcomm Qca9980 Firmware 1
Qualcomm Qcs605 Firmware 1
Qualcomm Qualcomm 215 Firmware 1
Qualcomm Sd 425 Firmware 1
Qualcomm Sd 429 Firmware 1
Qualcomm Sd 439 Firmware 1
Qualcomm Sd 450 Firmware 1
Qualcomm Sd 625 Firmware 1
Qualcomm Sd 632 Firmware 1
Qualcomm Sd 636 Firmware 1
Qualcomm Sd 670 Firmware 1
Qualcomm Sd 710 Firmware 1
Qualcomm Sd 712 Firmware 1
Qualcomm Sd 820a Firmware 1
Qualcomm Sd 845 Firmware 1
Qualcomm Sd 850 Firmware 1
Qualcomm Sd 855 Firmware 1
Qualcomm Sdm439 Firmware 1
Qualcomm Sdm660 Firmware 1
Qualcomm Sdx24 Firmware 1

- References For CVE-2019-2301

https://www.codeaurora.org/security-bulletin/2019/07/01/july-2019-code-aurora-security-bulletin CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2019-2301

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.