CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-15846

Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash.
Publish Date : 2019-09-06 Last Update Date : 2020-08-24
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID CWE id is not defined for this vulnerability

- Products Affected By CVE-2019-15846

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
3 OS Debian Debian Linux 10.0 * * * Version Details Vulnerabilities
4 Application Exim Exim * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 3
Exim Exim 1

- References For CVE-2019-15846

https://www.debian.org/security/2019/dsa-4517
DEBIAN DSA-4517
https://exim.org/static/doc/security/CVE-2019-15846.txt
https://usn.ubuntu.com/4124-2/
UBUNTU USN-4124-2
https://lists.fedoraproject.org/archives/list/[email protected]/message/SBNHDAF74RI6VK2JVSEIE3VYNL7JJDYM/
FEDORA FEDORA-2019-1ed7bbb09c
http://www.openwall.com/lists/oss-security/2019/09/06/6
MLIST [oss-security] 20190906 Sv: [exim] CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges
https://security.gentoo.org/glsa/201909-06
GENTOO GLSA-201909-06
http://www.openwall.com/lists/oss-security/2019/09/06/8
MLIST [oss-security] 20190906 Re: Re: CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges.
http://www.openwall.com/lists/oss-security/2019/09/07/2
MLIST [oss-security] 20190906 Re: Sv: [exim] CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges
http://www.openwall.com/lists/oss-security/2019/09/07/1
MLIST [oss-security] 20190907 Re: Sv: [exim] CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges
https://lists.fedoraproject.org/archives/list/[email protected]/message/NDF37AUNETIOXY6ZLQAUBGBVUTMMV242/
FEDORA FEDORA-2019-ae361e20c2
http://www.openwall.com/lists/oss-security/2019/09/08/1
MLIST [oss-security] 20190908 Re: Re: CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges.
https://seclists.org/bugtraq/2019/Sep/13
BUGTRAQ 20190906 [SECURITY] [DSA 4517-1] exim4 security update
http://www.openwall.com/lists/oss-security/2019/09/06/2
MLIST [oss-security] 20190906 Re: CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges.
http://www.openwall.com/lists/oss-security/2019/09/06/5
MLIST [oss-security] 20190906 Re: CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges.
https://www.kb.cert.org/vuls/id/672565
CERT-VN VU#672565
http://www.openwall.com/lists/oss-security/2019/09/06/4
MLIST [oss-security] 20190906 Re: CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges.
https://lists.fedoraproject.org/archives/list/[email protected]/message/FT3GY7V7SR2RHKNZNQCGXFWUSILVSZNU/
FEDORA FEDORA-2019-467fcbb10a
https://usn.ubuntu.com/4124-1/
UBUNTU USN-4124-1
http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00024.html
SUSE openSUSE-SU-2019:2093
http://www.openwall.com/lists/oss-security/2019/09/09/1
MLIST [oss-security] 20190909 Re: Sv: [exim] CVE-2019-15846: Exim - local or remote attacker can execute programs with root privileges
https://lists.debian.org/debian-lts-announce/2019/09/msg00004.html
MLIST [debian-lts-announce] 20190906 [SECURITY] [DLA 1911-1] exim4 security update
https://www.openwall.com/lists/oss-security/2019/09/06/1
http://exim.org/static/doc/security/CVE-2019-15846.txt

- Metasploit Modules Related To CVE-2019-15846

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.