CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-14982

In Exiv2 before v0.27.2, there is an integer overflow vulnerability in the WebPImage::getHeaderOffset function in webpimage.cpp. It can lead to a buffer overflow vulnerability and a crash.
Publish Date : 2019-08-12 Last Update Date : 2019-08-16
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Overflow
CWE ID 190

- Products Affected By CVE-2019-14982

# Product Type Vendor Product Version Update Edition Language
1 Application Exiv2 Exiv2 0.3 Version Details Vulnerabilities
2 Application Exiv2 Exiv2 0.4 Version Details Vulnerabilities
3 Application Exiv2 Exiv2 0.5 Version Details Vulnerabilities
4 Application Exiv2 Exiv2 0.6 Version Details Vulnerabilities
5 Application Exiv2 Exiv2 0.6.1 Version Details Vulnerabilities
6 Application Exiv2 Exiv2 0.6.2 Version Details Vulnerabilities
7 Application Exiv2 Exiv2 0.7 Version Details Vulnerabilities
8 Application Exiv2 Exiv2 0.8 Version Details Vulnerabilities
9 Application Exiv2 Exiv2 0.9 Version Details Vulnerabilities
10 Application Exiv2 Exiv2 0.9.1 Version Details Vulnerabilities
11 Application Exiv2 Exiv2 0.10 Version Details Vulnerabilities
12 Application Exiv2 Exiv2 0.11 Version Details Vulnerabilities
13 Application Exiv2 Exiv2 0.12 Version Details Vulnerabilities
14 Application Exiv2 Exiv2 0.13 Version Details Vulnerabilities
15 Application Exiv2 Exiv2 0.14 Version Details Vulnerabilities
16 Application Exiv2 Exiv2 0.15 Version Details Vulnerabilities
17 Application Exiv2 Exiv2 0.16 Pre1 Version Details Vulnerabilities
18 Application Exiv2 Exiv2 0.16 - Version Details Vulnerabilities
19 Application Exiv2 Exiv2 0.17 Version Details Vulnerabilities
20 Application Exiv2 Exiv2 0.17.1 Version Details Vulnerabilities
21 Application Exiv2 Exiv2 0.18 - Version Details Vulnerabilities
22 Application Exiv2 Exiv2 0.18 Pre1 Version Details Vulnerabilities
23 Application Exiv2 Exiv2 0.18 Pre2 Version Details Vulnerabilities
24 Application Exiv2 Exiv2 0.18.1 Version Details Vulnerabilities
25 Application Exiv2 Exiv2 0.18.2 Version Details Vulnerabilities
26 Application Exiv2 Exiv2 0.19 Version Details Vulnerabilities
27 Application Exiv2 Exiv2 0.20 Version Details Vulnerabilities
28 Application Exiv2 Exiv2 0.21 Version Details Vulnerabilities
29 Application Exiv2 Exiv2 0.21.1 Version Details Vulnerabilities
30 Application Exiv2 Exiv2 0.22 Version Details Vulnerabilities
31 Application Exiv2 Exiv2 0.23 Version Details Vulnerabilities
32 Application Exiv2 Exiv2 0.24 Version Details Vulnerabilities
33 Application Exiv2 Exiv2 0.25 Version Details Vulnerabilities
34 Application Exiv2 Exiv2 0.26 Version Details Vulnerabilities
35 Application Exiv2 Exiv2 0.27 - Version Details Vulnerabilities
36 Application Exiv2 Exiv2 0.27 RC1 Version Details Vulnerabilities
37 Application Exiv2 Exiv2 0.27 RC2 Version Details Vulnerabilities
38 Application Exiv2 Exiv2 0.27 RC3 Version Details Vulnerabilities
39 Application Exiv2 Exiv2 0.27.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Exiv2 Exiv2 39

- References For CVE-2019-14982

https://github.com/Exiv2/exiv2/pull/962/commits/e925bc5addd881543fa503470c8a859e112cca62
https://github.com/Exiv2/exiv2/compare/v0.27.2-RC2...v0.27.2
https://github.com/Exiv2/exiv2/issues/960

- Metasploit Modules Related To CVE-2019-14982

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.