CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-14439

A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x before 2.9.9.2. This occurs when Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has the logback jar in the classpath.
Publish Date : 2019-07-30 Last Update Date : 2019-09-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Products Affected By CVE-2019-14439

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
2 Application Fasterxml Jackson-databind 2.7.0 RC3 Version Details Vulnerabilities
3 Application Fasterxml Jackson-databind 2.7.0 Version Details Vulnerabilities
4 Application Fasterxml Jackson-databind 2.7.0 - Version Details Vulnerabilities
5 Application Fasterxml Jackson-databind 2.7.0 RC1 Version Details Vulnerabilities
6 Application Fasterxml Jackson-databind 2.7.0 RC2 Version Details Vulnerabilities
7 Application Fasterxml Jackson-databind 2.7.1 Version Details Vulnerabilities
8 Application Fasterxml Jackson-databind 2.7.1-1 Version Details Vulnerabilities
9 Application Fasterxml Jackson-databind 2.7.2 Version Details Vulnerabilities
10 Application Fasterxml Jackson-databind 2.7.3 Version Details Vulnerabilities
11 Application Fasterxml Jackson-databind 2.7.4 Version Details Vulnerabilities
12 Application Fasterxml Jackson-databind 2.7.5 Version Details Vulnerabilities
13 Application Fasterxml Jackson-databind 2.7.6 Version Details Vulnerabilities
14 Application Fasterxml Jackson-databind 2.7.7 Version Details Vulnerabilities
15 Application Fasterxml Jackson-databind 2.7.8 Version Details Vulnerabilities
16 Application Fasterxml Jackson-databind 2.7.9 Version Details Vulnerabilities
17 Application Fasterxml Jackson-databind 2.7.9.1 Version Details Vulnerabilities
18 Application Fasterxml Jackson-databind 2.7.9.2 Version Details Vulnerabilities
19 Application Fasterxml Jackson-databind 2.7.9.3 Version Details Vulnerabilities
20 Application Fasterxml Jackson-databind 2.7.9.4 Version Details Vulnerabilities
21 Application Fasterxml Jackson-databind 2.7.9.5 Version Details Vulnerabilities
22 Application Fasterxml Jackson-databind 2.8.0 Version Details Vulnerabilities
23 Application Fasterxml Jackson-databind 2.8.1 Version Details Vulnerabilities
24 Application Fasterxml Jackson-databind 2.8.2 Version Details Vulnerabilities
25 Application Fasterxml Jackson-databind 2.8.3 Version Details Vulnerabilities
26 Application Fasterxml Jackson-databind 2.8.4 Version Details Vulnerabilities
27 Application Fasterxml Jackson-databind 2.8.5 Version Details Vulnerabilities
28 Application Fasterxml Jackson-databind 2.8.6 Version Details Vulnerabilities
29 Application Fasterxml Jackson-databind 2.8.7 Version Details Vulnerabilities
30 Application Fasterxml Jackson-databind 2.8.8 Version Details Vulnerabilities
31 Application Fasterxml Jackson-databind 2.8.8.1 Version Details Vulnerabilities
32 Application Fasterxml Jackson-databind 2.8.9 Version Details Vulnerabilities
33 Application Fasterxml Jackson-databind 2.8.10 Version Details Vulnerabilities
34 Application Fasterxml Jackson-databind 2.8.11 Version Details Vulnerabilities
35 Application Fasterxml Jackson-databind 2.8.11.1 Version Details Vulnerabilities
36 Application Fasterxml Jackson-databind 2.8.11.2 Version Details Vulnerabilities
37 Application Fasterxml Jackson-databind 2.8.11.3 Version Details Vulnerabilities
38 Application Fasterxml Jackson-databind 2.9.0 Prerelease2 Version Details Vulnerabilities
39 Application Fasterxml Jackson-databind 2.9.0 Prerelease3 Version Details Vulnerabilities
40 Application Fasterxml Jackson-databind 2.9.0 Prerelease4 Version Details Vulnerabilities
41 Application Fasterxml Jackson-databind 2.9.0 Version Details Vulnerabilities
42 Application Fasterxml Jackson-databind 2.9.0 - Version Details Vulnerabilities
43 Application Fasterxml Jackson-databind 2.9.0 Prerelease1 Version Details Vulnerabilities
44 Application Fasterxml Jackson-databind 2.9.1 Version Details Vulnerabilities
45 Application Fasterxml Jackson-databind 2.9.2 Version Details Vulnerabilities
46 Application Fasterxml Jackson-databind 2.9.3 Version Details Vulnerabilities
47 Application Fasterxml Jackson-databind 2.9.4 Version Details Vulnerabilities
48 Application Fasterxml Jackson-databind 2.9.5 Version Details Vulnerabilities
49 Application Fasterxml Jackson-databind 2.9.6 Version Details Vulnerabilities
50 Application Fasterxml Jackson-databind 2.9.7 Version Details Vulnerabilities
51 Application Fasterxml Jackson-databind 2.9.8 Version Details Vulnerabilities
52 Application Fasterxml Jackson-databind 2.9.9 Version Details Vulnerabilities
53 Application Fasterxml Jackson-databind 2.9.9.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 1
Fasterxml Jackson-databind 52

- References For CVE-2019-14439

https://lists.apache.org/thread.html/[email protected]%3Cdev.struts.apache.org%3E
MLIST [struts-dev] 20190908 Build failed in Jenkins: Struts-master-JDK8-dependency-check #204
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190905 [GitHub] [tomee] robert-schaft-hon commented on issue #549: [TOMEE-2655] [7.1.x] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://lists.debian.org/debian-lts-announce/2019/08/msg00011.html
MLIST [debian-lts-announce] 20190812 [SECURITY] [DLA 1879-1] jackson-databind security update
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190905 [GitHub] [tomee] asf-ci commented on issue #549: [TOMEE-2655] [7.1.x] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://security.netapp.com/advisory/ntap-20190814-0001/ CONFIRM
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190909 [GitHub] [tomee] jgallimore merged pull request #548: [TOMEE-2655] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190905 [GitHub] [tomee] rzo1 opened a new pull request #548: [TOMEE-2655] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190905 [GitHub] [tomee] rzo1 opened a new pull request #549: [TOMEE-2655] [7.1.x] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190905 [GitHub] [tomee] asf-ci commented on issue #548: [TOMEE-2655] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190906 [GitHub] [tomee] rzo1 commented on issue #549: [TOMEE-2655] [7.1.x] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://lists.apache.org/thread.html/[email protected]%3Cdev.tomee.apache.org%3E
MLIST [tomee-dev] 20190909 [GitHub] [tomee] jgallimore merged pull request #549: [TOMEE-2655] [7.1.x] Updates jackson-databind to 2.9.9.3 to mitigate CVE-2019-12384, CVE-2019-12814, CVE-2019-14379 and CVE-2019-14439
https://github.com/FasterXML/jackson-databind/commit/ad418eeb974e357f2797aef64aa0e3ffaaa6125b
https://github.com/FasterXML/jackson-databind/compare/jackson-databind-2.9.9.1...jackson-databind-2.9.9.2
https://github.com/FasterXML/jackson-databind/issues/2389

- Metasploit Modules Related To CVE-2019-14439

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.