CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-1020013

parse-server before 3.6.0 allows account enumeration.
Publish Date : 2019-07-29 Last Update Date : 2019-08-01
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 287

- Products Affected By CVE-2019-1020013

# Product Type Vendor Product Version Update Edition Language
1 Application Parseplatform Parse-server - Version Details Vulnerabilities
2 Application Parseplatform Parse-server 2.0.0 Version Details Vulnerabilities
3 Application Parseplatform Parse-server 2.0.1 Version Details Vulnerabilities
4 Application Parseplatform Parse-server 2.0.2 Version Details Vulnerabilities
5 Application Parseplatform Parse-server 2.0.3 Version Details Vulnerabilities
6 Application Parseplatform Parse-server 2.0.4 Version Details Vulnerabilities
7 Application Parseplatform Parse-server 2.0.5 Version Details Vulnerabilities
8 Application Parseplatform Parse-server 2.0.6 Version Details Vulnerabilities
9 Application Parseplatform Parse-server 2.0.7 Version Details Vulnerabilities
10 Application Parseplatform Parse-server 2.0.8 Version Details Vulnerabilities
11 Application Parseplatform Parse-server 2.1.0 Version Details Vulnerabilities
12 Application Parseplatform Parse-server 2.1.1 Version Details Vulnerabilities
13 Application Parseplatform Parse-server 2.1.2 Version Details Vulnerabilities
14 Application Parseplatform Parse-server 2.1.3 Version Details Vulnerabilities
15 Application Parseplatform Parse-server 2.1.4 Version Details Vulnerabilities
16 Application Parseplatform Parse-server 2.1.5 Version Details Vulnerabilities
17 Application Parseplatform Parse-server 2.1.6 Version Details Vulnerabilities
18 Application Parseplatform Parse-server 2.2.0 Version Details Vulnerabilities
19 Application Parseplatform Parse-server 2.2.1 Version Details Vulnerabilities
20 Application Parseplatform Parse-server 2.2.2 Version Details Vulnerabilities
21 Application Parseplatform Parse-server 2.2.3 Version Details Vulnerabilities
22 Application Parseplatform Parse-server 2.2.4 Version Details Vulnerabilities
23 Application Parseplatform Parse-server 2.2.5 Version Details Vulnerabilities
24 Application Parseplatform Parse-server 2.2.6 Version Details Vulnerabilities
25 Application Parseplatform Parse-server 2.2.7 Version Details Vulnerabilities
26 Application Parseplatform Parse-server 2.2.8 Version Details Vulnerabilities
27 Application Parseplatform Parse-server 2.2.9 Version Details Vulnerabilities
28 Application Parseplatform Parse-server 2.2.10 Version Details Vulnerabilities
29 Application Parseplatform Parse-server 2.2.11 Version Details Vulnerabilities
30 Application Parseplatform Parse-server 2.2.12 Version Details Vulnerabilities
31 Application Parseplatform Parse-server 2.2.13 Version Details Vulnerabilities
32 Application Parseplatform Parse-server 2.2.14 Version Details Vulnerabilities
33 Application Parseplatform Parse-server 2.2.15 Version Details Vulnerabilities
34 Application Parseplatform Parse-server 2.2.16 Version Details Vulnerabilities
35 Application Parseplatform Parse-server 2.2.17 Version Details Vulnerabilities
36 Application Parseplatform Parse-server 2.2.18 Version Details Vulnerabilities
37 Application Parseplatform Parse-server 2.2.19 Version Details Vulnerabilities
38 Application Parseplatform Parse-server 2.2.20 Version Details Vulnerabilities
39 Application Parseplatform Parse-server 2.2.21 Version Details Vulnerabilities
40 Application Parseplatform Parse-server 2.2.22 Version Details Vulnerabilities
41 Application Parseplatform Parse-server 2.2.23 Version Details Vulnerabilities
42 Application Parseplatform Parse-server 2.2.24 Version Details Vulnerabilities
43 Application Parseplatform Parse-server 2.2.25 Version Details Vulnerabilities
44 Application Parseplatform Parse-server 2.3.0 Version Details Vulnerabilities
45 Application Parseplatform Parse-server 2.3.1 Version Details Vulnerabilities
46 Application Parseplatform Parse-server 2.3.2 Version Details Vulnerabilities
47 Application Parseplatform Parse-server 2.3.3 Version Details Vulnerabilities
48 Application Parseplatform Parse-server 2.3.4 Version Details Vulnerabilities
49 Application Parseplatform Parse-server 2.3.5 Version Details Vulnerabilities
50 Application Parseplatform Parse-server 2.3.6 Version Details Vulnerabilities
51 Application Parseplatform Parse-server 2.3.7 Version Details Vulnerabilities
52 Application Parseplatform Parse-server 2.3.8 Version Details Vulnerabilities
53 Application Parseplatform Parse-server 2.4.0 Version Details Vulnerabilities
54 Application Parseplatform Parse-server 2.4.1 Version Details Vulnerabilities
55 Application Parseplatform Parse-server 2.4.2 Version Details Vulnerabilities
56 Application Parseplatform Parse-server 2.5.0 Version Details Vulnerabilities
57 Application Parseplatform Parse-server 2.5.1 Version Details Vulnerabilities
58 Application Parseplatform Parse-server 2.5.2 Version Details Vulnerabilities
59 Application Parseplatform Parse-server 2.5.3 Version Details Vulnerabilities
60 Application Parseplatform Parse-server 2.6.0 Version Details Vulnerabilities
61 Application Parseplatform Parse-server 2.6.1 Version Details Vulnerabilities
62 Application Parseplatform Parse-server 2.6.2 Version Details Vulnerabilities
63 Application Parseplatform Parse-server 2.6.3 Version Details Vulnerabilities
64 Application Parseplatform Parse-server 2.6.4 Version Details Vulnerabilities
65 Application Parseplatform Parse-server 2.6.5 Version Details Vulnerabilities
66 Application Parseplatform Parse-server 2.7.0 Version Details Vulnerabilities
67 Application Parseplatform Parse-server 2.7.1 Version Details Vulnerabilities
68 Application Parseplatform Parse-server 2.7.2 Version Details Vulnerabilities
69 Application Parseplatform Parse-server 2.7.3 Version Details Vulnerabilities
70 Application Parseplatform Parse-server 2.7.4 Version Details Vulnerabilities
71 Application Parseplatform Parse-server 2.8.0 Version Details Vulnerabilities
72 Application Parseplatform Parse-server 2.8.1 Version Details Vulnerabilities
73 Application Parseplatform Parse-server 2.8.2 Version Details Vulnerabilities
74 Application Parseplatform Parse-server 2.8.3 Version Details Vulnerabilities
75 Application Parseplatform Parse-server 2.8.4 Version Details Vulnerabilities
76 Application Parseplatform Parse-server 3.0.0 Version Details Vulnerabilities
77 Application Parseplatform Parse-server 3.1.0 Version Details Vulnerabilities
78 Application Parseplatform Parse-server 3.1.1 Version Details Vulnerabilities
79 Application Parseplatform Parse-server 3.1.2 Version Details Vulnerabilities
80 Application Parseplatform Parse-server 3.1.3 Version Details Vulnerabilities
81 Application Parseplatform Parse-server 3.2.0 Version Details Vulnerabilities
82 Application Parseplatform Parse-server 3.2.1 Version Details Vulnerabilities
83 Application Parseplatform Parse-server 3.2.2 Version Details Vulnerabilities
84 Application Parseplatform Parse-server 3.2.3 Version Details Vulnerabilities
85 Application Parseplatform Parse-server 3.3.0 Version Details Vulnerabilities
86 Application Parseplatform Parse-server 3.4.0 Version Details Vulnerabilities
87 Application Parseplatform Parse-server 3.4.1 Version Details Vulnerabilities
88 Application Parseplatform Parse-server 3.4.2 Version Details Vulnerabilities
89 Application Parseplatform Parse-server 3.4.3 Version Details Vulnerabilities
90 Application Parseplatform Parse-server 3.5.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Parseplatform Parse-server 90

- References For CVE-2019-1020013

https://github.com/parse-community/parse-server/security/advisories/GHSA-8w3j-g983-8jh5

- Metasploit Modules Related To CVE-2019-1020013

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.