CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-0201

An issue is present in Apache ZooKeeper 1.0.0 to 3.4.13 and 3.5.0-alpha to 3.5.4-beta. ZooKeeper’s getACL() command doesn’t check any permission when retrieves the ACLs of the requested node and returns all information contained in the ACL Id field as plaintext string. DigestAuthenticationProvider overloads the Id field with the hash value that is used for user authentication. As a consequence, if Digest Authentication is in use, the unsalted hash value will be disclosed by getACL() request for unauthenticated or unprivileged users.
Publish Date : 2019-05-23 Last Update Date : 2021-07-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 862

- Products Affected By CVE-2019-0201

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Zookeeper * * * * Version Details Vulnerabilities
2 Application Apache Zookeeper 3.5.0 - * * Version Details Vulnerabilities
3 Application Apache Zookeeper 3.5.0 Alpha * * Version Details Vulnerabilities
4 Application Apache Zookeeper 3.5.0 RC0 * * Version Details Vulnerabilities
5 Application Apache Zookeeper 3.5.1 RC0 * * Version Details Vulnerabilities
6 Application Apache Zookeeper 3.5.1 RC3 * * Version Details Vulnerabilities
7 Application Apache Zookeeper 3.5.1 RC4 * * Version Details Vulnerabilities
8 Application Apache Zookeeper 3.5.1 - * * Version Details Vulnerabilities
9 Application Apache Zookeeper 3.5.1 RC1 * * Version Details Vulnerabilities
10 Application Apache Zookeeper 3.5.1 RC2 * * Version Details Vulnerabilities
11 Application Apache Zookeeper 3.5.1 Alpha * * Version Details Vulnerabilities
12 Application Apache Zookeeper 3.5.2 Alpha * * Version Details Vulnerabilities
13 Application Apache Zookeeper 3.5.2 RC0 * * Version Details Vulnerabilities
14 Application Apache Zookeeper 3.5.2 RC1 * * Version Details Vulnerabilities
15 Application Apache Zookeeper 3.5.2 - * * Version Details Vulnerabilities
16 Application Apache Zookeeper 3.5.3 RC0 * * Version Details Vulnerabilities
17 Application Apache Zookeeper 3.5.3 - * * Version Details Vulnerabilities
18 Application Apache Zookeeper 3.5.3 RC1 * * Version Details Vulnerabilities
19 Application Apache Zookeeper 3.5.3 Beta * * Version Details Vulnerabilities
20 Application Apache Zookeeper 3.5.4 Beta * * Version Details Vulnerabilities
21 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Zookeeper 20
Debian Debian Linux 1

- References For CVE-2019-0201

https://www.oracle.com/security-alerts/cpuoct2020.html
https://access.redhat.com/errata/RHSA-2019:3140
REDHAT RHSA-2019:3140
https://lists.apache.org/thread.html/[email protected]%3Cdev.drill.apache.org%3E
MLIST [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
https://www.debian.org/security/2019/dsa-4461
DEBIAN DSA-4461
https://lists.apache.org/thread.html/[email protected]%3Cissues.drill.apache.org%3E
MLIST [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
https://access.redhat.com/errata/RHSA-2019:3892
REDHAT RHSA-2019:3892
https://lists.apache.org/thread.html/[email protected]%3Cdev.drill.apache.org%3E
MLIST [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
https://seclists.org/bugtraq/2019/Jun/13
BUGTRAQ 20190612 [SECURITY] [DSA 4461-1] zookeeper security update
https://security.netapp.com/advisory/ntap-20190619-0001/ CONFIRM
https://lists.apache.org/thread.html/[email protected]%3Cissues.activemq.apache.org%3E
MLIST [activemq-issues] 20190820 [jira] [Created] (AMQ-7279) Security Vulnerabilities in Libraries - jackson-databind-2.9.8.jar, tomcat-servlet-api-8.0.53.jar, tomcat-websocket-api-8.0.53.jar, zookeeper-3.4.6.jar, guava-18.0.jar, jetty-all-9.2.26.v20180806.jar, scala-library-2.11.0.jar
https://www.oracle.com/security-alerts/cpujul2020.html
https://access.redhat.com/errata/RHSA-2019:4352
REDHAT RHSA-2019:4352
http://www.securityfocus.com/bid/108427
BID 108427 Apache ZooKeeper CVE-2019-0201 Information Disclosure Vulnerability Release Date:2019-05-20
https://lists.debian.org/debian-lts-announce/2019/05/msg00033.html
MLIST [debian-lts-announce] 20190524 [SECURITY] [DLA 1801-1] zookeeper security update
https://zookeeper.apache.org/security.html#CVE-2019-0201 CONFIRM
https://lists.apache.org/thread.html/[email protected]%3Ccommits.accumulo.apache.org%3E
MLIST [accumulo-commits] 20190605 [accumulo] branch 2.0 updated: Update ZooKeeper (CVE-2019-0201)
https://lists.apache.org/thread.html/[email protected]%3Cissues.bookkeeper.apache.org%3E
MLIST [bookkeeper-issues] 20190531 [GitHub] [bookkeeper] eolivelli opened a new issue #2106: Update ZookKeeper dependency to 3.5.5
https://issues.apache.org/jira/browse/ZOOKEEPER-1392

- Metasploit Modules Related To CVE-2019-0201

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.