CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-0155

Insufficient access control in a subsystem for Intel (R) processor graphics in 6th, 7th, 8th and 9th Generation Intel(R) Core(TM) Processor Families; Intel(R) Pentium(R) Processor J, N, Silver and Gold Series; Intel(R) Celeron(R) Processor J, N, G3900 and G4900 Series; Intel(R) Atom(R) Processor A and E3900 Series; Intel(R) Xeon(R) Processor E3-1500 v5 and v6, E-2100 and E-2200 Processor Families; Intel(R) Graphics Driver for Windows before 26.20.100.6813 (DCH) or 26.20.100.6812 and before 21.20.x.5077 (aka15.45.5077), i915 Linux Driver for Intel(R) Processor Graphics before versions 5.4-rc7, 5.3.11, 4.19.84, 4.14.154, 4.9.201, 4.4.201 may allow an authenticated user to potentially enable escalation of privilege via local access.
Publish Date : 2019-11-14 Last Update Date : 2021-07-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 269

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:3870: kernel-rt security update (Important) oval:com.redhat.rhsa:def:20193870 unix
RHSA-2019:3871: kernel security update (Important) oval:com.redhat.rhsa:def:20193871 unix
RHSA-2019:3872: kernel security update (Important) oval:com.redhat.rhsa:def:20193872 unix
RHSA-2019:3878: kernel security update (Important) oval:com.redhat.rhsa:def:20193878 unix
RHSA-2019:3887: kernel-rt security update (Important) oval:com.redhat.rhsa:def:20193887 unix
RHSA-2020:0204: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20200204 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2019-0155

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
2 Application Intel Graphics Driver * * * * Version Details Vulnerabilities
3 Application Intel Graphics Driver * * * * Version Details Vulnerabilities
4 OS Redhat Enterprise Linux Server Aus 7.2 * * * Version Details Vulnerabilities
5 OS Redhat Enterprise Linux Server Eus 7.5 * * * Version Details Vulnerabilities
6 OS Redhat Enterprise Linux Server Tus 7.2 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 1
Intel Graphics Driver 2
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server Eus 1
Redhat Enterprise Linux Server Tus 1

- References For CVE-2019-0155

https://security.netapp.com/advisory/ntap-20200320-0005/ CONFIRM
https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00242.html
https://usn.ubuntu.com/4186-2/
UBUNTU USN-4186-2
https://support.f5.com/csp/article/K73659122?utm_source=f5support&utm_medium=RSS CONFIRM
https://access.redhat.com/errata/RHSA-2019:3908
REDHAT RHSA-2019:3908
http://packetstormsecurity.com/files/155375/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
https://seclists.org/bugtraq/2019/Nov/26
BUGTRAQ 20191118 [slackware-security] Slackware 14.2 kernel (SSA:2019-320-01)
https://access.redhat.com/errata/RHSA-2019:3841
REDHAT RHSA-2019:3841
https://access.redhat.com/errata/RHSA-2019:3887
REDHAT RHSA-2019:3887
https://access.redhat.com/errata/RHSA-2019:3889
REDHAT RHSA-2019:3889
https://access.redhat.com/errata/RHSA-2020:0204
REDHAT RHSA-2020:0204

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2019-0155

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.