CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-8780

In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters. When using the corresponding method, unintentional directory traversal may be performed.
Publish Date : 2018-04-03 Last Update Date : 2019-07-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Directory traversal
CWE ID 22

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:2028: ruby security update (Moderate) oval:com.redhat.rhsa:def:20192028 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-8780

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 ~~lts~~~ Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 17.10 Version Details Vulnerabilities
4 OS Debian Debian Linux 7.0 Version Details Vulnerabilities
5 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
6 OS Debian Debian Linux 9.0 Version Details Vulnerabilities
7 Application Ruby-lang Ruby - Version Details Vulnerabilities
8 Application Ruby-lang Ruby 1.8 Version Details Vulnerabilities
9 Application Ruby-lang Ruby 1.8.0 Version Details Vulnerabilities
10 Application Ruby-lang Ruby 1.8.1 Preview1 Version Details Vulnerabilities
11 Application Ruby-lang Ruby 1.8.1 Preview2 Version Details Vulnerabilities
12 Application Ruby-lang Ruby 1.8.1 Preview3 Version Details Vulnerabilities
13 Application Ruby-lang Ruby 1.8.1 Preview4 Version Details Vulnerabilities
14 Application Ruby-lang Ruby 1.8.1 Version Details Vulnerabilities
15 Application Ruby-lang Ruby 1.8.2 Preview2 Version Details Vulnerabilities
16 Application Ruby-lang Ruby 1.8.2 Preview3 Version Details Vulnerabilities
17 Application Ruby-lang Ruby 1.8.2 Preview4 Version Details Vulnerabilities
18 Application Ruby-lang Ruby 1.8.2 Version Details Vulnerabilities
19 Application Ruby-lang Ruby 1.8.2 Preview1 Version Details Vulnerabilities
20 Application Ruby-lang Ruby 1.8.3 Preview2 Version Details Vulnerabilities
21 Application Ruby-lang Ruby 1.8.3 Preview3 Version Details Vulnerabilities
22 Application Ruby-lang Ruby 1.8.3 Version Details Vulnerabilities
23 Application Ruby-lang Ruby 1.8.3 Preview1 Version Details Vulnerabilities
24 Application Ruby-lang Ruby 1.8.4 Version Details Vulnerabilities
25 Application Ruby-lang Ruby 1.8.4 Preview1 Version Details Vulnerabilities
26 Application Ruby-lang Ruby 1.8.4 Preview2 Version Details Vulnerabilities
27 Application Ruby-lang Ruby 1.8.5 Preview1 Version Details Vulnerabilities
28 Application Ruby-lang Ruby 1.8.5 Preview2 Version Details Vulnerabilities
29 Application Ruby-lang Ruby 1.8.5 Preview3 Version Details Vulnerabilities
30 Application Ruby-lang Ruby 1.8.5 Preview4 Version Details Vulnerabilities
31 Application Ruby-lang Ruby 1.8.5 Preview5 Version Details Vulnerabilities
32 Application Ruby-lang Ruby 1.8.5 Version Details Vulnerabilities
33 Application Ruby-lang Ruby 1.8.5.1 Version Details Vulnerabilities
34 Application Ruby-lang Ruby 1.8.5.2 Version Details Vulnerabilities
35 Application Ruby-lang Ruby 1.8.5.3 Version Details Vulnerabilities
36 Application Ruby-lang Ruby 1.8.5.4 Version Details Vulnerabilities
37 Application Ruby-lang Ruby 1.8.5.5 Version Details Vulnerabilities
38 Application Ruby-lang Ruby 1.8.5.6 Version Details Vulnerabilities
39 Application Ruby-lang Ruby 1.8.5.7 Version Details Vulnerabilities
40 Application Ruby-lang Ruby 1.8.5.8 Version Details Vulnerabilities
41 Application Ruby-lang Ruby 1.8.5.9 Version Details Vulnerabilities
42 Application Ruby-lang Ruby 1.8.5.10 Version Details Vulnerabilities
43 Application Ruby-lang Ruby 1.8.5.11 Version Details Vulnerabilities
44 Application Ruby-lang Ruby 1.8.5.12 Version Details Vulnerabilities
45 Application Ruby-lang Ruby 1.8.5.13 Version Details Vulnerabilities
46 Application Ruby-lang Ruby 1.8.5.14 Version Details Vulnerabilities
47 Application Ruby-lang Ruby 1.8.5.15 Version Details Vulnerabilities
48 Application Ruby-lang Ruby 1.8.5.16 Version Details Vulnerabilities
49 Application Ruby-lang Ruby 1.8.5.17 Version Details Vulnerabilities
50 Application Ruby-lang Ruby 1.8.5.18 Version Details Vulnerabilities
51 Application Ruby-lang Ruby 1.8.5.19 Version Details Vulnerabilities
52 Application Ruby-lang Ruby 1.8.5.20 Version Details Vulnerabilities
53 Application Ruby-lang Ruby 1.8.5.21 Version Details Vulnerabilities
54 Application Ruby-lang Ruby 1.8.5.22 Version Details Vulnerabilities
55 Application Ruby-lang Ruby 1.8.5.23 Version Details Vulnerabilities
56 Application Ruby-lang Ruby 1.8.5.24 Version Details Vulnerabilities
57 Application Ruby-lang Ruby 1.8.5.25 Version Details Vulnerabilities
58 Application Ruby-lang Ruby 1.8.5.26 Version Details Vulnerabilities
59 Application Ruby-lang Ruby 1.8.5.27 Version Details Vulnerabilities
60 Application Ruby-lang Ruby 1.8.5.28 Version Details Vulnerabilities
61 Application Ruby-lang Ruby 1.8.5.29 Version Details Vulnerabilities
62 Application Ruby-lang Ruby 1.8.5.30 Version Details Vulnerabilities
63 Application Ruby-lang Ruby 1.8.5.31 Version Details Vulnerabilities
64 Application Ruby-lang Ruby 1.8.5.32 Version Details Vulnerabilities
65 Application Ruby-lang Ruby 1.8.5.33 Version Details Vulnerabilities
66 Application Ruby-lang Ruby 1.8.5.34 Version Details Vulnerabilities
67 Application Ruby-lang Ruby 1.8.5.35 Version Details Vulnerabilities
68 Application Ruby-lang Ruby 1.8.5.36 Version Details Vulnerabilities
69 Application Ruby-lang Ruby 1.8.5.37 Version Details Vulnerabilities
70 Application Ruby-lang Ruby 1.8.5.39 Version Details Vulnerabilities
71 Application Ruby-lang Ruby 1.8.5.40 Version Details Vulnerabilities
72 Application Ruby-lang Ruby 1.8.5.41 Version Details Vulnerabilities
73 Application Ruby-lang Ruby 1.8.5.42 Version Details Vulnerabilities
74 Application Ruby-lang Ruby 1.8.5.43 Version Details Vulnerabilities
75 Application Ruby-lang Ruby 1.8.5.44 Version Details Vulnerabilities
76 Application Ruby-lang Ruby 1.8.5.45 Version Details Vulnerabilities
77 Application Ruby-lang Ruby 1.8.5.46 Version Details Vulnerabilities
78 Application Ruby-lang Ruby 1.8.5.47 Version Details Vulnerabilities
79 Application Ruby-lang Ruby 1.8.5.48 Version Details Vulnerabilities
80 Application Ruby-lang Ruby 1.8.5.49 Version Details Vulnerabilities
81 Application Ruby-lang Ruby 1.8.5.51 Version Details Vulnerabilities
82 Application Ruby-lang Ruby 1.8.5.52 Version Details Vulnerabilities
83 Application Ruby-lang Ruby 1.8.5.53 Version Details Vulnerabilities
84 Application Ruby-lang Ruby 1.8.5.54 Version Details Vulnerabilities
85 Application Ruby-lang Ruby 1.8.5.55 Version Details Vulnerabilities
86 Application Ruby-lang Ruby 1.8.5.56 Version Details Vulnerabilities
87 Application Ruby-lang Ruby 1.8.5.57 Version Details Vulnerabilities
88 Application Ruby-lang Ruby 1.8.5.58 Version Details Vulnerabilities
89 Application Ruby-lang Ruby 1.8.5.59 Version Details Vulnerabilities
90 Application Ruby-lang Ruby 1.8.5.60 Version Details Vulnerabilities
91 Application Ruby-lang Ruby 1.8.5.61 Version Details Vulnerabilities
92 Application Ruby-lang Ruby 1.8.5.62 Version Details Vulnerabilities
93 Application Ruby-lang Ruby 1.8.5.63 Version Details Vulnerabilities
94 Application Ruby-lang Ruby 1.8.5.64 Version Details Vulnerabilities
95 Application Ruby-lang Ruby 1.8.5.65 Version Details Vulnerabilities
96 Application Ruby-lang Ruby 1.8.5.66 Version Details Vulnerabilities
97 Application Ruby-lang Ruby 1.8.5.67 Version Details Vulnerabilities
98 Application Ruby-lang Ruby 1.8.5.68 Version Details Vulnerabilities
99 Application Ruby-lang Ruby 1.8.5.69 Version Details Vulnerabilities
100 Application Ruby-lang Ruby 1.8.5.70 Version Details Vulnerabilities
101 Application Ruby-lang Ruby 1.8.5.71 Version Details Vulnerabilities
102 Application Ruby-lang Ruby 1.8.5.72 Version Details Vulnerabilities
103 Application Ruby-lang Ruby 1.8.5.73 Version Details Vulnerabilities
104 Application Ruby-lang Ruby 1.8.5.74 Version Details Vulnerabilities
105 Application Ruby-lang Ruby 1.8.5.75 Version Details Vulnerabilities
106 Application Ruby-lang Ruby 1.8.5.76 Version Details Vulnerabilities
107 Application Ruby-lang Ruby 1.8.5.77 Version Details Vulnerabilities
108 Application Ruby-lang Ruby 1.8.5.78 Version Details Vulnerabilities
109 Application Ruby-lang Ruby 1.8.5.79 Version Details Vulnerabilities
110 Application Ruby-lang Ruby 1.8.5.80 Version Details Vulnerabilities
111 Application Ruby-lang Ruby 1.8.5.81 Version Details Vulnerabilities
112 Application Ruby-lang Ruby 1.8.5.82 Version Details Vulnerabilities
113 Application Ruby-lang Ruby 1.8.5.83 Version Details Vulnerabilities
114 Application Ruby-lang Ruby 1.8.5.84 Version Details Vulnerabilities
115 Application Ruby-lang Ruby 1.8.5.85 Version Details Vulnerabilities
116 Application Ruby-lang Ruby 1.8.5.86 Version Details Vulnerabilities
117 Application Ruby-lang Ruby 1.8.5.87 Version Details Vulnerabilities
118 Application Ruby-lang Ruby 1.8.5.88 Version Details Vulnerabilities
119 Application Ruby-lang Ruby 1.8.5.89 Version Details Vulnerabilities
120 Application Ruby-lang Ruby 1.8.5.90 Version Details Vulnerabilities
121 Application Ruby-lang Ruby 1.8.5.91 Version Details Vulnerabilities
122 Application Ruby-lang Ruby 1.8.5.92 Version Details Vulnerabilities
123 Application Ruby-lang Ruby 1.8.5.93 Version Details Vulnerabilities
124 Application Ruby-lang Ruby 1.8.5.94 Version Details Vulnerabilities
125 Application Ruby-lang Ruby 1.8.5.95 Version Details Vulnerabilities
126 Application Ruby-lang Ruby 1.8.5.96 Version Details Vulnerabilities
127 Application Ruby-lang Ruby 1.8.5.97 Version Details Vulnerabilities
128 Application Ruby-lang Ruby 1.8.5.98 Version Details Vulnerabilities
129 Application Ruby-lang Ruby 1.8.5.99 Version Details Vulnerabilities
130 Application Ruby-lang Ruby 1.8.5.100 Version Details Vulnerabilities
131 Application Ruby-lang Ruby 1.8.5.101 Version Details Vulnerabilities
132 Application Ruby-lang Ruby 1.8.5.102 Version Details Vulnerabilities
133 Application Ruby-lang Ruby 1.8.5.103 Version Details Vulnerabilities
134 Application Ruby-lang Ruby 1.8.5.104 Version Details Vulnerabilities
135 Application Ruby-lang Ruby 1.8.5.105 Version Details Vulnerabilities
136 Application Ruby-lang Ruby 1.8.5.106 Version Details Vulnerabilities
137 Application Ruby-lang Ruby 1.8.5.107 Version Details Vulnerabilities
138 Application Ruby-lang Ruby 1.8.5.108 Version Details Vulnerabilities
139 Application Ruby-lang Ruby 1.8.5.109 Version Details Vulnerabilities
140 Application Ruby-lang Ruby 1.8.5.110 Version Details Vulnerabilities
141 Application Ruby-lang Ruby 1.8.5.111 Version Details Vulnerabilities
142 Application Ruby-lang Ruby 1.8.5.113 Version Details Vulnerabilities
143 Application Ruby-lang Ruby 1.8.5.114 Version Details Vulnerabilities
144 Application Ruby-lang Ruby 1.8.5.115 Version Details Vulnerabilities
145 Application Ruby-lang Ruby 1.8.5.116 Version Details Vulnerabilities
146 Application Ruby-lang Ruby 1.8.5.122 Version Details Vulnerabilities
147 Application Ruby-lang Ruby 1.8.5.123 Version Details Vulnerabilities
148 Application Ruby-lang Ruby 1.8.5.124 Version Details Vulnerabilities
149 Application Ruby-lang Ruby 1.8.5.125 Version Details Vulnerabilities
150 Application Ruby-lang Ruby 1.8.5.126 Version Details Vulnerabilities
151 Application Ruby-lang Ruby 1.8.5.127 Version Details Vulnerabilities
152 Application Ruby-lang Ruby 1.8.5.128 Version Details Vulnerabilities
153 Application Ruby-lang Ruby 1.8.5.129 Version Details Vulnerabilities
154 Application Ruby-lang Ruby 1.8.5.130 Version Details Vulnerabilities
155 Application Ruby-lang Ruby 1.8.5.131 Version Details Vulnerabilities
156 Application Ruby-lang Ruby 1.8.5.132 Version Details Vulnerabilities
157 Application Ruby-lang Ruby 1.8.5.133 Version Details Vulnerabilities
158 Application Ruby-lang Ruby 1.8.5.134 Version Details Vulnerabilities
159 Application Ruby-lang Ruby 1.8.5.135 Version Details Vulnerabilities
160 Application Ruby-lang Ruby 1.8.5.136 Version Details Vulnerabilities
161 Application Ruby-lang Ruby 1.8.5.137 Version Details Vulnerabilities
162 Application Ruby-lang Ruby 1.8.5.138 Version Details Vulnerabilities
163 Application Ruby-lang Ruby 1.8.5.139 Version Details Vulnerabilities
164 Application Ruby-lang Ruby 1.8.5.140 Version Details Vulnerabilities
165 Application Ruby-lang Ruby 1.8.5.141 Version Details Vulnerabilities
166 Application Ruby-lang Ruby 1.8.5.142 Version Details Vulnerabilities
167 Application Ruby-lang Ruby 1.8.5.145 Version Details Vulnerabilities
168 Application Ruby-lang Ruby 1.8.5.146 Version Details Vulnerabilities
169 Application Ruby-lang Ruby 1.8.5.147 Version Details Vulnerabilities
170 Application Ruby-lang Ruby 1.8.5.148 Version Details Vulnerabilities
171 Application Ruby-lang Ruby 1.8.5.149 Version Details Vulnerabilities
172 Application Ruby-lang Ruby 1.8.5.150 Version Details Vulnerabilities
173 Application Ruby-lang Ruby 1.8.5.151 Version Details Vulnerabilities
174 Application Ruby-lang Ruby 1.8.5.153 Version Details Vulnerabilities
175 Application Ruby-lang Ruby 1.8.5.154 Version Details Vulnerabilities
176 Application Ruby-lang Ruby 1.8.5.155 Version Details Vulnerabilities
177 Application Ruby-lang Ruby 1.8.5.156 Version Details Vulnerabilities
178 Application Ruby-lang Ruby 1.8.5.157 Version Details Vulnerabilities
179 Application Ruby-lang Ruby 1.8.5.158 Version Details Vulnerabilities
180 Application Ruby-lang Ruby 1.8.5.159 Version Details Vulnerabilities
181 Application Ruby-lang Ruby 1.8.5.160 Version Details Vulnerabilities
182 Application Ruby-lang Ruby 1.8.5.161 Version Details Vulnerabilities
183 Application Ruby-lang Ruby 1.8.5.162 Version Details Vulnerabilities
184 Application Ruby-lang Ruby 1.8.5.163 Version Details Vulnerabilities
185 Application Ruby-lang Ruby 1.8.5.164 Version Details Vulnerabilities
186 Application Ruby-lang Ruby 1.8.5.165 Version Details Vulnerabilities
187 Application Ruby-lang Ruby 1.8.5.166 Version Details Vulnerabilities
188 Application Ruby-lang Ruby 1.8.5.167 Version Details Vulnerabilities
189 Application Ruby-lang Ruby 1.8.5.168 Version Details Vulnerabilities
190 Application Ruby-lang Ruby 1.8.5.169 Version Details Vulnerabilities
191 Application Ruby-lang Ruby 1.8.5.170 Version Details Vulnerabilities
192 Application Ruby-lang Ruby 1.8.5.171 Version Details Vulnerabilities
193 Application Ruby-lang Ruby 1.8.5.172 Version Details Vulnerabilities
194 Application Ruby-lang Ruby 1.8.5.173 Version Details Vulnerabilities
195 Application Ruby-lang Ruby 1.8.5.174 Version Details Vulnerabilities
196 Application Ruby-lang Ruby 1.8.5.175 Version Details Vulnerabilities
197 Application Ruby-lang Ruby 1.8.5.176 Version Details Vulnerabilities
198 Application Ruby-lang Ruby 1.8.5.177 Version Details Vulnerabilities
199 Application Ruby-lang Ruby 1.8.5.178 Version Details Vulnerabilities
200 Application Ruby-lang Ruby 1.8.5.179 Version Details Vulnerabilities
201 Application Ruby-lang Ruby 1.8.5.180 Version Details Vulnerabilities
202 Application Ruby-lang Ruby 1.8.5.181 Version Details Vulnerabilities
203 Application Ruby-lang Ruby 1.8.5.182 Version Details Vulnerabilities
204 Application Ruby-lang Ruby 1.8.5.183 Version Details Vulnerabilities
205 Application Ruby-lang Ruby 1.8.5.184 Version Details Vulnerabilities
206 Application Ruby-lang Ruby 1.8.5.185 Version Details Vulnerabilities
207 Application Ruby-lang Ruby 1.8.5.186 Version Details Vulnerabilities
208 Application Ruby-lang Ruby 1.8.5.187 Version Details Vulnerabilities
209 Application Ruby-lang Ruby 1.8.5.188 Version Details Vulnerabilities
210 Application Ruby-lang Ruby 1.8.5.189 Version Details Vulnerabilities
211 Application Ruby-lang Ruby 1.8.5.190 Version Details Vulnerabilities
212 Application Ruby-lang Ruby 1.8.5.191 Version Details Vulnerabilities
213 Application Ruby-lang Ruby 1.8.5.192 Version Details Vulnerabilities
214 Application Ruby-lang Ruby 1.8.5.193 Version Details Vulnerabilities
215 Application Ruby-lang Ruby 1.8.5.194 Version Details Vulnerabilities
216 Application Ruby-lang Ruby 1.8.5.195 Version Details Vulnerabilities
217 Application Ruby-lang Ruby 1.8.5.196 Version Details Vulnerabilities
218 Application Ruby-lang Ruby 1.8.5.197 Version Details Vulnerabilities
219 Application Ruby-lang Ruby 1.8.5.198 Version Details Vulnerabilities
220 Application Ruby-lang Ruby 1.8.5.199 Version Details Vulnerabilities
221 Application Ruby-lang Ruby 1.8.5.200 Version Details Vulnerabilities
222 Application Ruby-lang Ruby 1.8.5.201 Version Details Vulnerabilities
223 Application Ruby-lang Ruby 1.8.5.202 Version Details Vulnerabilities
224 Application Ruby-lang Ruby 1.8.5.203 Version Details Vulnerabilities
225 Application Ruby-lang Ruby 1.8.5.204 Version Details Vulnerabilities
226 Application Ruby-lang Ruby 1.8.5.205 Version Details Vulnerabilities
227 Application Ruby-lang Ruby 1.8.5.206 Version Details Vulnerabilities
228 Application Ruby-lang Ruby 1.8.5.207 Version Details Vulnerabilities
229 Application Ruby-lang Ruby 1.8.5.208 Version Details Vulnerabilities
230 Application Ruby-lang Ruby 1.8.5.209 Version Details Vulnerabilities
231 Application Ruby-lang Ruby 1.8.5.210 Version Details Vulnerabilities
232 Application Ruby-lang Ruby 1.8.5.211 Version Details Vulnerabilities
233 Application Ruby-lang Ruby 1.8.5.212 Version Details Vulnerabilities
234 Application Ruby-lang Ruby 1.8.5.213 Version Details Vulnerabilities
235 Application Ruby-lang Ruby 1.8.5.214 Version Details Vulnerabilities
236 Application Ruby-lang Ruby 1.8.5.215 Version Details Vulnerabilities
237 Application Ruby-lang Ruby 1.8.5.216 Version Details Vulnerabilities
238 Application Ruby-lang Ruby 1.8.5.217 Version Details Vulnerabilities
239 Application Ruby-lang Ruby 1.8.5.218 Version Details Vulnerabilities
240 Application Ruby-lang Ruby 1.8.5.219 Version Details Vulnerabilities
241 Application Ruby-lang Ruby 1.8.5.220 Version Details Vulnerabilities
242 Application Ruby-lang Ruby 1.8.5.221 Version Details Vulnerabilities
243 Application Ruby-lang Ruby 1.8.5.222 Version Details Vulnerabilities
244 Application Ruby-lang Ruby 1.8.5.223 Version Details Vulnerabilities
245 Application Ruby-lang Ruby 1.8.5.224 Version Details Vulnerabilities
246 Application Ruby-lang Ruby 1.8.5.225 Version Details Vulnerabilities
247 Application Ruby-lang Ruby 1.8.5.226 Version Details Vulnerabilities
248 Application Ruby-lang Ruby 1.8.5.227 Version Details Vulnerabilities
249 Application Ruby-lang Ruby 1.8.5.228 Version Details Vulnerabilities
250 Application Ruby-lang Ruby 1.8.5.229 Version Details Vulnerabilities
251 Application Ruby-lang Ruby 1.8.5.230 Version Details Vulnerabilities
252 Application Ruby-lang Ruby 1.8.5.231 Version Details Vulnerabilities
253 Application Ruby-lang Ruby 1.8.5.254 Version Details Vulnerabilities
254 Application Ruby-lang Ruby 1.8.5.265 Version Details Vulnerabilities
255 Application Ruby-lang Ruby 1.8.6 Preview3 Version Details Vulnerabilities
256 Application Ruby-lang Ruby 1.8.6-26 Version Details Vulnerabilities
257 Application Ruby-lang Ruby 1.8.6 Version Details Vulnerabilities
258 Application Ruby-lang Ruby 1.8.6 Preview1 Version Details Vulnerabilities
259 Application Ruby-lang Ruby 1.8.6 Preview2 Version Details Vulnerabilities
260 Application Ruby-lang Ruby 1.8.6.1 Version Details Vulnerabilities
261 Application Ruby-lang Ruby 1.8.6.2 Version Details Vulnerabilities
262 Application Ruby-lang Ruby 1.8.6.4 Version Details Vulnerabilities
263 Application Ruby-lang Ruby 1.8.6.5 Version Details Vulnerabilities
264 Application Ruby-lang Ruby 1.8.6.6 Version Details Vulnerabilities
265 Application Ruby-lang Ruby 1.8.6.7 Version Details Vulnerabilities
266 Application Ruby-lang Ruby 1.8.6.8 Version Details Vulnerabilities
267 Application Ruby-lang Ruby 1.8.6.9 Version Details Vulnerabilities
268 Application Ruby-lang Ruby 1.8.6.10 Version Details Vulnerabilities
269 Application Ruby-lang Ruby 1.8.6.12 Version Details Vulnerabilities
270 Application Ruby-lang Ruby 1.8.6.13 Version Details Vulnerabilities
271 Application Ruby-lang Ruby 1.8.6.14 Version Details Vulnerabilities
272 Application Ruby-lang Ruby 1.8.6.15 Version Details Vulnerabilities
273 Application Ruby-lang Ruby 1.8.6.16 Version Details Vulnerabilities
274 Application Ruby-lang Ruby 1.8.6.17 Version Details Vulnerabilities
275 Application Ruby-lang Ruby 1.8.6.18 Version Details Vulnerabilities
276 Application Ruby-lang Ruby 1.8.6.19 Version Details Vulnerabilities
277 Application Ruby-lang Ruby 1.8.6.20 Version Details Vulnerabilities
278 Application Ruby-lang Ruby 1.8.6.21 Version Details Vulnerabilities
279 Application Ruby-lang Ruby 1.8.6.22 Version Details Vulnerabilities
280 Application Ruby-lang Ruby 1.8.6.23 Version Details Vulnerabilities
281 Application Ruby-lang Ruby 1.8.6.24 Version Details Vulnerabilities
282 Application Ruby-lang Ruby 1.8.6.25 Version Details Vulnerabilities
283 Application Ruby-lang Ruby 1.8.6.26 Version Details Vulnerabilities
284 Application Ruby-lang Ruby 1.8.6.27 Version Details Vulnerabilities
285 Application Ruby-lang Ruby 1.8.6.30 Version Details Vulnerabilities
286 Application Ruby-lang Ruby 1.8.6.31 Version Details Vulnerabilities
287 Application Ruby-lang Ruby 1.8.6.32 Version Details Vulnerabilities
288 Application Ruby-lang Ruby 1.8.6.33 Version Details Vulnerabilities
289 Application Ruby-lang Ruby 1.8.6.34 Version Details Vulnerabilities
290 Application Ruby-lang Ruby 1.8.6.35 Version Details Vulnerabilities
291 Application Ruby-lang Ruby 1.8.6.36 Version Details Vulnerabilities
292 Application Ruby-lang Ruby 1.8.6.37 Version Details Vulnerabilities
293 Application Ruby-lang Ruby 1.8.6.38 Version Details Vulnerabilities
294 Application Ruby-lang Ruby 1.8.6.39 Version Details Vulnerabilities
295 Application Ruby-lang Ruby 1.8.6.40 Version Details Vulnerabilities
296 Application Ruby-lang Ruby 1.8.6.41 Version Details Vulnerabilities
297 Application Ruby-lang Ruby 1.8.6.42 Version Details Vulnerabilities
298 Application Ruby-lang Ruby 1.8.6.43 Version Details Vulnerabilities
299 Application Ruby-lang Ruby 1.8.6.44 Version Details Vulnerabilities
300 Application Ruby-lang Ruby 1.8.6.45 Version Details Vulnerabilities
301 Application Ruby-lang Ruby 1.8.6.46 Version Details Vulnerabilities
302 Application Ruby-lang Ruby 1.8.6.47 Version Details Vulnerabilities
303 Application Ruby-lang Ruby 1.8.6.48 Version Details Vulnerabilities
304 Application Ruby-lang Ruby 1.8.6.49 Version Details Vulnerabilities
305 Application Ruby-lang Ruby 1.8.6.50 Version Details Vulnerabilities
306 Application Ruby-lang Ruby 1.8.6.51 Version Details Vulnerabilities
307 Application Ruby-lang Ruby 1.8.6.52 Version Details Vulnerabilities
308 Application Ruby-lang Ruby 1.8.6.53 Version Details Vulnerabilities
309 Application Ruby-lang Ruby 1.8.6.54 Version Details Vulnerabilities
310 Application Ruby-lang Ruby 1.8.6.55 Version Details Vulnerabilities
311 Application Ruby-lang Ruby 1.8.6.56 Version Details Vulnerabilities
312 Application Ruby-lang Ruby 1.8.6.57 Version Details Vulnerabilities
313 Application Ruby-lang Ruby 1.8.6.58 Version Details Vulnerabilities
314 Application Ruby-lang Ruby 1.8.6.59 Version Details Vulnerabilities
315 Application Ruby-lang Ruby 1.8.6.60 Version Details Vulnerabilities
316 Application Ruby-lang Ruby 1.8.6.63 Version Details Vulnerabilities
317 Application Ruby-lang Ruby 1.8.6.64 Version Details Vulnerabilities
318 Application Ruby-lang Ruby 1.8.6.65 Version Details Vulnerabilities
319 Application Ruby-lang Ruby 1.8.6.66 Version Details Vulnerabilities
320 Application Ruby-lang Ruby 1.8.6.67 Version Details Vulnerabilities
321 Application Ruby-lang Ruby 1.8.6.68 Version Details Vulnerabilities
322 Application Ruby-lang Ruby 1.8.6.69 Version Details Vulnerabilities
323 Application Ruby-lang Ruby 1.8.6.70 Version Details Vulnerabilities
324 Application Ruby-lang Ruby 1.8.6.72 Version Details Vulnerabilities
325 Application Ruby-lang Ruby 1.8.6.73 Version Details Vulnerabilities
326 Application Ruby-lang Ruby 1.8.6.74 Version Details Vulnerabilities
327 Application Ruby-lang Ruby 1.8.6.75 Version Details Vulnerabilities
328 Application Ruby-lang Ruby 1.8.6.76 Version Details Vulnerabilities
329 Application Ruby-lang Ruby 1.8.6.77 Version Details Vulnerabilities
330 Application Ruby-lang Ruby 1.8.6.78 Version Details Vulnerabilities
331 Application Ruby-lang Ruby 1.8.6.79 Version Details Vulnerabilities
332 Application Ruby-lang Ruby 1.8.6.80 Version Details Vulnerabilities
333 Application Ruby-lang Ruby 1.8.6.81 Version Details Vulnerabilities
334 Application Ruby-lang Ruby 1.8.6.82 Version Details Vulnerabilities
335 Application Ruby-lang Ruby 1.8.6.83 Version Details Vulnerabilities
336 Application Ruby-lang Ruby 1.8.6.84 Version Details Vulnerabilities
337 Application Ruby-lang Ruby 1.8.6.85 Version Details Vulnerabilities
338 Application Ruby-lang Ruby 1.8.6.86 Version Details Vulnerabilities
339 Application Ruby-lang Ruby 1.8.6.87 Version Details Vulnerabilities
340 Application Ruby-lang Ruby 1.8.6.88 Version Details Vulnerabilities
341 Application Ruby-lang Ruby 1.8.6.89 Version Details Vulnerabilities
342 Application Ruby-lang Ruby 1.8.6.90 Version Details Vulnerabilities
343 Application Ruby-lang Ruby 1.8.6.91 Version Details Vulnerabilities
344 Application Ruby-lang Ruby 1.8.6.92 Version Details Vulnerabilities
345 Application Ruby-lang Ruby 1.8.6.93 Version Details Vulnerabilities
346 Application Ruby-lang Ruby 1.8.6.94 Version Details Vulnerabilities
347 Application Ruby-lang Ruby 1.8.6.95 Version Details Vulnerabilities
348 Application Ruby-lang Ruby 1.8.6.96 Version Details Vulnerabilities
349 Application Ruby-lang Ruby 1.8.6.97 Version Details Vulnerabilities
350 Application Ruby-lang Ruby 1.8.6.98 Version Details Vulnerabilities
351 Application Ruby-lang Ruby 1.8.6.99 Version Details Vulnerabilities
352 Application Ruby-lang Ruby 1.8.6.100 Version Details Vulnerabilities
353 Application Ruby-lang Ruby 1.8.6.101 Version Details Vulnerabilities
354 Application Ruby-lang Ruby 1.8.6.102 Version Details Vulnerabilities
355 Application Ruby-lang Ruby 1.8.6.103 Version Details Vulnerabilities
356 Application Ruby-lang Ruby 1.8.6.104 Version Details Vulnerabilities
357 Application Ruby-lang Ruby 1.8.6.105 Version Details Vulnerabilities
358 Application Ruby-lang Ruby 1.8.6.106 Version Details Vulnerabilities
359 Application Ruby-lang Ruby 1.8.6.107 Version Details Vulnerabilities
360 Application Ruby-lang Ruby 1.8.6.109 Version Details Vulnerabilities
361 Application Ruby-lang Ruby 1.8.6.110 Version Details Vulnerabilities
362 Application Ruby-lang Ruby 1.8.6.111 Version Details Vulnerabilities
363 Application Ruby-lang Ruby 1.8.6.112 Version Details Vulnerabilities
364 Application Ruby-lang Ruby 1.8.6.113 Version Details Vulnerabilities
365 Application Ruby-lang Ruby 1.8.6.114 Version Details Vulnerabilities
366 Application Ruby-lang Ruby 1.8.6.115 Version Details Vulnerabilities
367 Application Ruby-lang Ruby 1.8.6.121 Version Details Vulnerabilities
368 Application Ruby-lang Ruby 1.8.6.122 Version Details Vulnerabilities
369 Application Ruby-lang Ruby 1.8.6.123 Version Details Vulnerabilities
370 Application Ruby-lang Ruby 1.8.6.124 Version Details Vulnerabilities
371 Application Ruby-lang Ruby 1.8.6.125 Version Details Vulnerabilities
372 Application Ruby-lang Ruby 1.8.6.126 Version Details Vulnerabilities
373 Application Ruby-lang Ruby 1.8.6.127 Version Details Vulnerabilities
374 Application Ruby-lang Ruby 1.8.6.128 Version Details Vulnerabilities
375 Application Ruby-lang Ruby 1.8.6.129 Version Details Vulnerabilities
376 Application Ruby-lang Ruby 1.8.6.130 Version Details Vulnerabilities
377 Application Ruby-lang Ruby 1.8.6.131 Version Details Vulnerabilities
378 Application Ruby-lang Ruby 1.8.6.132 Version Details Vulnerabilities
379 Application Ruby-lang Ruby 1.8.6.133 Version Details Vulnerabilities
380 Application Ruby-lang Ruby 1.8.6.134 Version Details Vulnerabilities
381 Application Ruby-lang Ruby 1.8.6.135 Version Details Vulnerabilities
382 Application Ruby-lang Ruby 1.8.6.136 Version Details Vulnerabilities
383 Application Ruby-lang Ruby 1.8.6.137 Version Details Vulnerabilities
384 Application Ruby-lang Ruby 1.8.6.138 Version Details Vulnerabilities
385 Application Ruby-lang Ruby 1.8.6.139 Version Details Vulnerabilities
386 Application Ruby-lang Ruby 1.8.6.140 Version Details Vulnerabilities
387 Application Ruby-lang Ruby 1.8.6.141 Version Details Vulnerabilities
388 Application Ruby-lang Ruby 1.8.6.144 Version Details Vulnerabilities
389 Application Ruby-lang Ruby 1.8.6.145 Version Details Vulnerabilities
390 Application Ruby-lang Ruby 1.8.6.146 Version Details Vulnerabilities
391 Application Ruby-lang Ruby 1.8.6.147 Version Details Vulnerabilities
392 Application Ruby-lang Ruby 1.8.6.148 Version Details Vulnerabilities
393 Application Ruby-lang Ruby 1.8.6.149 Version Details Vulnerabilities
394 Application Ruby-lang Ruby 1.8.6.150 Version Details Vulnerabilities
395 Application Ruby-lang Ruby 1.8.6.151 Version Details Vulnerabilities
396 Application Ruby-lang Ruby 1.8.6.153 Version Details Vulnerabilities
397 Application Ruby-lang Ruby 1.8.6.154 Version Details Vulnerabilities
398 Application Ruby-lang Ruby 1.8.6.155 Version Details Vulnerabilities
399 Application Ruby-lang Ruby 1.8.6.156 Version Details Vulnerabilities
400 Application Ruby-lang Ruby 1.8.6.157 Version Details Vulnerabilities
401 Application Ruby-lang Ruby 1.8.6.158 Version Details Vulnerabilities
402 Application Ruby-lang Ruby 1.8.6.159 Version Details Vulnerabilities
403 Application Ruby-lang Ruby 1.8.6.160 Version Details Vulnerabilities
404 Application Ruby-lang Ruby 1.8.6.161 Version Details Vulnerabilities
405 Application Ruby-lang Ruby 1.8.6.162 Version Details Vulnerabilities
406 Application Ruby-lang Ruby 1.8.6.163 Version Details Vulnerabilities
407 Application Ruby-lang Ruby 1.8.6.164 Version Details Vulnerabilities
408 Application Ruby-lang Ruby 1.8.6.165 Version Details Vulnerabilities
409 Application Ruby-lang Ruby 1.8.6.166 Version Details Vulnerabilities
410 Application Ruby-lang Ruby 1.8.6.167 Version Details Vulnerabilities
411 Application Ruby-lang Ruby 1.8.6.168 Version Details Vulnerabilities
412 Application Ruby-lang Ruby 1.8.6.169 Version Details Vulnerabilities
413 Application Ruby-lang Ruby 1.8.6.170 Version Details Vulnerabilities
414 Application Ruby-lang Ruby 1.8.6.171 Version Details Vulnerabilities
415 Application Ruby-lang Ruby 1.8.6.172 Version Details Vulnerabilities
416 Application Ruby-lang Ruby 1.8.6.173 Version Details Vulnerabilities
417 Application Ruby-lang Ruby 1.8.6.174 Version Details Vulnerabilities
418 Application Ruby-lang Ruby 1.8.6.175 Version Details Vulnerabilities
419 Application Ruby-lang Ruby 1.8.6.176 Version Details Vulnerabilities
420 Application Ruby-lang Ruby 1.8.6.177 Version Details Vulnerabilities
421 Application Ruby-lang Ruby 1.8.6.178 Version Details Vulnerabilities
422 Application Ruby-lang Ruby 1.8.6.179 Version Details Vulnerabilities
423 Application Ruby-lang Ruby 1.8.6.180 Version Details Vulnerabilities
424 Application Ruby-lang Ruby 1.8.6.181 Version Details Vulnerabilities
425 Application Ruby-lang Ruby 1.8.6.182 Version Details Vulnerabilities
426 Application Ruby-lang Ruby 1.8.6.183 Version Details Vulnerabilities
427 Application Ruby-lang Ruby 1.8.6.184 Version Details Vulnerabilities
428 Application Ruby-lang Ruby 1.8.6.185 Version Details Vulnerabilities
429 Application Ruby-lang Ruby 1.8.6.186 Version Details Vulnerabilities
430 Application Ruby-lang Ruby 1.8.6.187 Version Details Vulnerabilities
431 Application Ruby-lang Ruby 1.8.6.188 Version Details Vulnerabilities
432 Application Ruby-lang Ruby 1.8.6.189 Version Details Vulnerabilities
433 Application Ruby-lang Ruby 1.8.6.190 Version Details Vulnerabilities
434 Application Ruby-lang Ruby 1.8.6.191 Version Details Vulnerabilities
435 Application Ruby-lang Ruby 1.8.6.192 Version Details Vulnerabilities
436 Application Ruby-lang Ruby 1.8.6.193 Version Details Vulnerabilities
437 Application Ruby-lang Ruby 1.8.6.194 Version Details Vulnerabilities
438 Application Ruby-lang Ruby 1.8.6.195 Version Details Vulnerabilities
439 Application Ruby-lang Ruby 1.8.6.196 Version Details Vulnerabilities
440 Application Ruby-lang Ruby 1.8.6.197 Version Details Vulnerabilities
441 Application Ruby-lang Ruby 1.8.6.198 Version Details Vulnerabilities
442 Application Ruby-lang Ruby 1.8.6.199 Version Details Vulnerabilities
443 Application Ruby-lang Ruby 1.8.6.200 Version Details Vulnerabilities
444 Application Ruby-lang Ruby 1.8.6.201 Version Details Vulnerabilities
445 Application Ruby-lang Ruby 1.8.6.202 Version Details Vulnerabilities
446 Application Ruby-lang Ruby 1.8.6.203 Version Details Vulnerabilities
447 Application Ruby-lang Ruby 1.8.6.204 Version Details Vulnerabilities
448 Application Ruby-lang Ruby 1.8.6.205 Version Details Vulnerabilities
449 Application Ruby-lang Ruby 1.8.6.206 Version Details Vulnerabilities
450 Application Ruby-lang Ruby 1.8.6.207 Version Details Vulnerabilities
451 Application Ruby-lang Ruby 1.8.6.208 Version Details Vulnerabilities
452 Application Ruby-lang Ruby 1.8.6.209 Version Details Vulnerabilities
453 Application Ruby-lang Ruby 1.8.6.210 Version Details Vulnerabilities
454 Application Ruby-lang Ruby 1.8.6.211 Version Details Vulnerabilities
455 Application Ruby-lang Ruby 1.8.6.212 Version Details Vulnerabilities
456 Application Ruby-lang Ruby 1.8.6.213 Version Details Vulnerabilities
457 Application Ruby-lang Ruby 1.8.6.214 Version Details Vulnerabilities
458 Application Ruby-lang Ruby 1.8.6.215 Version Details Vulnerabilities
459 Application Ruby-lang Ruby 1.8.6.216 Version Details Vulnerabilities
460 Application Ruby-lang Ruby 1.8.6.217 Version Details Vulnerabilities
461 Application Ruby-lang Ruby 1.8.6.218 Version Details Vulnerabilities
462 Application Ruby-lang Ruby 1.8.6.219 Version Details Vulnerabilities
463 Application Ruby-lang Ruby 1.8.6.220 Version Details Vulnerabilities
464 Application Ruby-lang Ruby 1.8.6.221 Version Details Vulnerabilities
465 Application Ruby-lang Ruby 1.8.6.222 Version Details Vulnerabilities
466 Application Ruby-lang Ruby 1.8.6.223 Version Details Vulnerabilities
467 Application Ruby-lang Ruby 1.8.6.224 Version Details Vulnerabilities
468 Application Ruby-lang Ruby 1.8.6.225 Version Details Vulnerabilities
469 Application Ruby-lang Ruby 1.8.6.226 Version Details Vulnerabilities
470 Application Ruby-lang Ruby 1.8.6.227 Version Details Vulnerabilities
471 Application Ruby-lang Ruby 1.8.6.228 Version Details Vulnerabilities
472 Application Ruby-lang Ruby 1.8.6.229 Version Details Vulnerabilities
473 Application Ruby-lang Ruby 1.8.6.230 Version Details Vulnerabilities
474 Application Ruby-lang Ruby 1.8.6.231 Version Details Vulnerabilities
475 Application Ruby-lang Ruby 1.8.6.232 Version Details Vulnerabilities
476 Application Ruby-lang Ruby 1.8.6.233 Version Details Vulnerabilities
477 Application Ruby-lang Ruby 1.8.6.234 Version Details Vulnerabilities
478 Application Ruby-lang Ruby 1.8.6.235 Version Details Vulnerabilities
479 Application Ruby-lang Ruby 1.8.6.236 Version Details Vulnerabilities
480 Application Ruby-lang Ruby 1.8.6.237 Version Details Vulnerabilities
481 Application Ruby-lang Ruby 1.8.6.238 Version Details Vulnerabilities
482 Application Ruby-lang Ruby 1.8.6.239 Version Details Vulnerabilities
483 Application Ruby-lang Ruby 1.8.6.240 Version Details Vulnerabilities
484 Application Ruby-lang Ruby 1.8.6.241 Version Details Vulnerabilities
485 Application Ruby-lang Ruby 1.8.6.242 Version Details Vulnerabilities
486 Application Ruby-lang Ruby 1.8.6.243 Version Details Vulnerabilities
487 Application Ruby-lang Ruby 1.8.6.244 Version Details Vulnerabilities
488 Application Ruby-lang Ruby 1.8.6.245 Version Details Vulnerabilities
489 Application Ruby-lang Ruby 1.8.6.246 Version Details Vulnerabilities
490 Application Ruby-lang Ruby 1.8.6.247 Version Details Vulnerabilities
491 Application Ruby-lang Ruby 1.8.6.248 Version Details Vulnerabilities
492 Application Ruby-lang Ruby 1.8.6.249 Version Details Vulnerabilities
493 Application Ruby-lang Ruby 1.8.6.250 Version Details Vulnerabilities
494 Application Ruby-lang Ruby 1.8.6.251 Version Details Vulnerabilities
495 Application Ruby-lang Ruby 1.8.6.252 Version Details Vulnerabilities
496 Application Ruby-lang Ruby 1.8.6.253 Version Details Vulnerabilities
497 Application Ruby-lang Ruby 1.8.6.255 Version Details Vulnerabilities
498 Application Ruby-lang Ruby 1.8.6.256 Version Details Vulnerabilities
499 Application Ruby-lang Ruby 1.8.6.257 Version Details Vulnerabilities
500 Application Ruby-lang Ruby 1.8.6.258 Version Details Vulnerabilities
501 Application Ruby-lang Ruby 1.8.6.259 Version Details Vulnerabilities
502 Application Ruby-lang Ruby 1.8.6.260 Version Details Vulnerabilities
503 Application Ruby-lang Ruby 1.8.6.261 Version Details Vulnerabilities
504 Application Ruby-lang Ruby 1.8.6.262 Version Details Vulnerabilities
505 Application Ruby-lang Ruby 1.8.6.263 Version Details Vulnerabilities
506 Application Ruby-lang Ruby 1.8.6.264 Version Details Vulnerabilities
507 Application Ruby-lang Ruby 1.8.6.265 Version Details Vulnerabilities
508 Application Ruby-lang Ruby 1.8.6.266 Version Details Vulnerabilities
509 Application Ruby-lang Ruby 1.8.6.267 Version Details Vulnerabilities
510 Application Ruby-lang Ruby 1.8.6.268 Version Details Vulnerabilities
511 Application Ruby-lang Ruby 1.8.6.269 Version Details Vulnerabilities
512 Application Ruby-lang Ruby 1.8.6.270 Version Details Vulnerabilities
513 Application Ruby-lang Ruby 1.8.6.271 Version Details Vulnerabilities
514 Application Ruby-lang Ruby 1.8.6.272 Version Details Vulnerabilities
515 Application Ruby-lang Ruby 1.8.6.273 Version Details Vulnerabilities
516 Application Ruby-lang Ruby 1.8.6.274 Version Details Vulnerabilities
517 Application Ruby-lang Ruby 1.8.6.275 Version Details Vulnerabilities
518 Application Ruby-lang Ruby 1.8.6.276 Version Details Vulnerabilities
519 Application Ruby-lang Ruby 1.8.6.277 Version Details Vulnerabilities
520 Application Ruby-lang Ruby 1.8.6.278 Version Details Vulnerabilities
521 Application Ruby-lang Ruby 1.8.6.279 Version Details Vulnerabilities
522 Application Ruby-lang Ruby 1.8.6.280 Version Details Vulnerabilities
523 Application Ruby-lang Ruby 1.8.6.281 Version Details Vulnerabilities
524 Application Ruby-lang Ruby 1.8.6.282 Version Details Vulnerabilities
525 Application Ruby-lang Ruby 1.8.6.283 Version Details Vulnerabilities
526 Application Ruby-lang Ruby 1.8.6.284 Version Details Vulnerabilities
527 Application Ruby-lang Ruby 1.8.6.285 Version Details Vulnerabilities
528 Application Ruby-lang Ruby 1.8.6.286 Version Details Vulnerabilities
529 Application Ruby-lang Ruby 1.8.6.287 Version Details Vulnerabilities
530 Application Ruby-lang Ruby 1.8.6.288 Version Details Vulnerabilities
531 Application Ruby-lang Ruby 1.8.6.289 Version Details Vulnerabilities
532 Application Ruby-lang Ruby 1.8.6.290 Version Details Vulnerabilities
533 Application Ruby-lang Ruby 1.8.6.291 Version Details Vulnerabilities
534 Application Ruby-lang Ruby 1.8.6.292 Version Details Vulnerabilities
535 Application Ruby-lang Ruby 1.8.6.293 Version Details Vulnerabilities
536 Application Ruby-lang Ruby 1.8.6.294 Version Details Vulnerabilities
537 Application Ruby-lang Ruby 1.8.6.295 Version Details Vulnerabilities
538 Application Ruby-lang Ruby 1.8.6.296 Version Details Vulnerabilities
539 Application Ruby-lang Ruby 1.8.6.297 Version Details Vulnerabilities
540 Application Ruby-lang Ruby 1.8.6.298 Version Details Vulnerabilities
541 Application Ruby-lang Ruby 1.8.6.299 Version Details Vulnerabilities
542 Application Ruby-lang Ruby 1.8.6.300 Version Details Vulnerabilities
543 Application Ruby-lang Ruby 1.8.6.301 Version Details Vulnerabilities
544 Application Ruby-lang Ruby 1.8.6.302 Version Details Vulnerabilities
545 Application Ruby-lang Ruby 1.8.6.303 Version Details Vulnerabilities
546 Application Ruby-lang Ruby 1.8.6.304 Version Details Vulnerabilities
547 Application Ruby-lang Ruby 1.8.6.305 Version Details Vulnerabilities
548 Application Ruby-lang Ruby 1.8.6.306 Version Details Vulnerabilities
549 Application Ruby-lang Ruby 1.8.6.307 Version Details Vulnerabilities
550 Application Ruby-lang Ruby 1.8.6.308 Version Details Vulnerabilities
551 Application Ruby-lang Ruby 1.8.6.309 Version Details Vulnerabilities
552 Application Ruby-lang Ruby 1.8.6.310 Version Details Vulnerabilities
553 Application Ruby-lang Ruby 1.8.6.311 Version Details Vulnerabilities
554 Application Ruby-lang Ruby 1.8.6.312 Version Details Vulnerabilities
555 Application Ruby-lang Ruby 1.8.6.313 Version Details Vulnerabilities
556 Application Ruby-lang Ruby 1.8.6.314 Version Details Vulnerabilities
557 Application Ruby-lang Ruby 1.8.6.315 Version Details Vulnerabilities
558 Application Ruby-lang Ruby 1.8.6.316 Version Details Vulnerabilities
559 Application Ruby-lang Ruby 1.8.6.317 Version Details Vulnerabilities
560 Application Ruby-lang Ruby 1.8.6.318 Version Details Vulnerabilities
561 Application Ruby-lang Ruby 1.8.6.319 Version Details Vulnerabilities
562 Application Ruby-lang Ruby 1.8.6.320 Version Details Vulnerabilities
563 Application Ruby-lang Ruby 1.8.6.321 Version Details Vulnerabilities
564 Application Ruby-lang Ruby 1.8.6.322 Version Details Vulnerabilities
565 Application Ruby-lang Ruby 1.8.6.323 Version Details Vulnerabilities
566 Application Ruby-lang Ruby 1.8.6.324 Version Details Vulnerabilities
567 Application Ruby-lang Ruby 1.8.6.325 Version Details Vulnerabilities
568 Application Ruby-lang Ruby 1.8.6.326 Version Details Vulnerabilities
569 Application Ruby-lang Ruby 1.8.6.327 Version Details Vulnerabilities
570 Application Ruby-lang Ruby 1.8.6.328 Version Details Vulnerabilities
571 Application Ruby-lang Ruby 1.8.6.329 Version Details Vulnerabilities
572 Application Ruby-lang Ruby 1.8.6.330 Version Details Vulnerabilities
573 Application Ruby-lang Ruby 1.8.6.331 Version Details Vulnerabilities
574 Application Ruby-lang Ruby 1.8.6.332 Version Details Vulnerabilities
575 Application Ruby-lang Ruby 1.8.6.333 Version Details Vulnerabilities
576 Application Ruby-lang Ruby 1.8.6.334 Version Details Vulnerabilities
577 Application Ruby-lang Ruby 1.8.6.335 Version Details Vulnerabilities
578 Application Ruby-lang Ruby 1.8.6.336 Version Details Vulnerabilities
579 Application Ruby-lang Ruby 1.8.6.337 Version Details Vulnerabilities
580 Application Ruby-lang Ruby 1.8.6.338 Version Details Vulnerabilities
581 Application Ruby-lang Ruby 1.8.6.339 Version Details Vulnerabilities
582 Application Ruby-lang Ruby 1.8.6.340 Version Details Vulnerabilities
583 Application Ruby-lang Ruby 1.8.6.341 Version Details Vulnerabilities
584 Application Ruby-lang Ruby 1.8.6.342 Version Details Vulnerabilities
585 Application Ruby-lang Ruby 1.8.6.343 Version Details Vulnerabilities
586 Application Ruby-lang Ruby 1.8.6.344 Version Details Vulnerabilities
587 Application Ruby-lang Ruby 1.8.6.345 Version Details Vulnerabilities
588 Application Ruby-lang Ruby 1.8.6.346 Version Details Vulnerabilities
589 Application Ruby-lang Ruby 1.8.6.347 Version Details Vulnerabilities
590 Application Ruby-lang Ruby 1.8.6.348 Version Details Vulnerabilities
591 Application Ruby-lang Ruby 1.8.6.349 Version Details Vulnerabilities
592 Application Ruby-lang Ruby 1.8.6.350 Version Details Vulnerabilities
593 Application Ruby-lang Ruby 1.8.6.351 Version Details Vulnerabilities
594 Application Ruby-lang Ruby 1.8.6.352 Version Details Vulnerabilities
595 Application Ruby-lang Ruby 1.8.6.353 Version Details Vulnerabilities
596 Application Ruby-lang Ruby 1.8.6.354 Version Details Vulnerabilities
597 Application Ruby-lang Ruby 1.8.6.355 Version Details Vulnerabilities
598 Application Ruby-lang Ruby 1.8.6.356 Version Details Vulnerabilities
599 Application Ruby-lang Ruby 1.8.6.357 Version Details Vulnerabilities
600 Application Ruby-lang Ruby 1.8.6.358 Version Details Vulnerabilities
601 Application Ruby-lang Ruby 1.8.6.359 Version Details Vulnerabilities
602 Application Ruby-lang Ruby 1.8.6.360 Version Details Vulnerabilities
603 Application Ruby-lang Ruby 1.8.6.361 Version Details Vulnerabilities
604 Application Ruby-lang Ruby 1.8.6.362 Version Details Vulnerabilities
605 Application Ruby-lang Ruby 1.8.6.363 Version Details Vulnerabilities
606 Application Ruby-lang Ruby 1.8.6.364 Version Details Vulnerabilities
607 Application Ruby-lang Ruby 1.8.6.365 Version Details Vulnerabilities
608 Application Ruby-lang Ruby 1.8.6.366 Version Details Vulnerabilities
609 Application Ruby-lang Ruby 1.8.6.367 Version Details Vulnerabilities
610 Application Ruby-lang Ruby 1.8.6.368 Version Details Vulnerabilities
611 Application Ruby-lang Ruby 1.8.6.369 Version Details Vulnerabilities
612 Application Ruby-lang Ruby 1.8.6.381 Version Details Vulnerabilities
613 Application Ruby-lang Ruby 1.8.6.383 Version Details Vulnerabilities
614 Application Ruby-lang Ruby 1.8.6.388 Version Details Vulnerabilities
615 Application Ruby-lang Ruby 1.8.6.398 Version Details Vulnerabilities
616 Application Ruby-lang Ruby 1.8.6.399 Version Details Vulnerabilities
617 Application Ruby-lang Ruby 1.8.6.420 Version Details Vulnerabilities
618 Application Ruby-lang Ruby 1.8.6.5001 Version Details Vulnerabilities
619 Application Ruby-lang Ruby 1.8.7 Version Details Vulnerabilities
620 Application Ruby-lang Ruby 1.8.7 P330 Version Details Vulnerabilities
621 Application Ruby-lang Ruby 1.8.7 Preview1 Version Details Vulnerabilities
622 Application Ruby-lang Ruby 1.8.7 P371 Version Details Vulnerabilities
623 Application Ruby-lang Ruby 1.8.7 P248 Version Details Vulnerabilities
624 Application Ruby-lang Ruby 1.8.7 P160 Version Details Vulnerabilities
625 Application Ruby-lang Ruby 1.8.7 P334 Version Details Vulnerabilities
626 Application Ruby-lang Ruby 1.8.7 Preview2 Version Details Vulnerabilities
627 Application Ruby-lang Ruby 1.8.7 P249 Version Details Vulnerabilities
628 Application Ruby-lang Ruby 1.8.7 P373 Version Details Vulnerabilities
629 Application Ruby-lang Ruby 1.8.7 P17 Version Details Vulnerabilities
630 Application Ruby-lang Ruby 1.8.7 P352 Version Details Vulnerabilities
631 Application Ruby-lang Ruby 1.8.7 Preview3 Version Details Vulnerabilities
632 Application Ruby-lang Ruby 1.8.7 P299 Version Details Vulnerabilities
633 Application Ruby-lang Ruby 1.8.7 P374 Version Details Vulnerabilities
634 Application Ruby-lang Ruby 1.8.7 P173 Version Details Vulnerabilities
635 Application Ruby-lang Ruby 1.8.7 P357 Version Details Vulnerabilities
636 Application Ruby-lang Ruby 1.8.7 Preview4 Version Details Vulnerabilities
637 Application Ruby-lang Ruby 1.8.7 P301 Version Details Vulnerabilities
638 Application Ruby-lang Ruby 1.8.7 P71 Version Details Vulnerabilities
639 Application Ruby-lang Ruby 1.8.7 P358 Version Details Vulnerabilities
640 Application Ruby-lang Ruby 1.8.7 P174 Version Details Vulnerabilities
641 Application Ruby-lang Ruby 1.8.7 P302 Version Details Vulnerabilities
642 Application Ruby-lang Ruby 1.8.7 P72 Version Details Vulnerabilities
643 Application Ruby-lang Ruby 1.8.7 P370 Version Details Vulnerabilities
644 Application Ruby-lang Ruby 1.8.7 P22 Version Details Vulnerabilities
645 Application Ruby-lang Ruby 1.8.7.7 Version Details Vulnerabilities
646 Application Ruby-lang Ruby 1.8.7.17 Version Details Vulnerabilities
647 Application Ruby-lang Ruby 1.8.7.20 Version Details Vulnerabilities
648 Application Ruby-lang Ruby 1.8.7.21 Version Details Vulnerabilities
649 Application Ruby-lang Ruby 1.8.7.22 Version Details Vulnerabilities
650 Application Ruby-lang Ruby 1.8.7.23 Version Details Vulnerabilities
651 Application Ruby-lang Ruby 1.8.7.24 Version Details Vulnerabilities
652 Application Ruby-lang Ruby 1.8.7.25 Version Details Vulnerabilities
653 Application Ruby-lang Ruby 1.8.7.26 Version Details Vulnerabilities
654 Application Ruby-lang Ruby 1.8.7.27 Version Details Vulnerabilities
655 Application Ruby-lang Ruby 1.8.7.28 Version Details Vulnerabilities
656 Application Ruby-lang Ruby 1.8.7.29 Version Details Vulnerabilities
657 Application Ruby-lang Ruby 1.8.7.30 Version Details Vulnerabilities
658 Application Ruby-lang Ruby 1.8.7.31 Version Details Vulnerabilities
659 Application Ruby-lang Ruby 1.8.7.32 Version Details Vulnerabilities
660 Application Ruby-lang Ruby 1.8.7.33 Version Details Vulnerabilities
661 Application Ruby-lang Ruby 1.8.7.34 Version Details Vulnerabilities
662 Application Ruby-lang Ruby 1.8.7.35 Version Details Vulnerabilities
663 Application Ruby-lang Ruby 1.8.7.36 Version Details Vulnerabilities
664 Application Ruby-lang Ruby 1.8.7.37 Version Details Vulnerabilities
665 Application Ruby-lang Ruby 1.8.7.38 Version Details Vulnerabilities
666 Application Ruby-lang Ruby 1.8.7.39 Version Details Vulnerabilities
667 Application Ruby-lang Ruby 1.8.7.40 Version Details Vulnerabilities
668 Application Ruby-lang Ruby 1.8.7.41 Version Details Vulnerabilities
669 Application Ruby-lang Ruby 1.8.7.42 Version Details Vulnerabilities
670 Application Ruby-lang Ruby 1.8.7.43 Version Details Vulnerabilities
671 Application Ruby-lang Ruby 1.8.7.44 Version Details Vulnerabilities
672 Application Ruby-lang Ruby 1.8.7.45 Version Details Vulnerabilities
673 Application Ruby-lang Ruby 1.8.7.46 Version Details Vulnerabilities
674 Application Ruby-lang Ruby 1.8.7.47 Version Details Vulnerabilities
675 Application Ruby-lang Ruby 1.8.7.48 Version Details Vulnerabilities
676 Application Ruby-lang Ruby 1.8.7.49 Version Details Vulnerabilities
677 Application Ruby-lang Ruby 1.8.7.50 Version Details Vulnerabilities
678 Application Ruby-lang Ruby 1.8.7.51 Version Details Vulnerabilities
679 Application Ruby-lang Ruby 1.8.7.52 Version Details Vulnerabilities
680 Application Ruby-lang Ruby 1.8.7.53 Version Details Vulnerabilities
681 Application Ruby-lang Ruby 1.8.7.54 Version Details Vulnerabilities
682 Application Ruby-lang Ruby 1.8.7.55 Version Details Vulnerabilities
683 Application Ruby-lang Ruby 1.8.7.56 Version Details Vulnerabilities
684 Application Ruby-lang Ruby 1.8.7.57 Version Details Vulnerabilities
685 Application Ruby-lang Ruby 1.8.7.58 Version Details Vulnerabilities
686 Application Ruby-lang Ruby 1.8.7.59 Version Details Vulnerabilities
687 Application Ruby-lang Ruby 1.8.7.60 Version Details Vulnerabilities
688 Application Ruby-lang Ruby 1.8.7.61 Version Details Vulnerabilities
689 Application Ruby-lang Ruby 1.8.7.62 Version Details Vulnerabilities
690 Application Ruby-lang Ruby 1.8.7.63 Version Details Vulnerabilities
691 Application Ruby-lang Ruby 1.8.7.64 Version Details Vulnerabilities
692 Application Ruby-lang Ruby 1.8.7.65 Version Details Vulnerabilities
693 Application Ruby-lang Ruby 1.8.7.66 Version Details Vulnerabilities
694 Application Ruby-lang Ruby 1.8.7.67 Version Details Vulnerabilities
695 Application Ruby-lang Ruby 1.8.7.68 Version Details Vulnerabilities
696 Application Ruby-lang Ruby 1.8.7.69 Version Details Vulnerabilities
697 Application Ruby-lang Ruby 1.8.7.70 Version Details Vulnerabilities
698 Application Ruby-lang Ruby 1.8.7.71 Version Details Vulnerabilities
699 Application Ruby-lang Ruby 1.8.7.72 Version Details Vulnerabilities
700 Application Ruby-lang Ruby 1.8.7.73 Version Details Vulnerabilities
Maximum 700 results are displayed even if there are more. A very little number of cve entries, mostly related to cisco products and google chrome , affect even more than 700 different versions but they are not displayed to keep page size within reasonable limits. Affected product count numbers may not reflect the actuals numbers either. Does it really make sense to have so many versions?

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Debian Debian Linux 3
Ruby-lang Ruby 694

- References For CVE-2018-8780

https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-5-1-released/ CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
SUSE openSUSE-SU-2019:1771
http://www.securityfocus.com/bid/103739
BID 103739
https://usn.ubuntu.com/3626-1/
UBUNTU USN-3626-1
https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-4-4-released/ CONFIRM
https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-3-7-released/ CONFIRM
https://www.ruby-lang.org/en/news/2018/03/28/ruby-2-2-10-released/ CONFIRM
http://www.securitytracker.com/id/1042004
SECTRACK 1042004
https://access.redhat.com/errata/RHSA-2018:3729
REDHAT RHSA-2018:3729
https://access.redhat.com/errata/RHSA-2018:3730
REDHAT RHSA-2018:3730
https://www.debian.org/security/2018/dsa-4259
DEBIAN DSA-4259
https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
MLIST [debian-lts-announce] 20180714 [SECURITY] [DLA 1421-1] ruby2.1 security update
https://lists.debian.org/debian-lts-announce/2018/04/msg00024.html
MLIST [debian-lts-announce] 20180423 [SECURITY] [DLA 1359-1] ruby1.8 security update
https://access.redhat.com/errata/RHSA-2018:3731
REDHAT RHSA-2018:3731
https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html
MLIST [debian-lts-announce] 20180423 [SECURITY] [DLA 1358-1] ruby1.9.1 security update
https://www.ruby-lang.org/en/news/2018/03/28/poisoned-nul-byte-dir-cve-2018-8780/ CONFIRM

- Metasploit Modules Related To CVE-2018-8780

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.