CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-6830

Directory traversal vulnerability in Foscam Cameras C1 Lite V3, and C1 V3 with firmware 2.82.2.33 and earlier, FI9800P V3, FI9803P V4, FI9851P V3, and FI9853EP V2 2.84.2.33 and earlier, FI9816P V3, FI9821EP V2, FI9821P V3, FI9826P V3, and FI9831P V3 2.81.2.33 and earlier, C1, C1 V2, C1 Lite, and C1 Lite V2 2.52.2.47 and earlier, FI9800P, FI9800P V2, FI9803P V2, FI9803P V3, and FI9851P V2 2.54.2.47 and earlier, FI9815P, FI9815P V2, FI9816P, and FI9816P V2, 2.51.2.47 and earlier, R2 and R4 2.71.1.59 and earlier, C2 and FI9961EP 2.72.1.59 and earlier, FI9900EP, FI9900P, and FI9901EP 2.74.1.59 and earlier, FI9928P 2.74.1.58 and earlier, FI9803EP and FI9853EP 2.22.2.31 and earlier, FI9803P and FI9851P 2.24.2.31 and earlier, FI9821P V2, FI9826P V2, FI9831P V2, and FI9821EP 2.21.2.31 and earlier, FI9821W V2, FI9831W, FI9826W, FI9821P, FI9831P, and FI9826P 2.11.1.120 and earlier, FI9818W V2 2.13.2.120 and earlier, FI9805W, FI9804W, FI9804P, FI9805E, and FI9805P 2.14.1.120 and earlier, FI9828P, and FI9828W 2.13.1.120 and earlier, and FI9828P V2 2.11.1.133 and earlier allows remote attackers to delete arbitrary files via a .. (dot dot) in the URI path component.
Publish Date : 2018-07-09 Last Update Date : 2018-09-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Directory traversal
CWE ID 22

- Products Affected By CVE-2018-6830

# Product Type Vendor Product Version Update Edition Language
1 OS Foscam C1 Firmware 2.52.2.47 Version Details Vulnerabilities
2 OS Foscam C1 Firmware 2.82.2.33 Version Details Vulnerabilities
3 OS Foscam C1 Lite Firmware 2.52.2.47 Version Details Vulnerabilities
4 OS Foscam C1 Lite Firmware 2.82.2.33 Version Details Vulnerabilities
5 OS Foscam C2 Firmware 2.72.1.59 Version Details Vulnerabilities
6 OS Foscam Fi9800p Firmware 2.54.2.47 Version Details Vulnerabilities
7 OS Foscam Fi9800p Firmware 2.81.2.33 Version Details Vulnerabilities
8 OS Foscam Fi9803ep Firmware 2.22.2.31 Version Details Vulnerabilities
9 OS Foscam Fi9803p Firmware 2.24.2.31 Version Details Vulnerabilities
10 OS Foscam Fi9803p Firmware 2.54.2.47 Version Details Vulnerabilities
11 OS Foscam Fi9804p Firmware 2.14.1.120 Version Details Vulnerabilities
12 OS Foscam Fi9804w Firmware 2.14.1.120 Version Details Vulnerabilities
13 OS Foscam Fi9805e Firmware 2.14.1.120 Version Details Vulnerabilities
14 OS Foscam Fi9805p Firmware 2.14.1.120 Version Details Vulnerabilities
15 OS Foscam Fi9805w Firmware 2.14.1.120 Version Details Vulnerabilities
16 OS Foscam Fi9815p Firmware 2.51.2.47 Version Details Vulnerabilities
17 OS Foscam Fi9816p Firmware 2.51.2.47 Version Details Vulnerabilities
18 OS Foscam Fi9818w Firmware 2.13.2.120 Version Details Vulnerabilities
19 OS Foscam Fi9821ep Firmware 2.21.2.31 Version Details Vulnerabilities
20 OS Foscam Fi9821ep Firmware 2.81.2.33 Version Details Vulnerabilities
21 OS Foscam Fi9821p Firmware 2.11.1.120 Version Details Vulnerabilities
22 OS Foscam Fi9821p Firmware 2.21.2.31 Version Details Vulnerabilities
23 OS Foscam Fi9821p Firmware 2.81.2.33 Version Details Vulnerabilities
24 OS Foscam Fi9821w Firmware 2.11.1.120 Version Details Vulnerabilities
25 OS Foscam Fi9826p Firmware 2.11.1.120 Version Details Vulnerabilities
26 OS Foscam Fi9826p Firmware 2.21.2.31 Version Details Vulnerabilities
27 OS Foscam Fi9826p Firmware 2.81.2.33 Version Details Vulnerabilities
28 OS Foscam Fi9826w Firmware 2.11.1.120 Version Details Vulnerabilities
29 OS Foscam Fi9828p Firmware 2.11.1.133 Version Details Vulnerabilities
30 OS Foscam Fi9828p Firmware 2.13.1.120 Version Details Vulnerabilities
31 OS Foscam Fi9828w Firmware 2.13.1.120 Version Details Vulnerabilities
32 OS Foscam Fi9831p Firmware 2.11.1.120 Version Details Vulnerabilities
33 OS Foscam Fi9831p Firmware 2.21.2.31 Version Details Vulnerabilities
34 OS Foscam Fi9831p Firmware 2.81.2.33 Version Details Vulnerabilities
35 OS Foscam Fi9831w Firmware 2.11.1.120 Version Details Vulnerabilities
36 OS Foscam Fi9851p Firmware 2.24.2.31 Version Details Vulnerabilities
37 OS Foscam Fi9851p Firmware 2.54.2.47 Version Details Vulnerabilities
38 OS Foscam Fi9853ep Firmware 2.22.2.31 Version Details Vulnerabilities
39 OS Foscam Fi9900ep Firmware 2.74.1.59 Version Details Vulnerabilities
40 OS Foscam Fi9900p Firmware 2.74.1.59 Version Details Vulnerabilities
41 OS Foscam Fi9901ep Firmware 2.74.1.59 Version Details Vulnerabilities
42 OS Foscam Fi9928p Firmware 2.74.1.58 Version Details Vulnerabilities
43 OS Foscam Fi9961ep Firmware 2.72.1.59 Version Details Vulnerabilities
44 OS Foscam R2 Firmware 2.71.1.59 Version Details Vulnerabilities
45 OS Foscam R4 Firmware 2.71.1.59 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Foscam C1 Firmware 2
Foscam C1 Lite Firmware 2
Foscam C2 Firmware 1
Foscam Fi9800p Firmware 2
Foscam Fi9803ep Firmware 1
Foscam Fi9803p Firmware 2
Foscam Fi9804p Firmware 1
Foscam Fi9804w Firmware 1
Foscam Fi9805e Firmware 1
Foscam Fi9805p Firmware 1
Foscam Fi9805w Firmware 1
Foscam Fi9815p Firmware 1
Foscam Fi9816p Firmware 1
Foscam Fi9818w Firmware 1
Foscam Fi9821ep Firmware 2
Foscam Fi9821p Firmware 3
Foscam Fi9821w Firmware 1
Foscam Fi9826p Firmware 3
Foscam Fi9826w Firmware 1
Foscam Fi9828p Firmware 2
Foscam Fi9828w Firmware 1
Foscam Fi9831p Firmware 3
Foscam Fi9831w Firmware 1
Foscam Fi9851p Firmware 2
Foscam Fi9853ep Firmware 1
Foscam Fi9900ep Firmware 1
Foscam Fi9900p Firmware 1
Foscam Fi9901ep Firmware 1
Foscam Fi9928p Firmware 1
Foscam Fi9961ep Firmware 1
Foscam R2 Firmware 1
Foscam R4 Firmware 1

- References For CVE-2018-6830

https://www.foscam.com/company/securing-your-foscam-camera-important-notice.html CONFIRM
https://blog.vdoo.com/2018/06/06/vdoo-has-found-major-vulnerabilities-in-foscam-cameras/

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2018-6830

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.