CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-5390

Linux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service.
Publish Date : 2018-08-06 Last Update Date : 2020-09-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.8
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 400

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2018:2384: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20182384 unix
RHSA-2018:2390: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20182390 unix
RHSA-2018:2395: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20182395 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-5390

# Product Type Vendor Product Version Update Edition Language
1 OS A10networks Advanced Core Operating System 3.2.2 * * * Version Details Vulnerabilities
2 OS A10networks Advanced Core Operating System 3.2.2 P5 * * Version Details Vulnerabilities
3 OS A10networks Advanced Core Operating System 4.1.0 * * * Version Details Vulnerabilities
4 OS A10networks Advanced Core Operating System 4.1.0 P11 * * Version Details Vulnerabilities
5 OS A10networks Advanced Core Operating System 4.1.1 P8 * * Version Details Vulnerabilities
6 OS A10networks Advanced Core Operating System 4.1.2 P4 * * Version Details Vulnerabilities
7 OS A10networks Advanced Core Operating System 4.1.2 * * * Version Details Vulnerabilities
8 OS A10networks Advanced Core Operating System 4.1.4 * * * Version Details Vulnerabilities
9 OS A10networks Advanced Core Operating System 4.1.4 P1 * * Version Details Vulnerabilities
10 OS Canonical Ubuntu Linux 12.04 * * * Version Details Vulnerabilities
11 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
12 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
13 OS Canonical Ubuntu Linux 18.04 * * * Version Details Vulnerabilities
14 Application Cisco Collaboration Meeting Rooms 1.0 * * * Version Details Vulnerabilities
15 Application Cisco Digital Network Architecture Center 1.2 * * * Version Details Vulnerabilities
16 Application Cisco Expressway X8.10 * * * Version Details Vulnerabilities
17 Application Cisco Expressway X8.10.1 * * * Version Details Vulnerabilities
18 Application Cisco Expressway X8.10.2 * * * Version Details Vulnerabilities
19 Application Cisco Expressway X8.10.3 * * * Version Details Vulnerabilities
20 Application Cisco Expressway X8.10.4 * * * Version Details Vulnerabilities
21 Application Cisco Expressway X8.11 * * * Version Details Vulnerabilities
22 Application Cisco Expressway Series - * * * Version Details Vulnerabilities
23 Application Cisco Meeting Management 1.0 * * * Version Details Vulnerabilities
24 Application Cisco Meeting Management 1.0.1 * * * Version Details Vulnerabilities
25 Application Cisco Network Assurance Engine 2.1\(1a\) * * * Version Details Vulnerabilities
26 Application Cisco Threat Grid-cloud - * * * Version Details Vulnerabilities
27 Application Cisco Webex Hybrid Data Security - * * * Version Details Vulnerabilities
28 Application Cisco Webex Video Mesh - * * * Version Details Vulnerabilities
29 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
30 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
31 Application F5 Big-ip Access Policy Manager * * * * Version Details Vulnerabilities
32 Application F5 Big-ip Access Policy Manager 14.0.0 * * * Version Details Vulnerabilities
33 Application F5 Big-ip Advanced Firewall Manager * * * * Version Details Vulnerabilities
34 Application F5 Big-ip Advanced Firewall Manager 14.0.0 * * * Version Details Vulnerabilities
35 Application F5 Big-ip Analytics * * * * Version Details Vulnerabilities
36 Application F5 Big-ip Analytics 14.0.0 * * * Version Details Vulnerabilities
37 Application F5 Big-ip Application Acceleration Manager * * * * Version Details Vulnerabilities
38 Application F5 Big-ip Application Acceleration Manager 14.0.0 * * * Version Details Vulnerabilities
39 Application F5 Big-ip Application Security Manager * * * * Version Details Vulnerabilities
40 Application F5 Big-ip Application Security Manager 14.0.0 * * * Version Details Vulnerabilities
41 Application F5 Big-ip Domain Name System * * * * Version Details Vulnerabilities
42 Application F5 Big-ip Domain Name System 14.0.0 * * * Version Details Vulnerabilities
43 Application F5 Big-ip Edge Gateway * * * * Version Details Vulnerabilities
44 Application F5 Big-ip Edge Gateway 14.0.0 * * * Version Details Vulnerabilities
45 Application F5 Big-ip Fraud Protection Service * * * * Version Details Vulnerabilities
46 Application F5 Big-ip Fraud Protection Service 14.0.0 * * * Version Details Vulnerabilities
47 Application F5 Big-ip Global Traffic Manager * * * * Version Details Vulnerabilities
48 Application F5 Big-ip Global Traffic Manager 14.0.0 * * * Version Details Vulnerabilities
49 Application F5 Big-ip Link Controller * * * * Version Details Vulnerabilities
50 Application F5 Big-ip Link Controller 14.0.0 * * * Version Details Vulnerabilities
51 Application F5 Big-ip Local Traffic Manager * * * * Version Details Vulnerabilities
52 Application F5 Big-ip Local Traffic Manager 14.0.0 * * * Version Details Vulnerabilities
53 Application F5 Big-ip Policy Enforcement Manager * * * * Version Details Vulnerabilities
54 Application F5 Big-ip Policy Enforcement Manager 14.0.0 * * * Version Details Vulnerabilities
55 Application F5 Big-ip Webaccelerator * * * * Version Details Vulnerabilities
56 Application F5 Big-ip Webaccelerator 14.0.0 * * * Version Details Vulnerabilities
57 Application F5 Traffix Systems Signaling Delivery Controller * * * * Version Details Vulnerabilities
58 Application F5 Traffix Systems Signaling Delivery Controller 4.4.0 * * * Version Details Vulnerabilities
59 Application HP Aruba Airwave Amp * * * * Version Details Vulnerabilities
60 Application HP Aruba Clearpass Policy Manager * * * * Version Details Vulnerabilities
61 OS Linux Linux Kernel * * * * Version Details Vulnerabilities
62 OS Linux Linux Kernel 4.18 RC4 * * Version Details Vulnerabilities
63 OS Linux Linux Kernel 4.18 RC5 * * Version Details Vulnerabilities
64 OS Linux Linux Kernel 4.18 RC6 * * Version Details Vulnerabilities
65 OS Linux Linux Kernel 4.18 RC1 * * Version Details Vulnerabilities
66 OS Linux Linux Kernel 4.18 RC2 * * Version Details Vulnerabilities
67 OS Linux Linux Kernel 4.18 RC3 * * Version Details Vulnerabilities
68 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
69 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
70 OS Redhat Enterprise Linux Server Aus 6.4 * * * Version Details Vulnerabilities
71 OS Redhat Enterprise Linux Server Aus 6.5 * * * Version Details Vulnerabilities
72 OS Redhat Enterprise Linux Server Aus 6.6 * * * Version Details Vulnerabilities
73 OS Redhat Enterprise Linux Server Aus 7.2 * * * Version Details Vulnerabilities
74 OS Redhat Enterprise Linux Server Aus 7.3 * * * Version Details Vulnerabilities
75 OS Redhat Enterprise Linux Server Aus 7.4 * * * Version Details Vulnerabilities
76 OS Redhat Enterprise Linux Server Eus 6.4 * * * Version Details Vulnerabilities
77 OS Redhat Enterprise Linux Server Eus 6.7 * * * Version Details Vulnerabilities
78 OS Redhat Enterprise Linux Server Eus 7.2 * * * Version Details Vulnerabilities
79 OS Redhat Enterprise Linux Server Eus 7.3 * * * Version Details Vulnerabilities
80 OS Redhat Enterprise Linux Server Eus 7.4 * * * Version Details Vulnerabilities
81 OS Redhat Enterprise Linux Server Eus 7.5 * * * Version Details Vulnerabilities
82 OS Redhat Enterprise Linux Server Tus 6.6 * * * Version Details Vulnerabilities
83 OS Redhat Enterprise Linux Server Tus 7.2 * * * Version Details Vulnerabilities
84 OS Redhat Enterprise Linux Server Tus 7.3 * * * Version Details Vulnerabilities
85 OS Redhat Enterprise Linux Server Tus 7.4 * * * Version Details Vulnerabilities
86 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities
87 Application Redhat Virtualization 4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
A10networks Advanced Core Operating System 9
Canonical Ubuntu Linux 4
Cisco Collaboration Meeting Rooms 1
Cisco Digital Network Architecture Center 1
Cisco Expressway 6
Cisco Expressway Series 1
Cisco Meeting Management 2
Cisco Network Assurance Engine 1
Cisco Threat Grid-cloud 1
Cisco Webex Hybrid Data Security 1
Cisco Webex Video Mesh 1
Debian Debian Linux 2
F5 Big-ip Access Policy Manager 2
F5 Big-ip Advanced Firewall Manager 2
F5 Big-ip Analytics 2
F5 Big-ip Application Acceleration Manager 2
F5 Big-ip Application Security Manager 2
F5 Big-ip Domain Name System 2
F5 Big-ip Edge Gateway 2
F5 Big-ip Fraud Protection Service 2
F5 Big-ip Global Traffic Manager 2
F5 Big-ip Link Controller 2
F5 Big-ip Local Traffic Manager 2
F5 Big-ip Policy Enforcement Manager 2
F5 Big-ip Webaccelerator 2
F5 Traffix Systems Signaling Delivery Controller 2
HP Aruba Airwave Amp 1
HP Aruba Clearpass Policy Manager 1
Linux Linux Kernel 7
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Server Aus 6
Redhat Enterprise Linux Server Eus 6
Redhat Enterprise Linux Server Tus 4
Redhat Enterprise Linux Workstation 1
Redhat Virtualization 1

- References For CVE-2018-5390

https://access.redhat.com/errata/RHSA-2018:2403
REDHAT RHSA-2018:2403
https://access.redhat.com/errata/RHSA-2018:2402
REDHAT RHSA-2018:2402
http://www.openwall.com/lists/oss-security/2019/06/28/2
MLIST [oss-security] 20190628 Re: linux-distros membership application - Microsoft
https://access.redhat.com/errata/RHSA-2018:2789
REDHAT RHSA-2018:2789
https://usn.ubuntu.com/3741-1/
UBUNTU USN-3741-1
https://www.kb.cert.org/vuls/id/962459
CERT-VN VU#962459
https://git.kernel.org/pub/scm/linux/kernel/git/davem/net.git/commit/?id=1a4f14bab1868b443f0dd3c55b689a478f82e72e CONFIRM
https://access.redhat.com/errata/RHSA-2018:2924
REDHAT RHSA-2018:2924
https://access.redhat.com/errata/RHSA-2018:2933
REDHAT RHSA-2018:2933
https://access.redhat.com/errata/RHSA-2018:2776
REDHAT RHSA-2018:2776
https://access.redhat.com/errata/RHSA-2018:2785
REDHAT RHSA-2018:2785
https://access.redhat.com/errata/RHSA-2018:2948
REDHAT RHSA-2018:2948
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180824-linux-tcp
CISCO 20180824 Linux and FreeBSD Kernels TCP Reassembly Denial of Service Vulnerabilities Affecting Cisco Products: August 2018
https://usn.ubuntu.com/3732-2/
UBUNTU USN-3732-2
https://usn.ubuntu.com/3732-1/
UBUNTU USN-3732-1
http://www.securitytracker.com/id/1041424
SECTRACK 1041424
http://www.securityfocus.com/bid/104976
BID 104976 Linux Kernel 'tcp_input.c' Remote Denial of Service Vulnerability Release Date:2019-02-13
http://www.securitytracker.com/id/1041434
SECTRACK 1041434
https://usn.ubuntu.com/3742-2/
UBUNTU USN-3742-2
https://usn.ubuntu.com/3742-1/
UBUNTU USN-3742-1
https://www.synology.com/support/security/Synology_SA_18_41 CONFIRM
https://access.redhat.com/errata/RHSA-2018:2790
REDHAT RHSA-2018:2790
https://access.redhat.com/errata/RHSA-2018:2791
REDHAT RHSA-2018:2791
https://usn.ubuntu.com/3763-1/
UBUNTU USN-3763-1
https://access.redhat.com/errata/RHSA-2018:2645
REDHAT RHSA-2018:2645
https://www.a10networks.com/support/security-advisories/tcp-ip-cve-2018-5390-segmentsmack CONFIRM
https://usn.ubuntu.com/3741-2/
UBUNTU USN-3741-2
http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2018-004.txt CONFIRM
https://security.netapp.com/advisory/ntap-20180815-0003/ CONFIRM
https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0 CONFIRM
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html CONFIRM
https://support.f5.com/csp/article/K95343321 CONFIRM
https://lists.debian.org/debian-lts-announce/2018/08/msg00014.html
MLIST [debian-lts-announce] 20180815 [SECURITY] [DLA 1466-1] linux-4.9 security update
https://access.redhat.com/errata/RHSA-2018:2384
REDHAT RHSA-2018:2384
https://www.debian.org/security/2018/dsa-4266
DEBIAN DSA-4266
https://access.redhat.com/errata/RHSA-2018:2395
REDHAT RHSA-2018:2395
http://www.openwall.com/lists/oss-security/2019/07/06/3
MLIST [oss-security] 20190706 Re: linux-distros membership application - Microsoft
http://www.openwall.com/lists/oss-security/2019/07/06/4
MLIST [oss-security] 20190706 Re: linux-distros membership application - Microsoft
https://support.f5.com/csp/article/K95343321?utm_source=f5support&utm_medium=RSS CONFIRM
https://cert-portal.siemens.com/productcert/pdf/ssa-377115.pdf CONFIRM
http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20181031-02-linux-en CONFIRM
https://www.oracle.com/security-alerts/cpujul2020.html

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2018-5390

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.