CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-2800

Vulnerability in the Java SE, JRockit component of Oracle Java SE (subcomponent: RMI). Supported versions that are affected are Java SE: 6u181, 7u171 and 8u162; JRockit: R28.3.17. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, JRockit. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, JRockit accessible data as well as unauthorized read access to a subset of Java SE, JRockit accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 4.2 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N).
Publish Date : 2018-04-19 Last Update Date : 2020-09-08
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2018:1188: java-1.8.0-openjdk security update (Critical) oval:com.redhat.rhsa:def:20181188 unix
RHSA-2018:1191: java-1.8.0-openjdk security update (Critical) oval:com.redhat.rhsa:def:20181191 unix
RHSA-2018:1201: java-1.7.0-oracle security update (Critical) oval:com.redhat.rhsa:def:20181201 unix
RHSA-2018:1202: java-1.8.0-oracle security update (Critical) oval:com.redhat.rhsa:def:20181202 unix
RHSA-2018:1203: java-1.6.0-sun security update (Important) oval:com.redhat.rhsa:def:20181203 unix
RHSA-2018:1204: java-1.8.0-oracle security update (Critical) oval:com.redhat.rhsa:def:20181204 unix
RHSA-2018:1205: java-1.6.0-sun security update (Important) oval:com.redhat.rhsa:def:20181205 unix
RHSA-2018:1206: java-1.7.0-oracle security update (Critical) oval:com.redhat.rhsa:def:20181206 unix
RHSA-2018:1270: java-1.7.0-openjdk security update (Important) oval:com.redhat.rhsa:def:20181270 unix
RHSA-2018:1278: java-1.7.0-openjdk security update (Important) oval:com.redhat.rhsa:def:20181278 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-2800

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 17.10 * * * Version Details Vulnerabilities
4 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
5 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
6 Application HP Xp7 Command View * * * * Version Details Vulnerabilities
7 Application Oracle JDK 1.6.0 Update 181 * * Version Details Vulnerabilities
8 Application Oracle JDK 1.7.0 Update171 * * Version Details Vulnerabilities
9 Application Oracle JDK 1.8.0 Update162 * * Version Details Vulnerabilities
10 Application Oracle JRE 1.6.0 Update 181 * * Version Details Vulnerabilities
11 Application Oracle JRE 1.7.0 Update 171 * * Version Details Vulnerabilities
12 Application Oracle JRE 1.8.0 Update 162 * * Version Details Vulnerabilities
13 Application Oracle Jrockit R28.3.17 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Desktop 6.0 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Server 6.0 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux Server Aus 7.6 * * * Version Details Vulnerabilities
19 OS Redhat Enterprise Linux Server Eus 7.5 * * * Version Details Vulnerabilities
20 OS Redhat Enterprise Linux Server Eus 7.6 * * * Version Details Vulnerabilities
21 OS Redhat Enterprise Linux Server Tus 7.6 * * * Version Details Vulnerabilities
22 OS Redhat Enterprise Linux Workstation 6.0 * * * Version Details Vulnerabilities
23 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities
24 Application Redhat Satellite 5.6 * * * Version Details Vulnerabilities
25 Application Redhat Satellite 5.7 * * * Version Details Vulnerabilities
26 Application Redhat Satellite 5.8 * * * Version Details Vulnerabilities
27 Application Schneider-electric Struxureware Data Center Expert * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Debian Debian Linux 2
HP Xp7 Command View 1
Oracle JDK 3
Oracle JRE 3
Oracle Jrockit 1
Redhat Enterprise Linux Desktop 2
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server Eus 2
Redhat Enterprise Linux Server Tus 1
Redhat Enterprise Linux Workstation 2
Redhat Satellite 3
Schneider-electric Struxureware Data Center Expert 1

- References For CVE-2018-2800

https://security.gentoo.org/glsa/201903-14
GENTOO GLSA-201903-14
https://www.debian.org/security/2018/dsa-4225
DEBIAN DSA-4225
https://access.redhat.com/errata/RHSA-2018:1201
REDHAT RHSA-2018:1201
https://www.debian.org/security/2018/dsa-4185
DEBIAN DSA-4185
https://access.redhat.com/errata/RHSA-2018:1270
REDHAT RHSA-2018:1270
https://access.redhat.com/errata/RHSA-2018:1278
REDHAT RHSA-2018:1278
https://usn.ubuntu.com/3644-1/
UBUNTU USN-3644-1
https://access.redhat.com/errata/RHSA-2018:1974
REDHAT RHSA-2018:1974
https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0 CONFIRM
https://usn.ubuntu.com/3691-1/
UBUNTU USN-3691-1
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03915en_us CONFIRM
https://access.redhat.com/errata/RHSA-2018:1723
REDHAT RHSA-2018:1723
https://access.redhat.com/errata/RHSA-2018:1722
REDHAT RHSA-2018:1722
https://access.redhat.com/errata/RHSA-2018:1721
REDHAT RHSA-2018:1721
https://access.redhat.com/errata/RHSA-2018:1975
REDHAT RHSA-2018:1975
https://access.redhat.com/errata/RHSA-2018:1204
REDHAT RHSA-2018:1204
https://access.redhat.com/errata/RHSA-2018:1203
REDHAT RHSA-2018:1203
https://access.redhat.com/errata/RHSA-2018:1202
REDHAT RHSA-2018:1202
https://access.redhat.com/errata/RHSA-2018:1724
REDHAT RHSA-2018:1724
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03857en_us CONFIRM
https://access.redhat.com/errata/RHSA-2018:1206
REDHAT RHSA-2018:1206
https://access.redhat.com/errata/RHSA-2018:1205
REDHAT RHSA-2018:1205
https://access.redhat.com/errata/RHSA-2018:1188
REDHAT RHSA-2018:1188
https://security.netapp.com/advisory/ntap-20180419-0001/ CONFIRM
https://access.redhat.com/errata/RHSA-2018:1191
REDHAT RHSA-2018:1191
http://www.securityfocus.com/bid/103849
BID 103849 Oracle Java SE and JRockit CVE-2018-2800 Remote Security Vulnerability Release Date:2018-04-30
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html CONFIRM
http://www.securitytracker.com/id/1040697
SECTRACK 1040697

- Metasploit Modules Related To CVE-2018-2800

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.