CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-2657

Vulnerability in the Java SE, JRockit component of Oracle Java SE (subcomponent: Serialization). Supported versions that are affected are Java SE: 6u171 and 7u161; JRockit: R28.3.16. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, JRockit. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, JRockit. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).
Publish Date : 2018-01-17 Last Update Date : 2019-10-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2018:0100: java-1.7.0-oracle security update (Important) oval:com.redhat.rhsa:def:20180100 unix
RHSA-2018:0115: java-1.6.0-sun security update (Important) oval:com.redhat.rhsa:def:20180115 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-2657

# Product Type Vendor Product Version Update Edition Language
1 Application Oracle JDK 1.6.0 Update 171 Version Details Vulnerabilities
2 Application Oracle JDK 1.7.0 Update 161 Version Details Vulnerabilities
3 Application Oracle JRE 1.6.0 Update 171 Version Details Vulnerabilities
4 Application Oracle JRE 1.7.0 Update 161 Version Details Vulnerabilities
5 Application Oracle Jrockit R28.3.16 Version Details Vulnerabilities
6 OS Redhat Enterprise Linux Desktop 6.0 Version Details Vulnerabilities
7 OS Redhat Enterprise Linux Server 6.0 Version Details Vulnerabilities
8 OS Redhat Enterprise Linux Server 7.0 Version Details Vulnerabilities
9 OS Redhat Enterprise Linux Server Eus 7.5 Version Details Vulnerabilities
10 OS Redhat Enterprise Linux Workstation 6.0 Version Details Vulnerabilities
11 Application Redhat Satellite 5.6 Version Details Vulnerabilities
12 Application Redhat Satellite 5.7 Version Details Vulnerabilities
13 Application Redhat Satellite 5.8 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Oracle JDK 2
Oracle JRE 2
Oracle Jrockit 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Eus 1
Redhat Enterprise Linux Workstation 1
Redhat Satellite 3

- References For CVE-2018-2657

https://security.netapp.com/advisory/ntap-20180117-0001/ CONFIRM
https://access.redhat.com/errata/RHSA-2018:0458
REDHAT RHSA-2018:0458
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03911en_us CONFIRM
https://access.redhat.com/errata/RHSA-2018:1812
REDHAT RHSA-2018:1812
https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0 CONFIRM
https://access.redhat.com/errata/RHSA-2018:0100
REDHAT RHSA-2018:0100
https://access.redhat.com/errata/RHSA-2018:0115
REDHAT RHSA-2018:0115
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html CONFIRM
https://access.redhat.com/errata/RHSA-2018:1463
REDHAT RHSA-2018:1463
https://access.redhat.com/errata/RHSA-2018:0521
REDHAT RHSA-2018:0521
http://www.securitytracker.com/id/1040203
SECTRACK 1040203
http://www.securityfocus.com/bid/102629
BID 102629 Oracle Java SE and JRockit CVE-2018-2657 Remote Security Vulnerability Release Date:2018-01-16

- Metasploit Modules Related To CVE-2018-2657

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.