CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-19489

v9fs_wstat in hw/9pfs/9p.c in QEMU allows guest OS users to cause a denial of service (crash) because of a race condition during file renaming.
Publish Date : 2018-12-13 Last Update Date : 2019-01-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 362

- Products Affected By CVE-2018-19489

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
2 OS Debian Debian Linux 9.0 Version Details Vulnerabilities
3 Application Qemu Qemu - Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 2
Qemu Qemu 1

- References For CVE-2018-19489

https://lists.gnu.org/archive/html/qemu-devel/2018-11/msg04489.html
MLIST [qemu-devel] 20181122 9p: fix QEMU crash when renaming files
https://security-tracker.debian.org/tracker/CVE-2018-19489 CONFIRM
http://www.securityfocus.com/bid/106007
BID 106007 QEMU CVE-2018-19489 Local Denial of Service Vulnerability Release Date:2018-11-22
https://exchange.xforce.ibmcloud.com/vulnerabilities/153326
XF qemu-cve201819489-dos(153326)
https://git.qemu.org/?p=qemu.git;a=commit;h=1d20398694a3b67a388d955b7a945ba4aa90a8a8 CONFIRM
http://www.openwall.com/lists/oss-security/2018/11/26/1
MLIST [oss-security] 20181126 CVE-2018-19489 QEMU: 9pfs: crash due to race condition in renaming files

- Metasploit Modules Related To CVE-2018-19489

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.