CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-19207

The Van Ons WP GDPR Compliance (aka wp-gdpr-compliance) plugin before 1.4.3 for WordPress allows remote attackers to execute arbitrary code because $wpdb->prepare() input is mishandled, as exploited in the wild in November 2018.
Publish Date : 2018-11-12 Last Update Date : 2019-10-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 425

- Products Affected By CVE-2018-19207

# Product Type Vendor Product Version Update Edition Language
1 Application Van-ons Wp-gdpr-compliance 1.0 ~~~wordpress~~ Version Details Vulnerabilities
2 Application Van-ons Wp-gdpr-compliance 1.1 ~~~wordpress~~ Version Details Vulnerabilities
3 Application Van-ons Wp-gdpr-compliance 1.1.1 ~~~wordpress~~ Version Details Vulnerabilities
4 Application Van-ons Wp-gdpr-compliance 1.1.2 ~~~wordpress~~ Version Details Vulnerabilities
5 Application Van-ons Wp-gdpr-compliance 1.2 ~~~wordpress~~ Version Details Vulnerabilities
6 Application Van-ons Wp-gdpr-compliance 1.2.1 ~~~wordpress~~ Version Details Vulnerabilities
7 Application Van-ons Wp-gdpr-compliance 1.2.2 ~~~wordpress~~ Version Details Vulnerabilities
8 Application Van-ons Wp-gdpr-compliance 1.2.3 ~~~wordpress~~ Version Details Vulnerabilities
9 Application Van-ons Wp-gdpr-compliance 1.2.4 ~~~wordpress~~ Version Details Vulnerabilities
10 Application Van-ons Wp-gdpr-compliance 1.3 ~~~wordpress~~ Version Details Vulnerabilities
11 Application Van-ons Wp-gdpr-compliance 1.3.1 ~~~wordpress~~ Version Details Vulnerabilities
12 Application Van-ons Wp-gdpr-compliance 1.3.2 ~~~wordpress~~ Version Details Vulnerabilities
13 Application Van-ons Wp-gdpr-compliance 1.3.3 ~~~wordpress~~ Version Details Vulnerabilities
14 Application Van-ons Wp-gdpr-compliance 1.3.4 ~~~wordpress~~ Version Details Vulnerabilities
15 Application Van-ons Wp-gdpr-compliance 1.3.5 ~~~wordpress~~ Version Details Vulnerabilities
16 Application Van-ons Wp-gdpr-compliance 1.3.6 ~~~wordpress~~ Version Details Vulnerabilities
17 Application Van-ons Wp-gdpr-compliance 1.3.7 ~~~wordpress~~ Version Details Vulnerabilities
18 Application Van-ons Wp-gdpr-compliance 1.3.8 ~~~wordpress~~ Version Details Vulnerabilities
19 Application Van-ons Wp-gdpr-compliance 1.3.9 ~~~wordpress~~ Version Details Vulnerabilities
20 Application Van-ons Wp-gdpr-compliance 1.4.0 ~~~wordpress~~ Version Details Vulnerabilities
21 Application Van-ons Wp-gdpr-compliance 1.4.1 ~~~wordpress~~ Version Details Vulnerabilities
22 Application Van-ons Wp-gdpr-compliance 1.4.2 ~~~wordpress~~ Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Van-ons Wp-gdpr-compliance 22

- References For CVE-2018-19207

https://wpvulndb.com/vulnerabilities/9144
https://www.wordfence.com/blog/2018/11/trends-following-vulnerability-in-wp-gdpr-compliance-plugin/
http://www.securityfocus.com/bid/105921
BID 105921 WordPress WP GDPR Compliance Plugin CVE-2018-19207 Privilege Escalation Vulnerability Release Date:2018-11-08
https://wordpress.org/plugins/wp-gdpr-compliance/#developers

- Metasploit Modules Related To CVE-2018-19207

WordPress WP GDPR Compliance Plugin Privilege Escalation
The Wordpress GDPR Compliance plugin <= v1.4.2 allows unauthenticated users to set wordpress administration options by overwriting values within the database. The vulnerability is present in WordPress’s admin-ajax.php, which allows unauthorized users to trigger handlers and make configuration changes because of a failure to do capability checks when executing the 'save_setting' internal action. WARNING: The module sets Wordpress configuration options without reading their current values and restoring them later.
Module type : auxiliary Rank : normal


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.