CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-16842

Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.
Publish Date : 2018-10-31 Last Update Date : 2019-08-06
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 125

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:2181: curl security and bug fix update (Low) oval:com.redhat.rhsa:def:20192181 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-16842

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 12.04 ~~esm~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 16.04 ~~lts~~~ Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 18.04 ~~lts~~~ Version Details Vulnerabilities
5 OS Canonical Ubuntu Linux 18.10 Version Details Vulnerabilities
6 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
7 OS Debian Debian Linux 9.0 Version Details Vulnerabilities
8 Application Haxx Curl 7.14.1 Version Details Vulnerabilities
9 Application Haxx Curl 7.15.0 Version Details Vulnerabilities
10 Application Haxx Curl 7.15.1 Version Details Vulnerabilities
11 Application Haxx Curl 7.15.2 Version Details Vulnerabilities
12 Application Haxx Curl 7.15.3 Version Details Vulnerabilities
13 Application Haxx Curl 7.15.4 Version Details Vulnerabilities
14 Application Haxx Curl 7.15.5 Version Details Vulnerabilities
15 Application Haxx Curl 7.16.0 Version Details Vulnerabilities
16 Application Haxx Curl 7.16.1 Version Details Vulnerabilities
17 Application Haxx Curl 7.16.2 Version Details Vulnerabilities
18 Application Haxx Curl 7.16.3 Version Details Vulnerabilities
19 Application Haxx Curl 7.16.4 Version Details Vulnerabilities
20 Application Haxx Curl 7.17.0 Version Details Vulnerabilities
21 Application Haxx Curl 7.17.1 Version Details Vulnerabilities
22 Application Haxx Curl 7.18.0 Version Details Vulnerabilities
23 Application Haxx Curl 7.18.1 Version Details Vulnerabilities
24 Application Haxx Curl 7.18.2 Version Details Vulnerabilities
25 Application Haxx Curl 7.19.0 Version Details Vulnerabilities
26 Application Haxx Curl 7.19.1 Version Details Vulnerabilities
27 Application Haxx Curl 7.19.2 Version Details Vulnerabilities
28 Application Haxx Curl 7.19.3 Version Details Vulnerabilities
29 Application Haxx Curl 7.19.4 Version Details Vulnerabilities
30 Application Haxx Curl 7.19.5 Version Details Vulnerabilities
31 Application Haxx Curl 7.19.6 Version Details Vulnerabilities
32 Application Haxx Curl 7.19.7 Version Details Vulnerabilities
33 Application Haxx Curl 7.20.0 Version Details Vulnerabilities
34 Application Haxx Curl 7.20.1 Version Details Vulnerabilities
35 Application Haxx Curl 7.21.0 Version Details Vulnerabilities
36 Application Haxx Curl 7.21.1 Version Details Vulnerabilities
37 Application Haxx Curl 7.21.2 Version Details Vulnerabilities
38 Application Haxx Curl 7.21.3 Version Details Vulnerabilities
39 Application Haxx Curl 7.21.4 Version Details Vulnerabilities
40 Application Haxx Curl 7.21.5 Version Details Vulnerabilities
41 Application Haxx Curl 7.21.6 Version Details Vulnerabilities
42 Application Haxx Curl 7.21.7 Version Details Vulnerabilities
43 Application Haxx Curl 7.22.0 Version Details Vulnerabilities
44 Application Haxx Curl 7.23.0 Version Details Vulnerabilities
45 Application Haxx Curl 7.23.1 Version Details Vulnerabilities
46 Application Haxx Curl 7.24.0 Version Details Vulnerabilities
47 Application Haxx Curl 7.25.0 Version Details Vulnerabilities
48 Application Haxx Curl 7.26.0 Version Details Vulnerabilities
49 Application Haxx Curl 7.27.0 Version Details Vulnerabilities
50 Application Haxx Curl 7.28.0 Version Details Vulnerabilities
51 Application Haxx Curl 7.28.1 Version Details Vulnerabilities
52 Application Haxx Curl 7.29.0 Version Details Vulnerabilities
53 Application Haxx Curl 7.30.0 Version Details Vulnerabilities
54 Application Haxx Curl 7.31.0 Version Details Vulnerabilities
55 Application Haxx Curl 7.32.0 Version Details Vulnerabilities
56 Application Haxx Curl 7.33.0 Version Details Vulnerabilities
57 Application Haxx Curl 7.34.0 Version Details Vulnerabilities
58 Application Haxx Curl 7.35.0 Version Details Vulnerabilities
59 Application Haxx Curl 7.36.0 Version Details Vulnerabilities
60 Application Haxx Curl 7.37.0 Version Details Vulnerabilities
61 Application Haxx Curl 7.37.1 Version Details Vulnerabilities
62 Application Haxx Curl 7.38.0 Version Details Vulnerabilities
63 Application Haxx Curl 7.39.0 Version Details Vulnerabilities
64 Application Haxx Curl 7.40.0 Version Details Vulnerabilities
65 Application Haxx Curl 7.41.0 Version Details Vulnerabilities
66 Application Haxx Curl 7.42.0 Version Details Vulnerabilities
67 Application Haxx Curl 7.42.1 Version Details Vulnerabilities
68 Application Haxx Curl 7.43.0 Version Details Vulnerabilities
69 Application Haxx Curl 7.44.0 Version Details Vulnerabilities
70 Application Haxx Curl 7.45.0 Version Details Vulnerabilities
71 Application Haxx Curl 7.46.0 Version Details Vulnerabilities
72 Application Haxx Curl 7.47.0 Version Details Vulnerabilities
73 Application Haxx Curl 7.47.1 Version Details Vulnerabilities
74 Application Haxx Curl 7.48.0 Version Details Vulnerabilities
75 Application Haxx Curl 7.49.0 Version Details Vulnerabilities
76 Application Haxx Curl 7.49.1 Version Details Vulnerabilities
77 Application Haxx Curl 7.50.0 Version Details Vulnerabilities
78 Application Haxx Curl 7.50.1 Version Details Vulnerabilities
79 Application Haxx Curl 7.50.2 Version Details Vulnerabilities
80 Application Haxx Curl 7.50.3 Version Details Vulnerabilities
81 Application Haxx Curl 7.51.0 Version Details Vulnerabilities
82 Application Haxx Curl 7.52.0 Version Details Vulnerabilities
83 Application Haxx Curl 7.52.1 Version Details Vulnerabilities
84 Application Haxx Curl 7.53.0 Version Details Vulnerabilities
85 Application Haxx Curl 7.53.1 Version Details Vulnerabilities
86 Application Haxx Curl 7.54.0 Version Details Vulnerabilities
87 Application Haxx Curl 7.54.1 Version Details Vulnerabilities
88 Application Haxx Curl 7.55.0 Version Details Vulnerabilities
89 Application Haxx Curl 7.55.1 Version Details Vulnerabilities
90 Application Haxx Curl 7.56.0 Version Details Vulnerabilities
91 Application Haxx Curl 7.56.1 Version Details Vulnerabilities
92 Application Haxx Curl 7.57.0 Version Details Vulnerabilities
93 Application Haxx Curl 7.58.0 Version Details Vulnerabilities
94 Application Haxx Curl 7.59.0 Version Details Vulnerabilities
95 Application Haxx Curl 7.60.0 Version Details Vulnerabilities
96 Application Haxx Curl 7.61.0 Version Details Vulnerabilities
97 Application Haxx Curl 7.61.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 5
Debian Debian Linux 2
Haxx Curl 90

- References For CVE-2018-16842

https://usn.ubuntu.com/3805-2/
UBUNTU USN-3805-2
https://usn.ubuntu.com/3805-1/
UBUNTU USN-3805-1
https://security.gentoo.org/glsa/201903-03
GENTOO GLSA-201903-03
https://lists.debian.org/debian-lts-announce/2018/11/msg00005.html
MLIST [debian-lts-announce] 20181106 [SECURITY] [DLA 1568-1] curl security update
https://github.com/curl/curl/commit/d530e92f59ae9bb2d47066c3c460b25d2ffeb211 CONFIRM
http://www.securitytracker.com/id/1042014
SECTRACK 1042014
https://access.redhat.com/errata/RHSA-2019:2181
REDHAT RHSA-2019:2181
https://www.debian.org/security/2018/dsa-4331
DEBIAN DSA-4331
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16842 CONFIRM
https://curl.haxx.se/docs/CVE-2018-16842.html

- Metasploit Modules Related To CVE-2018-16842

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.