CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-14682

An issue was discovered in mspack/chmd.c in libmspack before 0.7alpha. There is an off-by-one error in the TOLOWER() macro for CHM decompression.
Publish Date : 2018-07-28 Last Update Date : 2019-03-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.8
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 682

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2018:3327: libmspack security update (Low) oval:com.redhat.rhsa:def:20183327 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-14682

# Product Type Vendor Product Version Update Edition Language
1 Application Cabextract Cabextract 1.5 Version Details Vulnerabilities
2 Application Cabextract Libmspack 0.0.20060920 Alpha Version Details Vulnerabilities
3 Application Cabextract Libmspack 0.3 Alpha Version Details Vulnerabilities
4 Application Cabextract Libmspack 0.4 Alpha Version Details Vulnerabilities
5 Application Cabextract Libmspack 0.5 Alpha Version Details Vulnerabilities
6 Application Cabextract Libmspack 0.6 Alpha Version Details Vulnerabilities
7 OS Canonical Ubuntu Linux 12.04 ~~esm~~~ Version Details Vulnerabilities
8 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
9 OS Canonical Ubuntu Linux 16.04 ~~lts~~~ Version Details Vulnerabilities
10 OS Canonical Ubuntu Linux 18.04 ~~lts~~~ Version Details Vulnerabilities
11 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
12 OS Debian Debian Linux 9.0 Version Details Vulnerabilities
13 Application Redhat Ansible Tower 3.3 Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Desktop 7.0 Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Server 7.0 Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Workstation 7.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Cabextract Cabextract 1
Cabextract Libmspack 5
Canonical Ubuntu Linux 4
Debian Debian Linux 2
Redhat Ansible Tower 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Workstation 1

- References For CVE-2018-14682

http://www.securitytracker.com/id/1041410
SECTRACK 1041410
https://www.debian.org/security/2018/dsa-4260
DEBIAN DSA-4260
https://usn.ubuntu.com/3789-2/
UBUNTU USN-3789-2
http://www.openwall.com/lists/oss-security/2018/07/26/1
https://bugs.debian.org/904800
https://github.com/kyz/libmspack/commit/4fd9ccaa54e1aebde1e4b95fb0163b699fd7bcc8
https://usn.ubuntu.com/3728-3/
UBUNTU USN-3728-3
https://usn.ubuntu.com/3728-2/
UBUNTU USN-3728-2
https://usn.ubuntu.com/3728-1/
UBUNTU USN-3728-1
https://security.gentoo.org/glsa/201903-20
GENTOO GLSA-201903-20
https://lists.debian.org/debian-lts-announce/2018/08/msg00007.html
MLIST [debian-lts-announce] 20180806 [SECURITY] [DLA-1460-1] libmspack security update
https://access.redhat.com/errata/RHSA-2018:3505
REDHAT RHSA-2018:3505
https://access.redhat.com/errata/RHSA-2018:3327
REDHAT RHSA-2018:3327

- Metasploit Modules Related To CVE-2018-14682

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.