CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-1287

In Apache JMeter 2.X and 3.X, when using Distributed Test only (RMI based), jmeter server binds RMI Registry to wildcard host. This could allow an attacker to get Access to JMeterEngine and send unauthorized code.
Publish Date : 2018-02-14 Last Update Date : 2019-10-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Products Affected By CVE-2018-1287

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Jmeter 2.1 Version Details Vulnerabilities
2 Application Apache Jmeter 2.2 Version Details Vulnerabilities
3 Application Apache Jmeter 2.3 Version Details Vulnerabilities
4 Application Apache Jmeter 2.3.1 Version Details Vulnerabilities
5 Application Apache Jmeter 2.3.2 Version Details Vulnerabilities
6 Application Apache Jmeter 2.3.3 Version Details Vulnerabilities
7 Application Apache Jmeter 2.3.3 RC1 Version Details Vulnerabilities
8 Application Apache Jmeter 2.3.3 RC2 Version Details Vulnerabilities
9 Application Apache Jmeter 2.3.4 RC2 Version Details Vulnerabilities
10 Application Apache Jmeter 2.3.4 RC3 Version Details Vulnerabilities
11 Application Apache Jmeter 2.3.4 Version Details Vulnerabilities
12 Application Apache Jmeter 2.3.4 RC1 Version Details Vulnerabilities
13 Application Apache Jmeter 2.4 Version Details Vulnerabilities
14 Application Apache Jmeter 2.5 RC2 Version Details Vulnerabilities
15 Application Apache Jmeter 2.5 RC3 Version Details Vulnerabilities
16 Application Apache Jmeter 2.5 Version Details Vulnerabilities
17 Application Apache Jmeter 2.5 RC1 Version Details Vulnerabilities
18 Application Apache Jmeter 2.5.1 Version Details Vulnerabilities
19 Application Apache Jmeter 2.5.1 RC1 Version Details Vulnerabilities
20 Application Apache Jmeter 2.5.1 RC2 Version Details Vulnerabilities
21 Application Apache Jmeter 2.5.1 RC3 Version Details Vulnerabilities
22 Application Apache Jmeter 2.6 Version Details Vulnerabilities
23 Application Apache Jmeter 2.6 RC1 Version Details Vulnerabilities
24 Application Apache Jmeter 2.6 RC2 Version Details Vulnerabilities
25 Application Apache Jmeter 2.7 RC2 Version Details Vulnerabilities
26 Application Apache Jmeter 2.7 RC3 Version Details Vulnerabilities
27 Application Apache Jmeter 2.7 Version Details Vulnerabilities
28 Application Apache Jmeter 2.7 RC1 Version Details Vulnerabilities
29 Application Apache Jmeter 2.8 Version Details Vulnerabilities
30 Application Apache Jmeter 2.8 RC1 Version Details Vulnerabilities
31 Application Apache Jmeter 2.8 RC2 Version Details Vulnerabilities
32 Application Apache Jmeter 2.9 Version Details Vulnerabilities
33 Application Apache Jmeter 2.9 RC1 Version Details Vulnerabilities
34 Application Apache Jmeter 2.9 RC2 Version Details Vulnerabilities
35 Application Apache Jmeter 2.9 RC3 Version Details Vulnerabilities
36 Application Apache Jmeter 2.10 RC1 Version Details Vulnerabilities
37 Application Apache Jmeter 2.10 RC2 Version Details Vulnerabilities
38 Application Apache Jmeter 2.11 Version Details Vulnerabilities
39 Application Apache Jmeter 2.11 RC1 Version Details Vulnerabilities
40 Application Apache Jmeter 2.11 RC2 Version Details Vulnerabilities
41 Application Apache Jmeter 2.12 RC2 Version Details Vulnerabilities
42 Application Apache Jmeter 2.12 Version Details Vulnerabilities
43 Application Apache Jmeter 2.12 RC1 Version Details Vulnerabilities
44 Application Apache Jmeter 2.13 Version Details Vulnerabilities
45 Application Apache Jmeter 2.13 RC1 Version Details Vulnerabilities
46 Application Apache Jmeter 2.13 RC2 Version Details Vulnerabilities
47 Application Apache Jmeter 3.0 RC2 Version Details Vulnerabilities
48 Application Apache Jmeter 3.0 RC3 Version Details Vulnerabilities
49 Application Apache Jmeter 3.0 RC4 Version Details Vulnerabilities
50 Application Apache Jmeter 3.0 RC5 Version Details Vulnerabilities
51 Application Apache Jmeter 3.0 Version Details Vulnerabilities
52 Application Apache Jmeter 3.0 RC1 Version Details Vulnerabilities
53 Application Apache Jmeter 3.1 RC1 Version Details Vulnerabilities
54 Application Apache Jmeter 3.1 RC2 Version Details Vulnerabilities
55 Application Apache Jmeter 3.1 RC3 Version Details Vulnerabilities
56 Application Apache Jmeter 3.1 RC4 Version Details Vulnerabilities
57 Application Apache Jmeter 3.1 Version Details Vulnerabilities
58 Application Apache Jmeter 3.2 RC1 Version Details Vulnerabilities
59 Application Apache Jmeter 3.2 RC2 Version Details Vulnerabilities
60 Application Apache Jmeter 3.2 RC3 Version Details Vulnerabilities
61 Application Apache Jmeter 3.2 Version Details Vulnerabilities
62 Application Apache Jmeter 3.3 Version Details Vulnerabilities
63 Application Apache Jmeter 3.3 RC1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Jmeter 63

- References For CVE-2018-1287

https://lists.apache.org/thread.html/[email protected]%3Cissues.jmeter.apache.org%3E
MLIST [jmeter-issues] 20190609 [Bug 62039] [CVE-2018-1287 & CVE-2018-1297] Distributed testing : Secure RMI connection by SSL and certificate and bind to host defined "java.rmi.server.hostname" system property
http://www.securityfocus.com/bid/103068
BID 103068 Apache JMeter CVE-2018-1287 Security Bypass Vulnerability Release Date:2018-02-14
http://mail-archives.apache.org/mod_mbox/www-announce/201802.mbox/%3CCAH9fUpYsFx1%2Brwz1A%3Dmc7wAgbDHARyj1VrWNg41y9OySuL1mqw%40mail.gmail.com%3E
MLIST [www-announce] 20180211 CVE-2018-1287: Apache JMeter binds RMI server to wildcard in distributed mode (based on RMI)

- Metasploit Modules Related To CVE-2018-1287

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.