CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-1116

A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.
Publish Date : 2018-07-10 Last Update Date : 2019-10-09
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
3.6
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Products Affected By CVE-2018-1116

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 12.04 ~~esm~~~ Version Details Vulnerabilities
2 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
3 Application Polkit Project Polkit - Version Details Vulnerabilities
4 Application Polkit Project Polkit 0.3 Version Details Vulnerabilities
5 Application Polkit Project Polkit 0.4 Version Details Vulnerabilities
6 Application Polkit Project Polkit 0.5 Version Details Vulnerabilities
7 Application Polkit Project Polkit 0.6 Version Details Vulnerabilities
8 Application Polkit Project Polkit 0.7 Version Details Vulnerabilities
9 Application Polkit Project Polkit 0.8 Version Details Vulnerabilities
10 Application Polkit Project Polkit 0.9 Version Details Vulnerabilities
11 Application Polkit Project Polkit 0.91 Version Details Vulnerabilities
12 Application Polkit Project Polkit 0.92 Version Details Vulnerabilities
13 Application Polkit Project Polkit 0.93 Version Details Vulnerabilities
14 Application Polkit Project Polkit 0.94 Version Details Vulnerabilities
15 Application Polkit Project Polkit 0.95 Version Details Vulnerabilities
16 Application Polkit Project Polkit 0.96 Version Details Vulnerabilities
17 Application Polkit Project Polkit 0.97 Version Details Vulnerabilities
18 Application Polkit Project Polkit 0.98 Version Details Vulnerabilities
19 Application Polkit Project Polkit 0.99 Version Details Vulnerabilities
20 Application Polkit Project Polkit 0.100 Version Details Vulnerabilities
21 Application Polkit Project Polkit 0.101 Version Details Vulnerabilities
22 Application Polkit Project Polkit 0.102 Version Details Vulnerabilities
23 Application Polkit Project Polkit 0.103 Version Details Vulnerabilities
24 Application Polkit Project Polkit 0.104 Version Details Vulnerabilities
25 Application Polkit Project Polkit 0.105 Version Details Vulnerabilities
26 Application Polkit Project Polkit 0.106 Version Details Vulnerabilities
27 Application Polkit Project Polkit 0.107 Version Details Vulnerabilities
28 Application Polkit Project Polkit 0.108 Version Details Vulnerabilities
29 Application Polkit Project Polkit 0.109 Version Details Vulnerabilities
30 Application Polkit Project Polkit 0.110 Version Details Vulnerabilities
31 Application Polkit Project Polkit 0.111 Version Details Vulnerabilities
32 Application Polkit Project Polkit 0.112 Version Details Vulnerabilities
33 Application Polkit Project Polkit 0.113 Version Details Vulnerabilities
34 Application Polkit Project Polkit 0.114 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 1
Debian Debian Linux 1
Polkit Project Polkit 32

- References For CVE-2018-1116

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1116 CONFIRM
https://usn.ubuntu.com/3717-2/
UBUNTU USN-3717-2
https://security.gentoo.org/glsa/201908-14
GENTOO GLSA-201908-14
https://lists.debian.org/debian-lts-announce/2018/07/msg00042.html
MLIST [debian-lts-announce] 20180728 [SECURITY] [DLA-1448-1] policykit-1 security update
https://cgit.freedesktop.org/polkit/commit/?id=bc7ffad5364 CONFIRM

- Metasploit Modules Related To CVE-2018-1116

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.