CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-10928

A flaw was found in RPC request using gfs3_symlink_req in glusterfs server which allows symlink destinations to point to file paths outside of the gluster volume. An authenticated attacker could use this flaw to create arbitrary symlinks pointing anywhere on the server and execute arbitrary code on glusterfs server nodes.
Publish Date : 2018-09-04 Last Update Date : 2019-04-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 59

- Products Affected By CVE-2018-10928

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
2 OS Redhat Enterprise Linux 6.0 Version Details Vulnerabilities
3 OS Redhat Enterprise Linux 7.0 Version Details Vulnerabilities
4 OS Redhat Enterprise Linux Server 6.0 Version Details Vulnerabilities
5 OS Redhat Enterprise Linux Server 7.0 Version Details Vulnerabilities
6 Application Redhat Gluster Storage 3.0 Version Details Vulnerabilities
7 OS Redhat Virtualization 4.0 Version Details Vulnerabilities
8 Application Redhat Virtualization Host 4.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 1
Redhat Enterprise Linux 2
Redhat Enterprise Linux Server 2
Redhat Gluster Storage 1
Redhat Virtualization 1
Redhat Virtualization Host 1

- References For CVE-2018-10928

https://security.gentoo.org/glsa/201904-06
GENTOO GLSA-201904-06
https://access.redhat.com/errata/RHSA-2018:2608
REDHAT RHSA-2018:2608
https://lists.debian.org/debian-lts-announce/2018/09/msg00021.html
MLIST [debian-lts-announce] 20180920 [SECURITY] [DLA 1510-1] glusterfs security update
https://access.redhat.com/errata/RHSA-2018:2607
REDHAT RHSA-2018:2607
https://access.redhat.com/errata/RHSA-2018:3470
REDHAT RHSA-2018:3470
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10928 CONFIRM

- Metasploit Modules Related To CVE-2018-10928

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.