CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-10915

A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.
Publish Date : 2018-08-09 Last Update Date : 2020-08-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication ???
Gained Access None
Vulnerability Type(s) Sql InjectionBypass a restriction or similar
CWE ID 89

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2018:2557: postgresql security update (Important) oval:com.redhat.rhsa:def:20182557 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-10915

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 18.04 * * * Version Details Vulnerabilities
4 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
5 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
6 Application Postgresql Postgresql * * * * Version Details Vulnerabilities
7 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
8 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
9 OS Redhat Enterprise Linux Server Eus 7.5 * * * Version Details Vulnerabilities
10 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities
11 Application Redhat Openstack 12.0 * * * Version Details Vulnerabilities
12 Application Redhat Openstack 13.0 * * * Version Details Vulnerabilities
13 Application Redhat Virtualization 4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Debian Debian Linux 2
Postgresql Postgresql 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Server Eus 1
Redhat Enterprise Linux Workstation 1
Redhat Openstack 2
Redhat Virtualization 1

- References For CVE-2018-10915

https://access.redhat.com/errata/RHSA-2018:2643
REDHAT RHSA-2018:2643
https://access.redhat.com/errata/RHSA-2018:2566
REDHAT RHSA-2018:2566
https://security.gentoo.org/glsa/201810-08
GENTOO GLSA-201810-08
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10915 CONFIRM
https://usn.ubuntu.com/3744-1/
UBUNTU USN-3744-1
https://access.redhat.com/errata/RHSA-2018:2565
REDHAT RHSA-2018:2565
https://lists.debian.org/debian-lts-announce/2018/08/msg00012.html
MLIST [debian-lts-announce] 20180815 [SECURITY] [DLA 1464-1] postgresql-9.4 security update
https://access.redhat.com/errata/RHSA-2018:2511
REDHAT RHSA-2018:2511
https://access.redhat.com/errata/RHSA-2018:2557
REDHAT RHSA-2018:2557
https://www.postgresql.org/about/news/1878/ CONFIRM
http://www.securitytracker.com/id/1041446
SECTRACK 1041446
https://access.redhat.com/errata/RHSA-2018:2721
REDHAT RHSA-2018:2721
http://www.securityfocus.com/bid/105054
BID 105054 PostgreSQL CVE-2018-10915 Security Bypass Vulnerability Release Date:2018-08-09
https://www.debian.org/security/2018/dsa-4269
DEBIAN DSA-4269
https://access.redhat.com/errata/RHSA-2018:3816
REDHAT RHSA-2018:3816
https://access.redhat.com/errata/RHSA-2018:2729
REDHAT RHSA-2018:2729
http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
SUSE openSUSE-SU-2020:1227

- Metasploit Modules Related To CVE-2018-10915

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.