Brave Software Inc. Brave version version 0.22.810 to 0.24.0 contains a Other/Unknown vulnerability in function ContentSettingsObserver::AllowScript() in content_settings_observer.cc that can result in Websites can run inline JavaScript even if script is blocked, making attackers easier to track users. This attack appear to be exploitable via the victim must visit a specially crafted website. This vulnerability appears to have been fixed in 0.25.2.
Published 2018-12-20 15:29:01
Updated 2019-02-06 14:36:31
Source MITRE
View at NVD,   CVE.org
Vulnerability category: Input validation

Exploit prediction scoring system (EPSS) score for CVE-2018-1000815

0.09%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 37 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2018-1000815

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.3
MEDIUM AV:N/AC:M/Au:N/C:P/I:N/A:N
8.6
2.9
NIST
4.3
MEDIUM CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
2.8
1.4
NIST

CWE ids for CVE-2018-1000815

  • The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2018-1000815

Products affected by CVE-2018-1000815

  • Brave » Brave
    Versions from including (>=) 0.22.810 and up to, including, (<=) 0.24.0
    cpe:2.3:a:brave:brave:*:*:*:*:*:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!