CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-0739

Constructed ASN.1 types with a recursive definition (such as can be found in PKCS7) could eventually exceed the stack given malicious input with excessive recursion. This could result in a Denial Of Service attack. There are no such structures used within SSL/TLS that come from untrusted sources so this is considered safe. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g). Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n).
Publish Date : 2018-03-27 Last Update Date : 2019-04-23
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 400

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2018:3090: ovmf security, bug fix, and enhancement update (Moderate) oval:com.redhat.rhsa:def:20183090 unix
RHSA-2018:3221: openssl security, bug fix, and enhancement update (Moderate) oval:com.redhat.rhsa:def:20183221 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2018-0739

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 ~~lts~~~ Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 17.10 Version Details Vulnerabilities
4 OS Debian Debian Linux 7.0 Version Details Vulnerabilities
5 OS Debian Debian Linux 8.0 Version Details Vulnerabilities
6 OS Debian Debian Linux 9.0 Version Details Vulnerabilities
7 Application Openssl Openssl 1.0.2k Version Details Vulnerabilities
8 Application Openssl Openssl 1.0.2c Version Details Vulnerabilities
9 Application Openssl Openssl 1.0.2l Version Details Vulnerabilities
10 Application Openssl Openssl 1.0.2d Version Details Vulnerabilities
11 Application Openssl Openssl 1.0.2m Version Details Vulnerabilities
12 Application Openssl Openssl 1.0.2h Version Details Vulnerabilities
13 Application Openssl Openssl 1.0.2e Version Details Vulnerabilities
14 Application Openssl Openssl 1.0.2n Version Details Vulnerabilities
15 Application Openssl Openssl 1.0.2i Version Details Vulnerabilities
16 Application Openssl Openssl 1.0.2f Version Details Vulnerabilities
17 Application Openssl Openssl 1.0.2j Version Details Vulnerabilities
18 Application Openssl Openssl 1.0.2g Version Details Vulnerabilities
19 Application Openssl Openssl 1.0.2b Version Details Vulnerabilities
20 Application Openssl Openssl 1.1.0 - Version Details Vulnerabilities
21 Application Openssl Openssl 1.1.0e Version Details Vulnerabilities
22 Application Openssl Openssl 1.1.0 Pre6 Version Details Vulnerabilities
23 Application Openssl Openssl 1.1.0 Pre1 Version Details Vulnerabilities
24 Application Openssl Openssl 1.1.0f Version Details Vulnerabilities
25 Application Openssl Openssl 1.1.0a Version Details Vulnerabilities
26 Application Openssl Openssl 1.1.0 Pre2 Version Details Vulnerabilities
27 Application Openssl Openssl 1.1.0g Version Details Vulnerabilities
28 Application Openssl Openssl 1.1.0b Version Details Vulnerabilities
29 Application Openssl Openssl 1.1.0 Pre3 Version Details Vulnerabilities
30 Application Openssl Openssl 1.1.0c Version Details Vulnerabilities
31 Application Openssl Openssl 1.1.0 Pre4 Version Details Vulnerabilities
32 Application Openssl Openssl 1.1.0 Version Details Vulnerabilities
33 Application Openssl Openssl 1.1.0d Version Details Vulnerabilities
34 Application Openssl Openssl 1.1.0 Pre5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Debian Debian Linux 3
Openssl Openssl 28

- References For CVE-2018-0739

https://access.redhat.com/errata/RHSA-2018:3505
REDHAT RHSA-2018:3505
https://access.redhat.com/errata/RHSA-2019:0367
REDHAT RHSA-2019:0367
http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html CONFIRM
https://access.redhat.com/errata/RHSA-2019:0366
REDHAT RHSA-2019:0366
https://nodejs.org/en/blog/vulnerability/march-2018-security-releases/ CONFIRM
https://security.netapp.com/advisory/ntap-20180726-0002/ CONFIRM
https://access.redhat.com/errata/RHSA-2018:3090
REDHAT RHSA-2018:3090
https://access.redhat.com/errata/RHSA-2018:3221
REDHAT RHSA-2018:3221
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.tenable.com/security/tns-2018-04 CONFIRM
https://www.debian.org/security/2018/dsa-4158
DEBIAN DSA-4158
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html CONFIRM
https://www.openssl.org/news/secadv/20180327.txt CONFIRM
https://www.debian.org/security/2018/dsa-4157
DEBIAN DSA-4157
https://security.netapp.com/advisory/ntap-20180330-0002/ CONFIRM
https://usn.ubuntu.com/3611-1/
UBUNTU USN-3611-1
http://www.securityfocus.com/bid/103518
BID 103518 OpenSSL CVE-2018-0739 Denial of Service Vulnerability Release Date:2019-02-13
https://usn.ubuntu.com/3611-2/
UBUNTU USN-3611-2
https://security.gentoo.org/glsa/201811-21
GENTOO GLSA-201811-21
https://securityadvisories.paloaltonetworks.com/Home/Detail/133 CONFIRM
https://www.tenable.com/security/tns-2018-06 CONFIRM
https://www.tenable.com/security/tns-2018-07 CONFIRM
https://lists.debian.org/debian-lts-announce/2018/03/msg00033.html
MLIST [debian-lts-announce] 20180330 [SECURITY] [DLA 1330-1] openssl security update
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=9310d45087ae546e27e61ddf8f6367f29848220d CONFIRM
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=2ac4c6f7b2b2af20c0e2b0ba05367e454cd11b33 CONFIRM
http://www.securitytracker.com/id/1040576
SECTRACK 1040576
http://www.securityfocus.com/bid/105609
BID 105609 Oracle PeopleSoft Enterprise PeopleTools Multiple Remote Security Vulnerabilities Release Date:2018-10-29
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html CONFIRM

- Metasploit Modules Related To CVE-2018-0739

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.