CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-2692

The Keyguard application in ALE-L02C635B140 and earlier versions,ALE-L02C636B140 and earlier versions,ALE-L21C10B150 and earlier versions,ALE-L21C185B200 and earlier versions,ALE-L21C432B214 and earlier versions,ALE-L21C464B150 and earlier versions,ALE-L21C636B200 and earlier versions,ALE-L23C605B190 and earlier versions,ALE-TL00C01B250 and earlier versions,ALE-UL00C00B250 and earlier versions,MT7-L09C605B325 and earlier versions,MT7-L09C900B339 and earlier versions,MT7-TL10C900B339 and earlier versions,CRR-CL00C92B172 and earlier versions,CRR-L09C432B180 and earlier versions,CRR-TL00C01B172 and earlier versions,CRR-UL00C00B172 and earlier versions,CRR-UL20C432B171 and earlier versions,GRA-CL00C92B230 and earlier versions,GRA-L09C432B222 and earlier versions,GRA-TL00C01B230SP01 and earlier versions,GRA-UL00C00B230 and earlier versions,GRA-UL00C10B201 and earlier versions,GRA-UL00C432B220 and earlier versions,H60-L04C10B523 and earlier versions,H60-L04C185B523 and earlier versions,H60-L04C636B527 and earlier versions,H60-L04C900B530 and earlier versions,PLK-AL10C00B220 and earlier versions,PLK-AL10C92B220 and earlier versions,PLK-CL00C92B220 and earlier versions,PLK-L01C10B140 and earlier versions,PLK-L01C185B130 and earlier versions,PLK-L01C432B187 and earlier versions,PLK-L01C432B190 and earlier versions,PLK-L01C432B190 and earlier versions,PLK-L01C636B130 and earlier versions,PLK-TL00C01B220 and earlier versions,PLK-TL01HC01B220 and earlier versions,PLK-UL00C17B220 and earlier versions,ATH-AL00C00B210 and earlier versions,ATH-AL00C92B200 and earlier versions,ATH-CL00C92B210 and earlier versions,ATH-TL00C01B210 and earlier versions,ATH-TL00HC01B210 and earlier versions,ATH-UL00C00B210 and earlier versions,RIO-AL00C00B220 and earlier versions,RIO-CL00C92B220 and earlier versions,RIO-TL00C01B220 and earlier versions,RIO-UL00C00B220 and earlier versions have a privilege elevation vulnerability. An attacker may exploit it to launch command injection in order to gain elevated privileges.
Publish Date : 2017-11-22 Last Update Date : 2017-12-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.8
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Gain privileges
CWE ID 77

- Products Affected By CVE-2017-2692

# Product Type Vendor Product Version Update Edition Language
1 OS Huawei G8 Firmware Rio-al00c00b220 Version Details Vulnerabilities
2 OS Huawei G8 Firmware Rio-cl00c92b220 Version Details Vulnerabilities
3 OS Huawei G8 Firmware Rio-tl00c01b220 Version Details Vulnerabilities
4 OS Huawei G8 Firmware Rio-ul00c00b220 Version Details Vulnerabilities
5 OS Huawei Honor 6 Firmware H60-l04c10b523 Version Details Vulnerabilities
6 OS Huawei Honor 6 Firmware H60-l04c185b523 Version Details Vulnerabilities
7 OS Huawei Honor 6 Firmware H60-l04c636b527 Version Details Vulnerabilities
8 OS Huawei Honor 6 Firmware H60-l04c900b530 Version Details Vulnerabilities
9 OS Huawei Honor 7 Firmware Plk-al10c00b220 Version Details Vulnerabilities
10 OS Huawei Honor 7 Firmware Plk-al10c92b220 Version Details Vulnerabilities
11 OS Huawei Honor 7 Firmware Plk-cl00c92b220 Version Details Vulnerabilities
12 OS Huawei Honor 7 Firmware Plk-l01c10b140 Version Details Vulnerabilities
13 OS Huawei Honor 7 Firmware Plk-l01c432b187 Version Details Vulnerabilities
14 OS Huawei Honor 7 Firmware Plk-l01c432b190 Version Details Vulnerabilities
15 OS Huawei Honor 7 Firmware Plk-l01c636b130 Version Details Vulnerabilities
16 OS Huawei Honor 7 Firmware Plk-tl00c01b220 Version Details Vulnerabilities
17 OS Huawei Honor 7 Firmware Plk-tl01hc01b220 Version Details Vulnerabilities
18 OS Huawei Honor 7 Firmware Plk-ul00c17b220 Version Details Vulnerabilities
19 OS Huawei Mate 7 Firmware Mt7-l09c605b325 Version Details Vulnerabilities
20 OS Huawei Mate 7 Firmware Mt7-l09c900b339 Version Details Vulnerabilities
21 OS Huawei Mate 7 Firmware Mt7-tl10c900b339 Version Details Vulnerabilities
22 OS Huawei Mate S Firmware Crr-cl00c92b172 Version Details Vulnerabilities
23 OS Huawei Mate S Firmware Crr-l09c432b180 Version Details Vulnerabilities
24 OS Huawei Mate S Firmware Crr-tl00c01b172 Version Details Vulnerabilities
25 OS Huawei Mate S Firmware Crr-ul00c00b172 Version Details Vulnerabilities
26 OS Huawei Mate S Firmware Crr-ul20c432b171 Version Details Vulnerabilities
27 OS Huawei P8 Firmware Gra-cl00c92b230 Version Details Vulnerabilities
28 OS Huawei P8 Firmware Gra-l09c432b222 Version Details Vulnerabilities
29 OS Huawei P8 Firmware Gra-tl00c01b230sp01 Version Details Vulnerabilities
30 OS Huawei P8 Firmware Gra-ul00c00b230 Version Details Vulnerabilities
31 OS Huawei P8 Firmware Gra-ul00c10b201 Version Details Vulnerabilities
32 OS Huawei P8 Firmware Gra-ul00c432b220 Version Details Vulnerabilities
33 OS Huawei P8 Lite Firmware Ale-ul00c00b250. Version Details Vulnerabilities
34 OS Huawei P8 Lite Firmware Ale-l02c635b140 Version Details Vulnerabilities
35 OS Huawei P8 Lite Firmware Ale-l02c636b140 Version Details Vulnerabilities
36 OS Huawei P8 Lite Firmware Ale-l21c10b150 Version Details Vulnerabilities
37 OS Huawei P8 Lite Firmware Ale-l21c185b200 Version Details Vulnerabilities
38 OS Huawei P8 Lite Firmware Ale-l21c432b214 Version Details Vulnerabilities
39 OS Huawei P8 Lite Firmware Ale-l21c464b150 Version Details Vulnerabilities
40 OS Huawei P8 Lite Firmware Ale-l21c636b200 Version Details Vulnerabilities
41 OS Huawei P8 Lite Firmware Ale-l23c605b190 Version Details Vulnerabilities
42 OS Huawei P8 Lite Firmware Ale-tl00c01b250 Version Details Vulnerabilities
43 OS Huawei Shotx Firmware Ath-al00c00b210 Version Details Vulnerabilities
44 OS Huawei Shotx Firmware Ath-al00c92b200 Version Details Vulnerabilities
45 OS Huawei Shotx Firmware Ath-cl00c92b210 Version Details Vulnerabilities
46 OS Huawei Shotx Firmware Ath-tl00c01b210 Version Details Vulnerabilities
47 OS Huawei Shotx Firmware Ath-tl00hc01b210 Version Details Vulnerabilities
48 OS Huawei Shotx Firmware Ath-ul00c00b210 Version Details Vulnerabilities
49 OS Huawei Shotx Firmware Rio-al00c00b220 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Huawei G8 Firmware 4
Huawei Honor 6 Firmware 4
Huawei Honor 7 Firmware 10
Huawei Mate 7 Firmware 3
Huawei Mate S Firmware 5
Huawei P8 Firmware 6
Huawei P8 Lite Firmware 10
Huawei Shotx Firmware 7

- References For CVE-2017-2692

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20170125-01-emui-en CONFIRM
http://www.securityfocus.com/bid/95919
BID 95919 Huawei EMUI Directory Traversal and Command Injection Vulnerabilities Release Date:2017-02-02

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2017-2692

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.