CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-2620

Quick emulator (QEMU) before 2.8 built with the Cirrus CLGD 54xx VGA Emulator support is vulnerable to an out-of-bounds access issue. The issue could occur while copying VGA data in cirrus_bitblt_cputovideo. A privileged user inside guest could use this flaw to crash the QEMU process OR potentially execute arbitrary code on host with privileges of the QEMU process.
Publish Date : 2018-07-27 Last Update Date : 2018-09-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 125

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2017:0352: qemu-kvm security update (Important) oval:com.redhat.rhsa:def:20170352 unix
RHSA-2017:0396: qemu-kvm security and bug fix update (Important) oval:com.redhat.rhsa:def:20170396 unix
RHSA-2017:0454: kvm security update (Important) oval:com.redhat.rhsa:def:20170454 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2017-2620

# Product Type Vendor Product Version Update Edition Language
1 Application Citrix Xenserver 6.0.2 Version Details Vulnerabilities
2 Application Citrix Xenserver 6.2.0 SP1 Version Details Vulnerabilities
3 Application Citrix Xenserver 6.5 SP1 Version Details Vulnerabilities
4 Application Citrix Xenserver 7.0 Version Details Vulnerabilities
5 Application Citrix Xenserver 7.1 Version Details Vulnerabilities
6 OS Debian Debian Linux 7.0 Version Details Vulnerabilities
7 Application Qemu Qemu - Version Details Vulnerabilities
8 Application Qemu Qemu 0.1 Version Details Vulnerabilities
9 Application Qemu Qemu 0.1.0 Version Details Vulnerabilities
10 Application Qemu Qemu 0.1.1 Version Details Vulnerabilities
11 Application Qemu Qemu 0.1.2 Version Details Vulnerabilities
12 Application Qemu Qemu 0.1.3 Version Details Vulnerabilities
13 Application Qemu Qemu 0.1.4 Version Details Vulnerabilities
14 Application Qemu Qemu 0.1.5 Version Details Vulnerabilities
15 Application Qemu Qemu 0.1.6 Version Details Vulnerabilities
16 Application Qemu Qemu 0.2 Version Details Vulnerabilities
17 Application Qemu Qemu 0.2.0 Version Details Vulnerabilities
18 Application Qemu Qemu 0.3 Version Details Vulnerabilities
19 Application Qemu Qemu 0.3.0 Version Details Vulnerabilities
20 Application Qemu Qemu 0.4 Version Details Vulnerabilities
21 Application Qemu Qemu 0.4.0 Version Details Vulnerabilities
22 Application Qemu Qemu 0.4.1 Version Details Vulnerabilities
23 Application Qemu Qemu 0.4.2 Version Details Vulnerabilities
24 Application Qemu Qemu 0.4.3 Version Details Vulnerabilities
25 Application Qemu Qemu 0.4.4 Version Details Vulnerabilities
26 Application Qemu Qemu 0.5.0 Version Details Vulnerabilities
27 Application Qemu Qemu 0.5.1 Version Details Vulnerabilities
28 Application Qemu Qemu 0.5.2 Version Details Vulnerabilities
29 Application Qemu Qemu 0.5.3 Version Details Vulnerabilities
30 Application Qemu Qemu 0.5.4 Version Details Vulnerabilities
31 Application Qemu Qemu 0.5.5 Version Details Vulnerabilities
32 Application Qemu Qemu 0.6.0 Version Details Vulnerabilities
33 Application Qemu Qemu 0.6.1 Version Details Vulnerabilities
34 Application Qemu Qemu 0.7.0 Version Details Vulnerabilities
35 Application Qemu Qemu 0.7.1 Version Details Vulnerabilities
36 Application Qemu Qemu 0.7.2 Version Details Vulnerabilities
37 Application Qemu Qemu 0.8.0 Version Details Vulnerabilities
38 Application Qemu Qemu 0.8.1 Version Details Vulnerabilities
39 Application Qemu Qemu 0.8.2 Version Details Vulnerabilities
40 Application Qemu Qemu 0.9.0 Version Details Vulnerabilities
41 Application Qemu Qemu 0.9.1 Version Details Vulnerabilities
42 Application Qemu Qemu 0.9.1-5 Version Details Vulnerabilities
43 Application Qemu Qemu 0.10.0 Version Details Vulnerabilities
44 Application Qemu Qemu 0.10.1 Version Details Vulnerabilities
45 Application Qemu Qemu 0.10.2 Version Details Vulnerabilities
46 Application Qemu Qemu 0.10.3 Version Details Vulnerabilities
47 Application Qemu Qemu 0.10.4 Version Details Vulnerabilities
48 Application Qemu Qemu 0.10.5 Version Details Vulnerabilities
49 Application Qemu Qemu 0.10.6 Version Details Vulnerabilities
50 Application Qemu Qemu 0.11.0 RC0 Version Details Vulnerabilities
51 Application Qemu Qemu 0.11.0 RC1 Version Details Vulnerabilities
52 Application Qemu Qemu 0.11.0 RC2 Version Details Vulnerabilities
53 Application Qemu Qemu 0.11.0-rc0 Version Details Vulnerabilities
54 Application Qemu Qemu 0.11.0-rc1 Version Details Vulnerabilities
55 Application Qemu Qemu 0.11.0 Version Details Vulnerabilities
56 Application Qemu Qemu 0.11.0-rc2 Version Details Vulnerabilities
57 Application Qemu Qemu 0.11.1 Version Details Vulnerabilities
58 Application Qemu Qemu 0.12.0 Version Details Vulnerabilities
59 Application Qemu Qemu 0.12.0 RC1 Version Details Vulnerabilities
60 Application Qemu Qemu 0.12.0 RC2 Version Details Vulnerabilities
61 Application Qemu Qemu 0.12.1 Version Details Vulnerabilities
62 Application Qemu Qemu 0.12.2 Version Details Vulnerabilities
63 Application Qemu Qemu 0.12.3 Version Details Vulnerabilities
64 Application Qemu Qemu 0.12.4 Version Details Vulnerabilities
65 Application Qemu Qemu 0.12.5 Version Details Vulnerabilities
66 Application Qemu Qemu 0.13.0 RC0 Version Details Vulnerabilities
67 Application Qemu Qemu 0.13.0 RC1 Version Details Vulnerabilities
68 Application Qemu Qemu 0.13.0 Version Details Vulnerabilities
69 Application Qemu Qemu 0.14.0 Version Details Vulnerabilities
70 Application Qemu Qemu 0.14.0 RC0 Version Details Vulnerabilities
71 Application Qemu Qemu 0.14.0 RC1 Version Details Vulnerabilities
72 Application Qemu Qemu 0.14.0 RC2 Version Details Vulnerabilities
73 Application Qemu Qemu 0.14.1 Version Details Vulnerabilities
74 Application Qemu Qemu 0.15.0 Version Details Vulnerabilities
75 Application Qemu Qemu 0.15.0 RC1 Version Details Vulnerabilities
76 Application Qemu Qemu 0.15.0 RC2 Version Details Vulnerabilities
77 Application Qemu Qemu 0.15.1 Version Details Vulnerabilities
78 Application Qemu Qemu 0.15.2 Version Details Vulnerabilities
79 Application Qemu Qemu 1.0 Version Details Vulnerabilities
80 Application Qemu Qemu 1.0 RC1 Version Details Vulnerabilities
81 Application Qemu Qemu 1.0 RC2 Version Details Vulnerabilities
82 Application Qemu Qemu 1.0 RC3 Version Details Vulnerabilities
83 Application Qemu Qemu 1.0 RC4 Version Details Vulnerabilities
84 Application Qemu Qemu 1.0.1 Version Details Vulnerabilities
85 Application Qemu Qemu 1.1 Version Details Vulnerabilities
86 Application Qemu Qemu 1.1 RC1 Version Details Vulnerabilities
87 Application Qemu Qemu 1.1 RC2 Version Details Vulnerabilities
88 Application Qemu Qemu 1.1 RC3 Version Details Vulnerabilities
89 Application Qemu Qemu 1.1 RC4 Version Details Vulnerabilities
90 Application Qemu Qemu 1.1.0 Version Details Vulnerabilities
91 Application Qemu Qemu 1.1.1 Version Details Vulnerabilities
92 Application Qemu Qemu 1.1.2 Version Details Vulnerabilities
93 Application Qemu Qemu 1.2.0 Version Details Vulnerabilities
94 Application Qemu Qemu 1.2.1 Version Details Vulnerabilities
95 Application Qemu Qemu 1.2.2 Version Details Vulnerabilities
96 Application Qemu Qemu 1.3.0 Version Details Vulnerabilities
97 Application Qemu Qemu 1.3.1 Version Details Vulnerabilities
98 Application Qemu Qemu 1.4.0 Version Details Vulnerabilities
99 Application Qemu Qemu 1.4.1 Version Details Vulnerabilities
100 Application Qemu Qemu 1.4.2 Version Details Vulnerabilities
101 Application Qemu Qemu 1.5.0 Version Details Vulnerabilities
102 Application Qemu Qemu 1.5.0 RC1 Version Details Vulnerabilities
103 Application Qemu Qemu 1.5.0 RC2 Version Details Vulnerabilities
104 Application Qemu Qemu 1.5.0 RC3 Version Details Vulnerabilities
105 Application Qemu Qemu 1.5.1 Version Details Vulnerabilities
106 Application Qemu Qemu 1.5.2 Version Details Vulnerabilities
107 Application Qemu Qemu 1.5.3 Version Details Vulnerabilities
108 Application Qemu Qemu 1.6.0 RC3 Version Details Vulnerabilities
109 Application Qemu Qemu 1.6.0 Version Details Vulnerabilities
110 Application Qemu Qemu 1.6.0 RC1 Version Details Vulnerabilities
111 Application Qemu Qemu 1.6.0 RC2 Version Details Vulnerabilities
112 Application Qemu Qemu 1.6.1 Version Details Vulnerabilities
113 Application Qemu Qemu 1.6.2 Version Details Vulnerabilities
114 Application Qemu Qemu 1.7.0 Version Details Vulnerabilities
115 Application Qemu Qemu 1.7.1 Version Details Vulnerabilities
116 Application Qemu Qemu 1.7.2 Version Details Vulnerabilities
117 Application Qemu Qemu 2.0.0 RC3 Version Details Vulnerabilities
118 Application Qemu Qemu 2.0.0 Version Details Vulnerabilities
119 Application Qemu Qemu 2.0.0 - Version Details Vulnerabilities
120 Application Qemu Qemu 2.0.0 RC0 Version Details Vulnerabilities
121 Application Qemu Qemu 2.0.0 RC1 Version Details Vulnerabilities
122 Application Qemu Qemu 2.0.0 RC2 Version Details Vulnerabilities
123 Application Qemu Qemu 2.0.1 Version Details Vulnerabilities
124 Application Qemu Qemu 2.0.2 Version Details Vulnerabilities
125 Application Qemu Qemu 2.1.0 RC0 Version Details Vulnerabilities
126 Application Qemu Qemu 2.1.0 RC1 Version Details Vulnerabilities
127 Application Qemu Qemu 2.1.0 RC2 Version Details Vulnerabilities
128 Application Qemu Qemu 2.1.0 RC3 Version Details Vulnerabilities
129 Application Qemu Qemu 2.1.0 RC5 Version Details Vulnerabilities
130 Application Qemu Qemu 2.1.0 Version Details Vulnerabilities
131 Application Qemu Qemu 2.1.1 Version Details Vulnerabilities
132 Application Qemu Qemu 2.1.2 Version Details Vulnerabilities
133 Application Qemu Qemu 2.1.3 Version Details Vulnerabilities
134 Application Qemu Qemu 2.2.0 Version Details Vulnerabilities
135 Application Qemu Qemu 2.2.1 Version Details Vulnerabilities
136 Application Qemu Qemu 2.3.0 Version Details Vulnerabilities
137 Application Qemu Qemu 2.3.1 Version Details Vulnerabilities
138 Application Qemu Qemu 2.4.0 Version Details Vulnerabilities
139 Application Qemu Qemu 2.4.0.1 Version Details Vulnerabilities
140 Application Qemu Qemu 2.4.1 Version Details Vulnerabilities
141 Application Qemu Qemu 2.5.0 Version Details Vulnerabilities
142 Application Qemu Qemu 2.5.1 Version Details Vulnerabilities
143 Application Qemu Qemu 2.5.1.1 Version Details Vulnerabilities
144 Application Qemu Qemu 2.6.0 Version Details Vulnerabilities
145 Application Qemu Qemu 2.6.1 Version Details Vulnerabilities
146 Application Qemu Qemu 2.6.2 Version Details Vulnerabilities
147 Application Qemu Qemu 2.7.0 Version Details Vulnerabilities
148 Application Qemu Qemu 2.7.1 Version Details Vulnerabilities
149 OS Redhat Enterprise Linux Desktop 6.0 Version Details Vulnerabilities
150 OS Redhat Enterprise Linux Desktop 7.0 Version Details Vulnerabilities
151 OS Redhat Enterprise Linux Server 6.0 Version Details Vulnerabilities
152 OS Redhat Enterprise Linux Server 7.0 Version Details Vulnerabilities
153 OS Redhat Enterprise Linux Server Aus 7.3 Version Details Vulnerabilities
154 OS Redhat Enterprise Linux Server Aus 7.4 Version Details Vulnerabilities
155 OS Redhat Enterprise Linux Server Eus 7.3 Version Details Vulnerabilities
156 OS Redhat Enterprise Linux Server Eus 7.4 Version Details Vulnerabilities
157 OS Redhat Enterprise Linux Server Eus 7.5 Version Details Vulnerabilities
158 OS Redhat Enterprise Linux Workstation 6.0 Version Details Vulnerabilities
159 OS Redhat Enterprise Linux Workstation 7.0 Version Details Vulnerabilities
160 Application Redhat Openstack 5.0 Version Details Vulnerabilities
161 Application Redhat Openstack 6.0 Version Details Vulnerabilities
162 Application Redhat Openstack 7.0 Version Details Vulnerabilities
163 Application Redhat Openstack 8.0 Version Details Vulnerabilities
164 Application Redhat Openstack 9.0 Version Details Vulnerabilities
165 Application Redhat Openstack 10.0 Version Details Vulnerabilities
166 OS XEN XEN 4.7.1 R3 Version Details Vulnerabilities
167 OS XEN XEN 4.7.1 R4 Version Details Vulnerabilities
168 OS XEN XEN 4.7.1 R5 Version Details Vulnerabilities
169 OS XEN XEN 4.7.1 Version Details Vulnerabilities
170 OS XEN XEN 4.7.1 R6 Version Details Vulnerabilities
171 OS XEN XEN 4.7.1 R1 Version Details Vulnerabilities
172 OS XEN XEN 4.7.1 R7 Version Details Vulnerabilities
173 OS XEN XEN 4.7.1 R2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Citrix Xenserver 5
Debian Debian Linux 1
Qemu Qemu 142
Redhat Enterprise Linux Desktop 2
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Aus 2
Redhat Enterprise Linux Server Eus 3
Redhat Enterprise Linux Workstation 2
Redhat Openstack 6
XEN XEN 8

- References For CVE-2017-2620

https://security.gentoo.org/glsa/201704-01
GENTOO GLSA-201704-01
https://support.citrix.com/article/CTX220771 CONFIRM
https://security.gentoo.org/glsa/201703-07
GENTOO GLSA-201703-07
https://xenbits.xen.org/xsa/advisory-209.html CONFIRM
https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg04700.html
MLIST [qemu-devel] 20170221 [PATCH] cirrus: add blit_is_unsafe call to cirrus_bitblt_cputovideo (CVE-2017-2620)
https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
MLIST [debian-lts-announce] 20180906 [SECURITY] [DLA 1497-1] qemu security update
http://www.securityfocus.com/bid/96378
BID 96378 Qemu CVE-2017-2620 Remote Code Execution Vulnerability Release Date:2017-04-14
http://www.securitytracker.com/id/1037870
SECTRACK 1037870
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2620 CONFIRM
https://lists.debian.org/debian-lts-announce/2018/02/msg00005.html
MLIST [debian-lts-announce] 20180206 [SECURITY] [DLA 1270-1] xen security update
http://rhn.redhat.com/errata/RHSA-2017-0396.html
REDHAT RHSA-2017:0396
http://www.openwall.com/lists/oss-security/2017/02/21/1
MLIST [oss-security] 20170221 CVE-2017-2620 Qemu: display: cirrus: out-of-bounds access issue while in cirrus_bitblt_cputovideo
http://rhn.redhat.com/errata/RHSA-2017-0454.html
REDHAT RHSA-2017:0454
http://rhn.redhat.com/errata/RHSA-2017-0352.html
REDHAT RHSA-2017:0352
http://rhn.redhat.com/errata/RHSA-2017-0351.html
REDHAT RHSA-2017:0351
http://rhn.redhat.com/errata/RHSA-2017-0350.html
REDHAT RHSA-2017:0350
http://rhn.redhat.com/errata/RHSA-2017-0334.html
REDHAT RHSA-2017:0334
http://rhn.redhat.com/errata/RHSA-2017-0333.html
REDHAT RHSA-2017:0333
http://rhn.redhat.com/errata/RHSA-2017-0328.html
REDHAT RHSA-2017:0328
http://rhn.redhat.com/errata/RHSA-2017-0329.html
REDHAT RHSA-2017:0329
http://rhn.redhat.com/errata/RHSA-2017-0330.html
REDHAT RHSA-2017:0330
http://rhn.redhat.com/errata/RHSA-2017-0332.html
REDHAT RHSA-2017:0332
http://rhn.redhat.com/errata/RHSA-2017-0331.html
REDHAT RHSA-2017:0331

- Metasploit Modules Related To CVE-2017-2620

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.