CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-16723

A Cross-site Scripting issue was discovered in PHOENIX CONTACT FL COMSERVER BASIC 232/422/485, FL COMSERVER UNI 232/422/485, FL COMSERVER BAS 232/422/485-T, FL COMSERVER UNI 232/422/485-T, FL COM SERVER RS232, FL COM SERVER RS485, and PSI-MODEM/ETH (running firmware versions prior to 1.99, 2.20, or 2.40). The cross-site scripting vulnerability has been identified, which may allow remote code execution.
Publish Date : 2017-12-11 Last Update Date : 2018-01-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeCross Site Scripting
CWE ID 79

- Products Affected By CVE-2017-16723

# Product Type Vendor Product Version Update Edition Language
1 OS Phoenixcontact Fl Com Server Rs232 Firmware 1.99 Version Details Vulnerabilities
2 OS Phoenixcontact Fl Com Server Rs485 Firmware 1.99 Version Details Vulnerabilities
3 OS Phoenixcontact Fl Comserver Bas 232 Firmware 2.40 Version Details Vulnerabilities
4 OS Phoenixcontact Fl Comserver Bas 422 Firmware 2.40 Version Details Vulnerabilities
5 OS Phoenixcontact Fl Comserver Bas 485-t Firmware 2.40 Version Details Vulnerabilities
6 OS Phoenixcontact Fl Comserver Basic 232 Firmware 2.40 Version Details Vulnerabilities
7 OS Phoenixcontact Fl Comserver Basic 422 Firmware 2.40 Version Details Vulnerabilities
8 OS Phoenixcontact Fl Comserver Basic 485 Firmware 2.40 Version Details Vulnerabilities
9 OS Phoenixcontact Fl Comserver Uni 232 Firmware 2.40 Version Details Vulnerabilities
10 OS Phoenixcontact Fl Comserver Uni 422 Firmware 2.40 Version Details Vulnerabilities
11 OS Phoenixcontact Fl Comserver Uni 485 Firmware 2.40 Version Details Vulnerabilities
12 OS Phoenixcontact Fl Comserver Uni 485-t Firmware 2.40 Version Details Vulnerabilities
13 OS Phoenixcontact Psi-modem/eth Firmware 2.20 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Phoenixcontact Fl Com Server Rs232 Firmware 1
Phoenixcontact Fl Com Server Rs485 Firmware 1
Phoenixcontact Fl Comserver Bas 232 Firmware 1
Phoenixcontact Fl Comserver Bas 422 Firmware 1
Phoenixcontact Fl Comserver Bas 485-t Firmware 1
Phoenixcontact Fl Comserver Basic 232 Firmware 1
Phoenixcontact Fl Comserver Basic 422 Firmware 1
Phoenixcontact Fl Comserver Basic 485 Firmware 1
Phoenixcontact Fl Comserver Uni 232 Firmware 1
Phoenixcontact Fl Comserver Uni 422 Firmware 1
Phoenixcontact Fl Comserver Uni 485 Firmware 1
Phoenixcontact Fl Comserver Uni 485-t Firmware 1
Phoenixcontact Psi-modem/eth Firmware 1

- References For CVE-2017-16723

http://www.securityfocus.com/bid/102111
BID 102111 Multiple Phoenix Contact Products CVE-2017-16723 Cross Site Scripting Vulnerability Release Date:2017-12-13
https://cert.vde.com/de-de/advisories/vde-2017-004
https://ics-cert.us-cert.gov/advisories/ICSA-17-341-03

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2017-16723

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.