CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-15713

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.
Publish Date : 2018-01-19 Last Update Date : 2018-02-06
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Products Affected By CVE-2017-15713

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Hadoop 0.23.0 Version Details Vulnerabilities
2 Application Apache Hadoop 0.23.1 Version Details Vulnerabilities
3 Application Apache Hadoop 0.23.3 Version Details Vulnerabilities
4 Application Apache Hadoop 0.23.4 Version Details Vulnerabilities
5 Application Apache Hadoop 0.23.5 Version Details Vulnerabilities
6 Application Apache Hadoop 0.23.6 Version Details Vulnerabilities
7 Application Apache Hadoop 0.23.7 Version Details Vulnerabilities
8 Application Apache Hadoop 0.23.8 Version Details Vulnerabilities
9 Application Apache Hadoop 0.23.9 Version Details Vulnerabilities
10 Application Apache Hadoop 0.23.10 Version Details Vulnerabilities
11 Application Apache Hadoop 0.23.11 Version Details Vulnerabilities
12 Application Apache Hadoop 2.0.0 Alpha Version Details Vulnerabilities
13 Application Apache Hadoop 2.0.1 Alpha Version Details Vulnerabilities
14 Application Apache Hadoop 2.0.2 Alpha Version Details Vulnerabilities
15 Application Apache Hadoop 2.0.3 Alpha Version Details Vulnerabilities
16 Application Apache Hadoop 2.0.4 Alpha Version Details Vulnerabilities
17 Application Apache Hadoop 2.0.5 Alpha Version Details Vulnerabilities
18 Application Apache Hadoop 2.0.6 Alpha Version Details Vulnerabilities
19 Application Apache Hadoop 2.1.0 Beta Version Details Vulnerabilities
20 Application Apache Hadoop 2.1.1 Beta Version Details Vulnerabilities
21 Application Apache Hadoop 2.2.0 Version Details Vulnerabilities
22 Application Apache Hadoop 2.3.0 Version Details Vulnerabilities
23 Application Apache Hadoop 2.4.0 Version Details Vulnerabilities
24 Application Apache Hadoop 2.4.1 Version Details Vulnerabilities
25 Application Apache Hadoop 2.5.0 Version Details Vulnerabilities
26 Application Apache Hadoop 2.5.1 Version Details Vulnerabilities
27 Application Apache Hadoop 2.6.0 Version Details Vulnerabilities
28 Application Apache Hadoop 2.6.1 Version Details Vulnerabilities
29 Application Apache Hadoop 2.6.2 Version Details Vulnerabilities
30 Application Apache Hadoop 2.6.3 Version Details Vulnerabilities
31 Application Apache Hadoop 2.6.4 Version Details Vulnerabilities
32 Application Apache Hadoop 2.7.0 Version Details Vulnerabilities
33 Application Apache Hadoop 2.7.1 Version Details Vulnerabilities
34 Application Apache Hadoop 2.7.2 Version Details Vulnerabilities
35 Application Apache Hadoop 3.0.0 Alpha2 Version Details Vulnerabilities
36 Application Apache Hadoop 3.0.0 Alpha3 Version Details Vulnerabilities
37 Application Apache Hadoop 3.0.0 Alpha4 Version Details Vulnerabilities
38 Application Apache Hadoop 3.0.0 Beta1 Version Details Vulnerabilities
39 Application Apache Hadoop 3.0.0 Alpha1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Hadoop 39

- References For CVE-2017-15713

https://lists.apache.org/thread.html/a790a251ace7213bde9f69777dedb453b1a01a6d18289c14a61d4f[email protected]%3Cgeneral.hadoop.apache.org%3E
MLIST [general] 20180119 CVE-2017-15713: Apache Hadoop MapReduce job history server vulnerability

- Metasploit Modules Related To CVE-2017-15713

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.