CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-12134

The xen_biovec_phys_mergeable function in drivers/xen/biomerge.c in Xen might allow local OS guest users to corrupt block device data streams and consequently obtain sensitive memory information, cause a denial of service, or gain host OS privileges by leveraging incorrect block IO merge-ability calculation.
Publish Date : 2017-08-24 Last Update Date : 2018-05-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceGain privilegesObtain Information
CWE ID 264

- Products Affected By CVE-2017-12134

# Product Type Vendor Product Version Update Edition Language
1 Application Citrix Xenserver 6.0.2 Version Details Vulnerabilities
2 Application Citrix Xenserver 6.2.0 Version Details Vulnerabilities
3 Application Citrix Xenserver 6.5 Version Details Vulnerabilities
4 Application Citrix Xenserver 7.0 Version Details Vulnerabilities
5 Application Citrix Xenserver 7.1 Version Details Vulnerabilities
6 Application Citrix Xenserver 7.2 Version Details Vulnerabilities
7 OS XEN XEN Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Citrix Xenserver 6
XEN XEN 1

- References For CVE-2017-12134

https://support.citrix.com/article/CTX225941 CONFIRM
https://usn.ubuntu.com/3655-1/
UBUNTU USN-3655-1
http://www.securitytracker.com/id/1039176
SECTRACK 1039176
http://xenbits.xen.org/xsa/advisory-229.html CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=1477656
https://security.gentoo.org/glsa/201801-14
GENTOO GLSA-201801-14
https://usn.ubuntu.com/3655-2/
UBUNTU USN-3655-2
http://www.openwall.com/lists/oss-security/2017/08/15/4
MLIST [oss-security] 20170815 Xen Security Advisory 229 (CVE-2017-12134) - linux: Fix Xen block IO merge-ability calculation
http://www.securityfocus.com/bid/100343
BID 100343 Xen CVE-2017-12134 Memory Corruption Vulnerability Release Date:2017-10-11
http://www.debian.org/security/2017/dsa-3981
DEBIAN DSA-3981

- Metasploit Modules Related To CVE-2017-12134

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.