CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-1149

IBM UrbanCode Deploy (UCD) 6.0, 6.1, and 6.2 is vulnerable to a denial of service, caused by an XML External Entity Injection (XXE) error when processing XML data. A remote attacker could exploit this vulnerability to expose highly sensitive information or consume all available memory resources. IBM X-Force ID: 122202.
Publish Date : 2017-04-25 Last Update Date : 2017-05-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 611

- Products Affected By CVE-2017-1149

# Product Type Vendor Product Version Update Edition Language
1 Application IBM Urbancode Deploy 6.0 Version Details Vulnerabilities
2 Application IBM Urbancode Deploy 6.0.1.0 Version Details Vulnerabilities
3 Application IBM Urbancode Deploy 6.0.1.1 Version Details Vulnerabilities
4 Application IBM Urbancode Deploy 6.0.1.2 Version Details Vulnerabilities
5 Application IBM Urbancode Deploy 6.0.1.3 Version Details Vulnerabilities
6 Application IBM Urbancode Deploy 6.0.1.4 Version Details Vulnerabilities
7 Application IBM Urbancode Deploy 6.0.1.5 Version Details Vulnerabilities
8 Application IBM Urbancode Deploy 6.0.1.6 Version Details Vulnerabilities
9 Application IBM Urbancode Deploy 6.0.1.7 Version Details Vulnerabilities
10 Application IBM Urbancode Deploy 6.0.1.8 Version Details Vulnerabilities
11 Application IBM Urbancode Deploy 6.0.1.9 Version Details Vulnerabilities
12 Application IBM Urbancode Deploy 6.0.1.10 Version Details Vulnerabilities
13 Application IBM Urbancode Deploy 6.0.1.11 Version Details Vulnerabilities
14 Application IBM Urbancode Deploy 6.0.1.12 Version Details Vulnerabilities
15 Application IBM Urbancode Deploy 6.0.1.13 Version Details Vulnerabilities
16 Application IBM Urbancode Deploy 6.1 Version Details Vulnerabilities
17 Application IBM Urbancode Deploy 6.1.0.1 Version Details Vulnerabilities
18 Application IBM Urbancode Deploy 6.1.0.3 Version Details Vulnerabilities
19 Application IBM Urbancode Deploy 6.1.0.4 Version Details Vulnerabilities
20 Application IBM Urbancode Deploy 6.1.1.0 Version Details Vulnerabilities
21 Application IBM Urbancode Deploy 6.1.1.1 Version Details Vulnerabilities
22 Application IBM Urbancode Deploy 6.1.1.2 Version Details Vulnerabilities
23 Application IBM Urbancode Deploy 6.1.1.3 Version Details Vulnerabilities
24 Application IBM Urbancode Deploy 6.1.1.4 Version Details Vulnerabilities
25 Application IBM Urbancode Deploy 6.1.1.5 Version Details Vulnerabilities
26 Application IBM Urbancode Deploy 6.1.1.6 Version Details Vulnerabilities
27 Application IBM Urbancode Deploy 6.1.1.7 Version Details Vulnerabilities
28 Application IBM Urbancode Deploy 6.1.1.8 Version Details Vulnerabilities
29 Application IBM Urbancode Deploy 6.1.2 Version Details Vulnerabilities
30 Application IBM Urbancode Deploy 6.1.3 Version Details Vulnerabilities
31 Application IBM Urbancode Deploy 6.1.3.1 Version Details Vulnerabilities
32 Application IBM Urbancode Deploy 6.1.3.2 Version Details Vulnerabilities
33 Application IBM Urbancode Deploy 6.2.0.0 Version Details Vulnerabilities
34 Application IBM Urbancode Deploy 6.2.0.1 Version Details Vulnerabilities
35 Application IBM Urbancode Deploy 6.2.0.2 Version Details Vulnerabilities
36 Application IBM Urbancode Deploy 6.2.0.201 Version Details Vulnerabilities
37 Application IBM Urbancode Deploy 6.2.1 Version Details Vulnerabilities
38 Application IBM Urbancode Deploy 6.2.1.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
IBM Urbancode Deploy 38

- References For CVE-2017-1149

http://www.securityfocus.com/bid/98026
BID 98026 IBM UrbanCode Deploy CVE-2017-1149 XML External Entity Injection Vulnerability Release Date:2017-05-01
http://www.ibm.com/support/docview.wss?uid=swg2C1000289 CONFIRM

- Metasploit Modules Related To CVE-2017-1149

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.