CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-1000254

libcurl may read outside of a heap allocated buffer when doing FTP. When libcurl connects to an FTP server and successfully logs in (anonymous or not), it asks the server for the current directory with the `PWD` command. The server then responds with a 257 response containing the path, inside double quotes. The returned path name is then kept by libcurl for subsequent uses. Due to a flaw in the string parser for this directory name, a directory name passed like this but without a closing double quote would lead to libcurl not adding a trailing NUL byte to the buffer holding the name. When libcurl would then later access the string, it could read beyond the allocated heap buffer and crash or wrongly access data beyond the buffer, thinking it was part of the path. A malicious server could abuse this fact and effectively prevent libcurl-based clients to work with it - the PWD command is always issued on new FTP connections and the mistake has a high chance of causing a segfault. The simple fact that this has issue remained undiscovered for this long could suggest that malformed PWD responses are rare in benign servers. We are not aware of any exploit of this flaw. This bug was introduced in commit [415d2e7cb7](https://github.com/curl/curl/commit/415d2e7cb7), March 2005. In libcurl version 7.56.0, the parser always zero terminates the string but also rejects it if not terminated properly with a final double quote.
Publish Date : 2017-10-06 Last Update Date : 2017-12-25
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Overflow
CWE ID 119

- Products Affected By CVE-2017-1000254

# Product Type Vendor Product Version Update Edition Language
1 Application Haxx Libcurl 7.7 Version Details Vulnerabilities
2 Application Haxx Libcurl 7.7.1 Version Details Vulnerabilities
3 Application Haxx Libcurl 7.7.2 Version Details Vulnerabilities
4 Application Haxx Libcurl 7.7.3 Version Details Vulnerabilities
5 Application Haxx Libcurl 7.8 Version Details Vulnerabilities
6 Application Haxx Libcurl 7.8.1 Version Details Vulnerabilities
7 Application Haxx Libcurl 7.9 Version Details Vulnerabilities
8 Application Haxx Libcurl 7.9.1 Version Details Vulnerabilities
9 Application Haxx Libcurl 7.9.2 Version Details Vulnerabilities
10 Application Haxx Libcurl 7.9.3 Version Details Vulnerabilities
11 Application Haxx Libcurl 7.9.4 Version Details Vulnerabilities
12 Application Haxx Libcurl 7.9.5 Version Details Vulnerabilities
13 Application Haxx Libcurl 7.9.6 Version Details Vulnerabilities
14 Application Haxx Libcurl 7.9.7 Version Details Vulnerabilities
15 Application Haxx Libcurl 7.9.8 Version Details Vulnerabilities
16 Application Haxx Libcurl 7.10 Version Details Vulnerabilities
17 Application Haxx Libcurl 7.10.1 Version Details Vulnerabilities
18 Application Haxx Libcurl 7.10.2 Version Details Vulnerabilities
19 Application Haxx Libcurl 7.10.3 Version Details Vulnerabilities
20 Application Haxx Libcurl 7.10.4 Version Details Vulnerabilities
21 Application Haxx Libcurl 7.10.5 Version Details Vulnerabilities
22 Application Haxx Libcurl 7.10.6 Version Details Vulnerabilities
23 Application Haxx Libcurl 7.10.7 Version Details Vulnerabilities
24 Application Haxx Libcurl 7.10.8 Version Details Vulnerabilities
25 Application Haxx Libcurl 7.11.0 Version Details Vulnerabilities
26 Application Haxx Libcurl 7.11.1 Version Details Vulnerabilities
27 Application Haxx Libcurl 7.11.2 Version Details Vulnerabilities
28 Application Haxx Libcurl 7.12.0 Version Details Vulnerabilities
29 Application Haxx Libcurl 7.12.1 Version Details Vulnerabilities
30 Application Haxx Libcurl 7.12.2 Version Details Vulnerabilities
31 Application Haxx Libcurl 7.12.3 Version Details Vulnerabilities
32 Application Haxx Libcurl 7.13.0 Version Details Vulnerabilities
33 Application Haxx Libcurl 7.13.1 Version Details Vulnerabilities
34 Application Haxx Libcurl 7.13.2 Version Details Vulnerabilities
35 Application Haxx Libcurl 7.14.0 Version Details Vulnerabilities
36 Application Haxx Libcurl 7.14.1 Version Details Vulnerabilities
37 Application Haxx Libcurl 7.15.0 Version Details Vulnerabilities
38 Application Haxx Libcurl 7.15.1 Version Details Vulnerabilities
39 Application Haxx Libcurl 7.15.2 Version Details Vulnerabilities
40 Application Haxx Libcurl 7.15.3 Version Details Vulnerabilities
41 Application Haxx Libcurl 7.15.4 Version Details Vulnerabilities
42 Application Haxx Libcurl 7.15.5 Version Details Vulnerabilities
43 Application Haxx Libcurl 7.16.0 Version Details Vulnerabilities
44 Application Haxx Libcurl 7.16.1 Version Details Vulnerabilities
45 Application Haxx Libcurl 7.16.2 Version Details Vulnerabilities
46 Application Haxx Libcurl 7.16.3 Version Details Vulnerabilities
47 Application Haxx Libcurl 7.16.4 Version Details Vulnerabilities
48 Application Haxx Libcurl 7.17.0 Version Details Vulnerabilities
49 Application Haxx Libcurl 7.17.1 Version Details Vulnerabilities
50 Application Haxx Libcurl 7.18.0 Version Details Vulnerabilities
51 Application Haxx Libcurl 7.18.1 Version Details Vulnerabilities
52 Application Haxx Libcurl 7.18.2 Version Details Vulnerabilities
53 Application Haxx Libcurl 7.19.0 Version Details Vulnerabilities
54 Application Haxx Libcurl 7.19.1 Version Details Vulnerabilities
55 Application Haxx Libcurl 7.19.2 Version Details Vulnerabilities
56 Application Haxx Libcurl 7.19.3 Version Details Vulnerabilities
57 Application Haxx Libcurl 7.19.4 Version Details Vulnerabilities
58 Application Haxx Libcurl 7.19.5 Version Details Vulnerabilities
59 Application Haxx Libcurl 7.19.6 Version Details Vulnerabilities
60 Application Haxx Libcurl 7.19.7 Version Details Vulnerabilities
61 Application Haxx Libcurl 7.20.0 Version Details Vulnerabilities
62 Application Haxx Libcurl 7.20.1 Version Details Vulnerabilities
63 Application Haxx Libcurl 7.21.0 Version Details Vulnerabilities
64 Application Haxx Libcurl 7.21.1 Version Details Vulnerabilities
65 Application Haxx Libcurl 7.21.2 Version Details Vulnerabilities
66 Application Haxx Libcurl 7.21.3 Version Details Vulnerabilities
67 Application Haxx Libcurl 7.21.4 Version Details Vulnerabilities
68 Application Haxx Libcurl 7.21.5 Version Details Vulnerabilities
69 Application Haxx Libcurl 7.21.6 Version Details Vulnerabilities
70 Application Haxx Libcurl 7.21.7 Version Details Vulnerabilities
71 Application Haxx Libcurl 7.22.0 Version Details Vulnerabilities
72 Application Haxx Libcurl 7.23.0 Version Details Vulnerabilities
73 Application Haxx Libcurl 7.23.1 Version Details Vulnerabilities
74 Application Haxx Libcurl 7.24.0 Version Details Vulnerabilities
75 Application Haxx Libcurl 7.25.0 Version Details Vulnerabilities
76 Application Haxx Libcurl 7.26.0 Version Details Vulnerabilities
77 Application Haxx Libcurl 7.27.0 Version Details Vulnerabilities
78 Application Haxx Libcurl 7.28.0 Version Details Vulnerabilities
79 Application Haxx Libcurl 7.28.1 Version Details Vulnerabilities
80 Application Haxx Libcurl 7.29.0 Version Details Vulnerabilities
81 Application Haxx Libcurl 7.30.0 Version Details Vulnerabilities
82 Application Haxx Libcurl 7.31.0 Version Details Vulnerabilities
83 Application Haxx Libcurl 7.32.0 Version Details Vulnerabilities
84 Application Haxx Libcurl 7.33.0 Version Details Vulnerabilities
85 Application Haxx Libcurl 7.34.0 Version Details Vulnerabilities
86 Application Haxx Libcurl 7.35.0 Version Details Vulnerabilities
87 Application Haxx Libcurl 7.36.0 Version Details Vulnerabilities
88 Application Haxx Libcurl 7.37.0 Version Details Vulnerabilities
89 Application Haxx Libcurl 7.37.1 Version Details Vulnerabilities
90 Application Haxx Libcurl 7.38.0 Version Details Vulnerabilities
91 Application Haxx Libcurl 7.39 Version Details Vulnerabilities
92 Application Haxx Libcurl 7.40.0 Version Details Vulnerabilities
93 Application Haxx Libcurl 7.41.0 Version Details Vulnerabilities
94 Application Haxx Libcurl 7.42.0 Version Details Vulnerabilities
95 Application Haxx Libcurl 7.42.1 Version Details Vulnerabilities
96 Application Haxx Libcurl 7.43.0 Version Details Vulnerabilities
97 Application Haxx Libcurl 7.44.0 Version Details Vulnerabilities
98 Application Haxx Libcurl 7.45.0 Version Details Vulnerabilities
99 Application Haxx Libcurl 7.46.0 Version Details Vulnerabilities
100 Application Haxx Libcurl 7.47.0 Version Details Vulnerabilities
101 Application Haxx Libcurl 7.47.1 Version Details Vulnerabilities
102 Application Haxx Libcurl 7.48.0 Version Details Vulnerabilities
103 Application Haxx Libcurl 7.49.0 Version Details Vulnerabilities
104 Application Haxx Libcurl 7.49.1 Version Details Vulnerabilities
105 Application Haxx Libcurl 7.50.0 Version Details Vulnerabilities
106 Application Haxx Libcurl 7.50.1 Version Details Vulnerabilities
107 Application Haxx Libcurl 7.50.2 Version Details Vulnerabilities
108 Application Haxx Libcurl 7.50.3 Version Details Vulnerabilities
109 Application Haxx Libcurl 7.51.0 Version Details Vulnerabilities
110 Application Haxx Libcurl 7.52.0 Version Details Vulnerabilities
111 Application Haxx Libcurl 7.52.1 Version Details Vulnerabilities
112 Application Haxx Libcurl 7.53.0 Version Details Vulnerabilities
113 Application Haxx Libcurl 7.53.1 Version Details Vulnerabilities
114 Application Haxx Libcurl 7.54.0 Version Details Vulnerabilities
115 Application Haxx Libcurl 7.54.1 Version Details Vulnerabilities
116 Application Haxx Libcurl 7.55.0 Version Details Vulnerabilities
117 Application Haxx Libcurl 7.55.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Haxx Libcurl 117

- References For CVE-2017-1000254

https://security.gentoo.org/glsa/201712-04
GENTOO GLSA-201712-04
http://www.debian.org/security/2017/dsa-3992
DEBIAN DSA-3992
https://curl.haxx.se/673d0cd8.patch CONFIRM
https://support.apple.com/HT208331 CONFIRM
http://www.securitytracker.com/id/1039509
SECTRACK 1039509
https://curl.haxx.se/docs/adv_20171004.html CONFIRM
http://www.securityfocus.com/bid/101115
BID 101115 Curl CVE-2017-1000254 Out of Bounds Read Denial of Service Vulnerability Release Date:2017-10-09

- Metasploit Modules Related To CVE-2017-1000254

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.