CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-4997

The compat IPT_SO_SET_REPLACE and IP6T_SO_SET_REPLACE setsockopt implementations in the netfilter subsystem in the Linux kernel before 4.6.3 allow local users to gain privileges or cause a denial of service (memory corruption) by leveraging in-container root access to provide a crafted offset value that triggers an unintended decrement.
Publish Date : 2016-07-03 Last Update Date : 2018-01-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceGain privilegesMemory corruption
CWE ID 264

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2016:1847: kernel security, bug fix, and enhancement update (Important) oval:com.redhat.rhsa:def:20161847 unix
RHSA-2016:1875: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20161875 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2016-4997

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 12.04 ~~lts~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 15.10 Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 16.04 ~~lts~~~ Version Details Vulnerabilities
5 OS Linux Linux Kernel 4.6.2 Version Details Vulnerabilities
6 OS Novell Suse Linux Enterprise Desktop 12.0 Version Details Vulnerabilities
7 OS Novell Suse Linux Enterprise Desktop 12.0 SP1 Version Details Vulnerabilities
8 OS Novell Suse Linux Enterprise Live Patching 12.0 Version Details Vulnerabilities
9 OS Novell Suse Linux Enterprise Module For Public Cloud 12.0 Version Details Vulnerabilities
10 OS Novell Suse Linux Enterprise Real Time Extension 12.0 SP1 Version Details Vulnerabilities
11 OS Novell Suse Linux Enterprise Server 12.0 Version Details Vulnerabilities
12 OS Novell Suse Linux Enterprise Server 12.0 SP1 Version Details Vulnerabilities
13 OS Novell Suse Linux Enterprise Software Development Kit 12.0 Version Details Vulnerabilities
14 OS Novell Suse Linux Enterprise Software Development Kit 12.0 SP1 Version Details Vulnerabilities
15 OS Novell Suse Linux Enterprise Workstation Extension 12.0 Version Details Vulnerabilities
16 OS Novell Suse Linux Enterprise Workstation Extension 12.0 SP1 Version Details Vulnerabilities
17 OS Oracle Linux 7.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Linux Linux Kernel 1
Novell Suse Linux Enterprise Desktop 2
Novell Suse Linux Enterprise Live Patching 1
Novell Suse Linux Enterprise Module For Public Cloud 1
Novell Suse Linux Enterprise Real Time Extension 1
Novell Suse Linux Enterprise Server 2
Novell Suse Linux Enterprise Software Development Kit 2
Novell Suse Linux Enterprise Workstation Extension 2
Oracle Linux 1

- References For CVE-2016-4997

https://www.exploit-db.com/exploits/40489/
EXPLOIT-DB 40489
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05347541 CONFIRM
https://www.exploit-db.com/exploits/40435/
EXPLOIT-DB 40435
https://github.com/torvalds/linux/commit/ce683e5f9d045e5d67d1312a42b359cb2ab2a13c CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00060.html
SUSE SUSE-SU-2016:1709
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00061.html
SUSE SUSE-SU-2016:1710
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
SUSE SUSE-SU-2016:1937
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html
SUSE SUSE-SU-2016:1985
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00027.html
SUSE SUSE-SU-2016:2018
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html
SUSE SUSE-SU-2016:2105
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00048.html
SUSE SUSE-SU-2016:2174
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00050.html
SUSE SUSE-SU-2016:2177
http://www.ubuntu.com/usn/USN-3018-2
UBUNTU USN-3018-2
http://www.ubuntu.com/usn/USN-3019-1
UBUNTU USN-3019-1
http://www.ubuntu.com/usn/USN-3020-1
UBUNTU USN-3020-1
https://github.com/nccgroup/TriforceLinuxSyscallFuzzer/tree/master/crash_reports/report_compatIpt
http://www.securityfocus.com/bid/91451
BID 91451 Linux Kernel Multiple Local Memory Corruption Vulnerabilities Release Date:2017-08-01
https://bugzilla.redhat.com/show_bug.cgi?id=1349722 CONFIRM
http://www.ubuntu.com/usn/USN-3018-1
UBUNTU USN-3018-1
http://www.ubuntu.com/usn/USN-3017-1
UBUNTU USN-3017-1
http://www.ubuntu.com/usn/USN-3017-2
UBUNTU USN-3017-2
http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.6.3 CONFIRM
http://www.ubuntu.com/usn/USN-3016-4
UBUNTU USN-3016-4
http://www.ubuntu.com/usn/USN-3016-2
UBUNTU USN-3016-2
http://www.ubuntu.com/usn/USN-3016-3
UBUNTU USN-3016-3
http://www.ubuntu.com/usn/USN-3016-1
UBUNTU USN-3016-1
http://www.ubuntu.com/usn/USN-3017-3
UBUNTU USN-3017-3
http://www.securitytracker.com/id/1036171
SECTRACK 1036171
http://www.oracle.com/technetwork/topics/security/ovmbulletinoct2016-3090547.html CONFIRM
http://www.oracle.com/technetwork/topics/security/linuxbulletinjul2016-3090544.html CONFIRM
http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2016-3090545.html CONFIRM
http://www.openwall.com/lists/oss-security/2016/09/29/10
MLIST [oss-security] 20160929 CVE request - Linux kernel through 4.6.2 allows escalade privileges via IP6T_SO_SET_REPLACE compat setsockopt call
http://www.openwall.com/lists/oss-security/2016/06/24/5
MLIST [oss-security] 20160624 Linux CVE-2016-4997 (local privilege escalation) and CVE-2016-4998 (out of bounds memory access)
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00052.html
SUSE SUSE-SU-2016:2179
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00053.html
SUSE SUSE-SU-2016:2180
http://rhn.redhat.com/errata/RHSA-2016-1847.html
REDHAT RHSA-2016:1847
http://rhn.redhat.com/errata/RHSA-2016-1875.html
REDHAT RHSA-2016:1875
http://www.debian.org/security/2016/dsa-3607
DEBIAN DSA-3607
http://rhn.redhat.com/errata/RHSA-2016-1883.html
REDHAT RHSA-2016:1883
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00055.html
SUSE openSUSE-SU-2016:2184
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00054.html
SUSE SUSE-SU-2016:2181
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00051.html
SUSE SUSE-SU-2016:2178
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ce683e5f9d045e5d67d1312a42b359cb2ab2a13c CONFIRM

- Metasploit Modules Related To CVE-2016-4997

Linux Kernel 4.6.3 Netfilter Privilege Escalation
This module attempts to exploit a netfilter bug on Linux Kernels before 4.6.3, and currently only works against Ubuntu 16.04 (not 16.04.1) with kernel 4.4.0-21-generic. Several conditions have to be met for successful exploitation: Ubuntu: 1. ip_tables.ko (ubuntu), iptable_raw (fedora) has to be loaded (root running iptables -L will do such) 2. libc6-dev-i386 (ubuntu), glibc-devel.i686 & libgcc.i686 (fedora) needs to be installed to compile Kernel 4.4.0-31-generic and newer are not vulnerable. We write the ascii files and compile on target instead of locally since metasm bombs for not having cdefs.h (even if locally installed)
Module type : exploit Rank : good Platforms : Linux


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.