CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-1234

Stack-based buffer overflow in the glob implementation in GNU C Library (aka glibc) before 2.24, when GLOB_ALTDIRFUNC is used, allows context-dependent attackers to cause a denial of service (crash) via a long name.
Publish Date : 2016-06-01 Last Update Date : 2019-05-31
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 119

- Products Affected By CVE-2016-1234

# Product Type Vendor Product Version Update Edition Language
1 OS Fedoraproject Fedora 23 Version Details Vulnerabilities
2 Application GNU Glibc - Version Details Vulnerabilities
3 Application GNU Glibc 0.1 Version Details Vulnerabilities
4 Application GNU Glibc 0.4 Version Details Vulnerabilities
5 Application GNU Glibc 0.4.1 Version Details Vulnerabilities
6 Application GNU Glibc 0.5 Version Details Vulnerabilities
7 Application GNU Glibc 0.6 Version Details Vulnerabilities
8 Application GNU Glibc 1.00 Version Details Vulnerabilities
9 Application GNU Glibc 1.01 Version Details Vulnerabilities
10 Application GNU Glibc 1.02 Version Details Vulnerabilities
11 Application GNU Glibc 1.03 Version Details Vulnerabilities
12 Application GNU Glibc 1.04 Version Details Vulnerabilities
13 Application GNU Glibc 1.05 Version Details Vulnerabilities
14 Application GNU Glibc 1.06 Version Details Vulnerabilities
15 Application GNU Glibc 1.06.1 Version Details Vulnerabilities
16 Application GNU Glibc 1.06.2 Version Details Vulnerabilities
17 Application GNU Glibc 1.06.3 Version Details Vulnerabilities
18 Application GNU Glibc 1.06.4 Version Details Vulnerabilities
19 Application GNU Glibc 1.06.6 Version Details Vulnerabilities
20 Application GNU Glibc 1.06.7 Version Details Vulnerabilities
21 Application GNU Glibc 1.06.8 Version Details Vulnerabilities
22 Application GNU Glibc 1.06.9 Version Details Vulnerabilities
23 Application GNU Glibc 1.06.10 Version Details Vulnerabilities
24 Application GNU Glibc 1.06.11 Version Details Vulnerabilities
25 Application GNU Glibc 1.06.12 Version Details Vulnerabilities
26 Application GNU Glibc 1.06.13 Version Details Vulnerabilities
27 Application GNU Glibc 1.07 Version Details Vulnerabilities
28 Application GNU Glibc 1.07.1 Version Details Vulnerabilities
29 Application GNU Glibc 1.07.2 Version Details Vulnerabilities
30 Application GNU Glibc 1.07.3 Version Details Vulnerabilities
31 Application GNU Glibc 1.07.4 Version Details Vulnerabilities
32 Application GNU Glibc 1.07.5 Version Details Vulnerabilities
33 Application GNU Glibc 1.07.6 Version Details Vulnerabilities
34 Application GNU Glibc 1.08 Version Details Vulnerabilities
35 Application GNU Glibc 1.08.1 Version Details Vulnerabilities
36 Application GNU Glibc 1.08.3 Version Details Vulnerabilities
37 Application GNU Glibc 1.08.4 Version Details Vulnerabilities
38 Application GNU Glibc 1.08.5 Version Details Vulnerabilities
39 Application GNU Glibc 1.08.6 Version Details Vulnerabilities
40 Application GNU Glibc 1.08.7 Version Details Vulnerabilities
41 Application GNU Glibc 1.08.8 Version Details Vulnerabilities
42 Application GNU Glibc 1.08.9 Version Details Vulnerabilities
43 Application GNU Glibc 1.08.10 Version Details Vulnerabilities
44 Application GNU Glibc 1.08.11 Version Details Vulnerabilities
45 Application GNU Glibc 1.08.12 Version Details Vulnerabilities
46 Application GNU Glibc 1.08.13 Version Details Vulnerabilities
47 Application GNU Glibc 1.08.14 Version Details Vulnerabilities
48 Application GNU Glibc 1.09 Version Details Vulnerabilities
49 Application GNU Glibc 1.09.1 Version Details Vulnerabilities
50 Application GNU Glibc 1.09.2 Version Details Vulnerabilities
51 Application GNU Glibc 1.09.3 Version Details Vulnerabilities
52 Application GNU Glibc 1.09.5 Version Details Vulnerabilities
53 Application GNU Glibc 2.0 Version Details Vulnerabilities
54 Application GNU Glibc 2.0.1 Version Details Vulnerabilities
55 Application GNU Glibc 2.0.2 Version Details Vulnerabilities
56 Application GNU Glibc 2.0.3 Version Details Vulnerabilities
57 Application GNU Glibc 2.0.4 Version Details Vulnerabilities
58 Application GNU Glibc 2.0.5 Version Details Vulnerabilities
59 Application GNU Glibc 2.0.6 Version Details Vulnerabilities
60 Application GNU Glibc 2.1 Version Details Vulnerabilities
61 Application GNU Glibc 2.1.1 Version Details Vulnerabilities
62 Application GNU Glibc 2.1.1.6 Version Details Vulnerabilities
63 Application GNU Glibc 2.1.2 Version Details Vulnerabilities
64 Application GNU Glibc 2.1.3 Version Details Vulnerabilities
65 Application GNU Glibc 2.1.3.10 Version Details Vulnerabilities
66 Application GNU Glibc 2.1.9 Version Details Vulnerabilities
67 Application GNU Glibc 2.2 Version Details Vulnerabilities
68 Application GNU Glibc 2.2.1 Version Details Vulnerabilities
69 Application GNU Glibc 2.2.2 Version Details Vulnerabilities
70 Application GNU Glibc 2.2.3 Version Details Vulnerabilities
71 Application GNU Glibc 2.2.4 Version Details Vulnerabilities
72 Application GNU Glibc 2.2.5 Version Details Vulnerabilities
73 Application GNU Glibc 2.3 Version Details Vulnerabilities
74 Application GNU Glibc 2.3.1 Version Details Vulnerabilities
75 Application GNU Glibc 2.3.2 Version Details Vulnerabilities
76 Application GNU Glibc 2.3.3 Version Details Vulnerabilities
77 Application GNU Glibc 2.3.4 Version Details Vulnerabilities
78 Application GNU Glibc 2.3.5 Version Details Vulnerabilities
79 Application GNU Glibc 2.3.6 Version Details Vulnerabilities
80 Application GNU Glibc 2.3.10 Version Details Vulnerabilities
81 Application GNU Glibc 2.4 Version Details Vulnerabilities
82 Application GNU Glibc 2.5 Version Details Vulnerabilities
83 Application GNU Glibc 2.5.1 Version Details Vulnerabilities
84 Application GNU Glibc 2.6 Version Details Vulnerabilities
85 Application GNU Glibc 2.6.1 Version Details Vulnerabilities
86 Application GNU Glibc 2.7 Version Details Vulnerabilities
87 Application GNU Glibc 2.8 Version Details Vulnerabilities
88 Application GNU Glibc 2.9 Version Details Vulnerabilities
89 Application GNU Glibc 2.10 Version Details Vulnerabilities
90 Application GNU Glibc 2.10.1 Version Details Vulnerabilities
91 Application GNU Glibc 2.10.2 Version Details Vulnerabilities
92 Application GNU Glibc 2.11 Version Details Vulnerabilities
93 Application GNU Glibc 2.11.1 Version Details Vulnerabilities
94 Application GNU Glibc 2.11.2 Version Details Vulnerabilities
95 Application GNU Glibc 2.11.3 Version Details Vulnerabilities
96 Application GNU Glibc 2.12 Version Details Vulnerabilities
97 Application GNU Glibc 2.12 ~~~~x86~ Version Details Vulnerabilities
98 Application GNU Glibc 2.12.0 Version Details Vulnerabilities
99 Application GNU Glibc 2.12.1 Version Details Vulnerabilities
100 Application GNU Glibc 2.12.2 Version Details Vulnerabilities
101 Application GNU Glibc 2.13 Version Details Vulnerabilities
102 Application GNU Glibc 2.14 Version Details Vulnerabilities
103 Application GNU Glibc 2.14.1 Version Details Vulnerabilities
104 Application GNU Glibc 2.15 Version Details Vulnerabilities
105 Application GNU Glibc 2.16 Version Details Vulnerabilities
106 Application GNU Glibc 2.17 Version Details Vulnerabilities
107 Application GNU Glibc 2.17 ~~~~x86~ Version Details Vulnerabilities
108 Application GNU Glibc 2.18 Version Details Vulnerabilities
109 Application GNU Glibc 2.18 ~~~~x86~ Version Details Vulnerabilities
110 Application GNU Glibc 2.19 Version Details Vulnerabilities
111 Application GNU Glibc 2.20 Version Details Vulnerabilities
112 Application GNU Glibc 2.20 ~~~~x86~ Version Details Vulnerabilities
113 Application GNU Glibc 2.21 Version Details Vulnerabilities
114 Application GNU Glibc 2.22 Version Details Vulnerabilities
115 Application GNU Glibc 2.22 ~~~~x86~ Version Details Vulnerabilities
116 Application GNU Glibc 2.23 Version Details Vulnerabilities
117 OS Opensuse Leap 42.1 Version Details Vulnerabilities
118 OS Opensuse Opensuse 13.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Fedoraproject Fedora 1
GNU Glibc 115
Opensuse Leap 1
Opensuse Opensuse 1

- References For CVE-2016-1234

http://lists.opensuse.org/opensuse-updates/2016-06/msg00030.html
SUSE openSUSE-SU-2016:1527
http://lists.fedoraproject.org/pipermail/package-announce/2016-May/184626.html
FEDORA FEDORA-2016-68abc0be35
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=5171f3079f2cc53e0548fc4967361f4d1ce9d7ea CONFIRM
http://www.securityfocus.com/bid/84204
BID 84204 GNU glibc CVE-2016-1234 Local Buffer Overflow Vulnerability Release Date:2017-03-28
https://security.gentoo.org/glsa/201702-11
GENTOO GLSA-201702-11
http://www.openwall.com/lists/oss-security/2016/03/07/16
MLIST [oss-security] 20160307 CVE-2016-1234 in glibc glob with GLOB_ALTDIRFUNC
http://lists.opensuse.org/opensuse-updates/2016-07/msg00039.html
SUSE openSUSE-SU-2016:1779
https://sourceware.org/bugzilla/show_bug.cgi?id=19779 CONFIRM

- Metasploit Modules Related To CVE-2016-1234

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.