CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-10558

aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Publish Date : 2018-05-29 Last Update Date : 2019-10-09
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 310

- Products Affected By CVE-2016-10558

# Product Type Vendor Product Version Update Edition Language
1 Application Aerospike Aerospike 1.0.0 ~~~node.js~~ Version Details Vulnerabilities
2 Application Aerospike Aerospike 1.0.1 ~~~node.js~~ Version Details Vulnerabilities
3 Application Aerospike Aerospike 1.0.2 ~~~node.js~~ Version Details Vulnerabilities
4 Application Aerospike Aerospike 1.0.3 ~~~node.js~~ Version Details Vulnerabilities
5 Application Aerospike Aerospike 1.0.4 ~~~node.js~~ Version Details Vulnerabilities
6 Application Aerospike Aerospike 1.0.5 ~~~node.js~~ Version Details Vulnerabilities
7 Application Aerospike Aerospike 1.0.6 ~~~node.js~~ Version Details Vulnerabilities
8 Application Aerospike Aerospike 1.0.7 ~~~node.js~~ Version Details Vulnerabilities
9 Application Aerospike Aerospike 1.0.8 ~~~node.js~~ Version Details Vulnerabilities
10 Application Aerospike Aerospike 1.0.9 ~~~node.js~~ Version Details Vulnerabilities
11 Application Aerospike Aerospike 1.0.10 ~~~node.js~~ Version Details Vulnerabilities
12 Application Aerospike Aerospike 1.0.11 ~~~node.js~~ Version Details Vulnerabilities
13 Application Aerospike Aerospike 1.0.12 ~~~node.js~~ Version Details Vulnerabilities
14 Application Aerospike Aerospike 1.0.13 ~~~node.js~~ Version Details Vulnerabilities
15 Application Aerospike Aerospike 1.0.14 ~~~node.js~~ Version Details Vulnerabilities
16 Application Aerospike Aerospike 1.0.15 ~~~node.js~~ Version Details Vulnerabilities
17 Application Aerospike Aerospike 1.0.16 ~~~node.js~~ Version Details Vulnerabilities
18 Application Aerospike Aerospike 1.0.17 ~~~node.js~~ Version Details Vulnerabilities
19 Application Aerospike Aerospike 1.0.18 ~~~node.js~~ Version Details Vulnerabilities
20 Application Aerospike Aerospike 1.0.19 ~~~node.js~~ Version Details Vulnerabilities
21 Application Aerospike Aerospike 1.0.20 ~~~node.js~~ Version Details Vulnerabilities
22 Application Aerospike Aerospike 1.0.21 ~~~node.js~~ Version Details Vulnerabilities
23 Application Aerospike Aerospike 1.0.22 ~~~node.js~~ Version Details Vulnerabilities
24 Application Aerospike Aerospike 1.0.23 ~~~node.js~~ Version Details Vulnerabilities
25 Application Aerospike Aerospike 1.0.24 ~~~node.js~~ Version Details Vulnerabilities
26 Application Aerospike Aerospike 1.0.25 ~~~node.js~~ Version Details Vulnerabilities
27 Application Aerospike Aerospike 1.0.26 ~~~node.js~~ Version Details Vulnerabilities
28 Application Aerospike Aerospike 1.0.27 ~~~node.js~~ Version Details Vulnerabilities
29 Application Aerospike Aerospike 1.0.28 ~~~node.js~~ Version Details Vulnerabilities
30 Application Aerospike Aerospike 1.0.29 ~~~node.js~~ Version Details Vulnerabilities
31 Application Aerospike Aerospike 1.0.30 ~~~node.js~~ Version Details Vulnerabilities
32 Application Aerospike Aerospike 1.0.31 ~~~node.js~~ Version Details Vulnerabilities
33 Application Aerospike Aerospike 1.0.32 ~~~node.js~~ Version Details Vulnerabilities
34 Application Aerospike Aerospike 1.0.33 ~~~node.js~~ Version Details Vulnerabilities
35 Application Aerospike Aerospike 1.0.34 ~~~node.js~~ Version Details Vulnerabilities
36 Application Aerospike Aerospike 1.0.35 ~~~node.js~~ Version Details Vulnerabilities
37 Application Aerospike Aerospike 1.0.36 ~~~node.js~~ Version Details Vulnerabilities
38 Application Aerospike Aerospike 1.0.37 ~~~node.js~~ Version Details Vulnerabilities
39 Application Aerospike Aerospike 1.0.38 ~~~node.js~~ Version Details Vulnerabilities
40 Application Aerospike Aerospike 1.0.39 ~~~node.js~~ Version Details Vulnerabilities
41 Application Aerospike Aerospike 1.0.40 ~~~node.js~~ Version Details Vulnerabilities
42 Application Aerospike Aerospike 1.0.41 ~~~node.js~~ Version Details Vulnerabilities
43 Application Aerospike Aerospike 1.0.42 ~~~node.js~~ Version Details Vulnerabilities
44 Application Aerospike Aerospike 1.0.43 ~~~node.js~~ Version Details Vulnerabilities
45 Application Aerospike Aerospike 1.0.44 ~~~node.js~~ Version Details Vulnerabilities
46 Application Aerospike Aerospike 1.0.45 ~~~node.js~~ Version Details Vulnerabilities
47 Application Aerospike Aerospike 1.0.46 ~~~node.js~~ Version Details Vulnerabilities
48 Application Aerospike Aerospike 1.0.47 ~~~node.js~~ Version Details Vulnerabilities
49 Application Aerospike Aerospike 1.0.48 ~~~node.js~~ Version Details Vulnerabilities
50 Application Aerospike Aerospike 1.0.49 ~~~node.js~~ Version Details Vulnerabilities
51 Application Aerospike Aerospike 1.0.50 ~~~node.js~~ Version Details Vulnerabilities
52 Application Aerospike Aerospike 1.0.51 ~~~node.js~~ Version Details Vulnerabilities
53 Application Aerospike Aerospike 1.0.52 ~~~node.js~~ Version Details Vulnerabilities
54 Application Aerospike Aerospike 1.0.53 ~~~node.js~~ Version Details Vulnerabilities
55 Application Aerospike Aerospike 1.0.54 ~~~node.js~~ Version Details Vulnerabilities
56 Application Aerospike Aerospike 1.0.55 ~~~node.js~~ Version Details Vulnerabilities
57 Application Aerospike Aerospike 1.0.56 ~~~node.js~~ Version Details Vulnerabilities
58 Application Aerospike Aerospike 1.0.57 ~~~node.js~~ Version Details Vulnerabilities
59 Application Aerospike Aerospike 1.0.58 ~~~node.js~~ Version Details Vulnerabilities
60 Application Aerospike Aerospike 2.0.0 Alpha1 ~~~node.js~~ Version Details Vulnerabilities
61 Application Aerospike Aerospike 2.0.0 Alpha2 ~~~node.js~~ Version Details Vulnerabilities
62 Application Aerospike Aerospike 2.0.0 Alpha3 ~~~node.js~~ Version Details Vulnerabilities
63 Application Aerospike Aerospike 2.0.0 - ~~~node.js~~ Version Details Vulnerabilities
64 Application Aerospike Aerospike 2.0.1 ~~~node.js~~ Version Details Vulnerabilities
65 Application Aerospike Aerospike 2.0.2 ~~~node.js~~ Version Details Vulnerabilities
66 Application Aerospike Aerospike 2.0.3 ~~~node.js~~ Version Details Vulnerabilities
67 Application Aerospike Aerospike 2.0.4 ~~~node.js~~ Version Details Vulnerabilities
68 Application Aerospike Aerospike 2.1.0 ~~~node.js~~ Version Details Vulnerabilities
69 Application Aerospike Aerospike 2.1.1 ~~~node.js~~ Version Details Vulnerabilities
70 Application Aerospike Aerospike 2.2.0 ~~~node.js~~ Version Details Vulnerabilities
71 Application Aerospike Aerospike 2.3.0 ~~~node.js~~ Version Details Vulnerabilities
72 Application Aerospike Aerospike 2.3.1 ~~~node.js~~ Version Details Vulnerabilities
73 Application Aerospike Aerospike 2.4.0 ~~~node.js~~ Version Details Vulnerabilities
74 Application Aerospike Aerospike 2.4.1 ~~~node.js~~ Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Aerospike Aerospike 74

- References For CVE-2016-10558

https://nodesecurity.io/advisories/167

- Metasploit Modules Related To CVE-2016-10558

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.