CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-9236

Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at worst allowed cross-origin activities that were expected to be forbidden. If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route.
Publish Date : 2018-05-31 Last Update Date : 2018-08-01
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Products Affected By CVE-2015-9236

# Product Type Vendor Product Version Update Edition Language
1 Application Hapijs Hapi 0.0.1 ~~~node.js~~ Version Details Vulnerabilities
2 Application Hapijs Hapi 0.0.2 ~~~node.js~~ Version Details Vulnerabilities
3 Application Hapijs Hapi 0.0.3 ~~~node.js~~ Version Details Vulnerabilities
4 Application Hapijs Hapi 0.0.4 ~~~node.js~~ Version Details Vulnerabilities
5 Application Hapijs Hapi 0.0.5 ~~~node.js~~ Version Details Vulnerabilities
6 Application Hapijs Hapi 0.0.6 ~~~node.js~~ Version Details Vulnerabilities
7 Application Hapijs Hapi 0.1.0 ~~~node.js~~ Version Details Vulnerabilities
8 Application Hapijs Hapi 0.1.1 ~~~node.js~~ Version Details Vulnerabilities
9 Application Hapijs Hapi 0.1.2 ~~~node.js~~ Version Details Vulnerabilities
10 Application Hapijs Hapi 0.1.3 ~~~node.js~~ Version Details Vulnerabilities
11 Application Hapijs Hapi 0.2.0 ~~~node.js~~ Version Details Vulnerabilities
12 Application Hapijs Hapi 0.2.1 ~~~node.js~~ Version Details Vulnerabilities
13 Application Hapijs Hapi 0.3.0 ~~~node.js~~ Version Details Vulnerabilities
14 Application Hapijs Hapi 0.4.0 ~~~node.js~~ Version Details Vulnerabilities
15 Application Hapijs Hapi 0.4.1 ~~~node.js~~ Version Details Vulnerabilities
16 Application Hapijs Hapi 0.4.2 ~~~node.js~~ Version Details Vulnerabilities
17 Application Hapijs Hapi 0.4.3 ~~~node.js~~ Version Details Vulnerabilities
18 Application Hapijs Hapi 0.4.4 ~~~node.js~~ Version Details Vulnerabilities
19 Application Hapijs Hapi 0.5.0 ~~~node.js~~ Version Details Vulnerabilities
20 Application Hapijs Hapi 0.5.1 ~~~node.js~~ Version Details Vulnerabilities
21 Application Hapijs Hapi 0.5.2 ~~~node.js~~ Version Details Vulnerabilities
22 Application Hapijs Hapi 0.6.0 ~~~node.js~~ Version Details Vulnerabilities
23 Application Hapijs Hapi 0.6.1 ~~~node.js~~ Version Details Vulnerabilities
24 Application Hapijs Hapi 0.7.0 ~~~node.js~~ Version Details Vulnerabilities
25 Application Hapijs Hapi 0.7.1 ~~~node.js~~ Version Details Vulnerabilities
26 Application Hapijs Hapi 0.8.0 ~~~node.js~~ Version Details Vulnerabilities
27 Application Hapijs Hapi 0.8.1 ~~~node.js~~ Version Details Vulnerabilities
28 Application Hapijs Hapi 0.8.2 ~~~node.js~~ Version Details Vulnerabilities
29 Application Hapijs Hapi 0.8.3 ~~~node.js~~ Version Details Vulnerabilities
30 Application Hapijs Hapi 0.8.4 ~~~node.js~~ Version Details Vulnerabilities
31 Application Hapijs Hapi 0.9.0 ~~~node.js~~ Version Details Vulnerabilities
32 Application Hapijs Hapi 0.9.1 ~~~node.js~~ Version Details Vulnerabilities
33 Application Hapijs Hapi 0.9.2 ~~~node.js~~ Version Details Vulnerabilities
34 Application Hapijs Hapi 0.10.0 ~~~node.js~~ Version Details Vulnerabilities
35 Application Hapijs Hapi 0.10.1 ~~~node.js~~ Version Details Vulnerabilities
36 Application Hapijs Hapi 0.11.0 ~~~node.js~~ Version Details Vulnerabilities
37 Application Hapijs Hapi 0.11.1 ~~~node.js~~ Version Details Vulnerabilities
38 Application Hapijs Hapi 0.11.2 ~~~node.js~~ Version Details Vulnerabilities
39 Application Hapijs Hapi 0.11.3 ~~~node.js~~ Version Details Vulnerabilities
40 Application Hapijs Hapi 0.11.4 ~~~node.js~~ Version Details Vulnerabilities
41 Application Hapijs Hapi 0.12.0 ~~~node.js~~ Version Details Vulnerabilities
42 Application Hapijs Hapi 0.13.0 ~~~node.js~~ Version Details Vulnerabilities
43 Application Hapijs Hapi 0.13.1 ~~~node.js~~ Version Details Vulnerabilities
44 Application Hapijs Hapi 0.13.2 ~~~node.js~~ Version Details Vulnerabilities
45 Application Hapijs Hapi 0.13.3 ~~~node.js~~ Version Details Vulnerabilities
46 Application Hapijs Hapi 0.14.0 ~~~node.js~~ Version Details Vulnerabilities
47 Application Hapijs Hapi 0.14.1 ~~~node.js~~ Version Details Vulnerabilities
48 Application Hapijs Hapi 0.14.2 ~~~node.js~~ Version Details Vulnerabilities
49 Application Hapijs Hapi 0.15.0 ~~~node.js~~ Version Details Vulnerabilities
50 Application Hapijs Hapi 0.15.1 ~~~node.js~~ Version Details Vulnerabilities
51 Application Hapijs Hapi 0.15.2 ~~~node.js~~ Version Details Vulnerabilities
52 Application Hapijs Hapi 0.15.3 ~~~node.js~~ Version Details Vulnerabilities
53 Application Hapijs Hapi 0.15.4 ~~~node.js~~ Version Details Vulnerabilities
54 Application Hapijs Hapi 0.15.5 ~~~node.js~~ Version Details Vulnerabilities
55 Application Hapijs Hapi 0.15.6 ~~~node.js~~ Version Details Vulnerabilities
56 Application Hapijs Hapi 0.15.7 ~~~node.js~~ Version Details Vulnerabilities
57 Application Hapijs Hapi 0.15.8 ~~~node.js~~ Version Details Vulnerabilities
58 Application Hapijs Hapi 0.15.9 ~~~node.js~~ Version Details Vulnerabilities
59 Application Hapijs Hapi 0.16.0 ~~~node.js~~ Version Details Vulnerabilities
60 Application Hapijs Hapi 1.0.0 ~~~node.js~~ Version Details Vulnerabilities
61 Application Hapijs Hapi 1.0.1 ~~~node.js~~ Version Details Vulnerabilities
62 Application Hapijs Hapi 1.0.2 ~~~node.js~~ Version Details Vulnerabilities
63 Application Hapijs Hapi 1.0.3 ~~~node.js~~ Version Details Vulnerabilities
64 Application Hapijs Hapi 1.1.0 ~~~node.js~~ Version Details Vulnerabilities
65 Application Hapijs Hapi 1.2.0 ~~~node.js~~ Version Details Vulnerabilities
66 Application Hapijs Hapi 1.3.0 ~~~node.js~~ Version Details Vulnerabilities
67 Application Hapijs Hapi 1.4.0 ~~~node.js~~ Version Details Vulnerabilities
68 Application Hapijs Hapi 1.5.0 ~~~node.js~~ Version Details Vulnerabilities
69 Application Hapijs Hapi 1.6.0 ~~~node.js~~ Version Details Vulnerabilities
70 Application Hapijs Hapi 1.6.1 ~~~node.js~~ Version Details Vulnerabilities
71 Application Hapijs Hapi 1.6.2 ~~~node.js~~ Version Details Vulnerabilities
72 Application Hapijs Hapi 1.7.0 ~~~node.js~~ Version Details Vulnerabilities
73 Application Hapijs Hapi 1.7.1 ~~~node.js~~ Version Details Vulnerabilities
74 Application Hapijs Hapi 1.7.2 ~~~node.js~~ Version Details Vulnerabilities
75 Application Hapijs Hapi 1.7.3 ~~~node.js~~ Version Details Vulnerabilities
76 Application Hapijs Hapi 1.8.0 ~~~node.js~~ Version Details Vulnerabilities
77 Application Hapijs Hapi 1.8.1 ~~~node.js~~ Version Details Vulnerabilities
78 Application Hapijs Hapi 1.8.2 ~~~node.js~~ Version Details Vulnerabilities
79 Application Hapijs Hapi 1.8.3 ~~~node.js~~ Version Details Vulnerabilities
80 Application Hapijs Hapi 1.9.0 ~~~node.js~~ Version Details Vulnerabilities
81 Application Hapijs Hapi 1.9.1 ~~~node.js~~ Version Details Vulnerabilities
82 Application Hapijs Hapi 1.9.2 ~~~node.js~~ Version Details Vulnerabilities
83 Application Hapijs Hapi 1.9.3 ~~~node.js~~ Version Details Vulnerabilities
84 Application Hapijs Hapi 1.9.4 ~~~node.js~~ Version Details Vulnerabilities
85 Application Hapijs Hapi 1.9.5 ~~~node.js~~ Version Details Vulnerabilities
86 Application Hapijs Hapi 1.9.6 ~~~node.js~~ Version Details Vulnerabilities
87 Application Hapijs Hapi 1.9.7 ~~~node.js~~ Version Details Vulnerabilities
88 Application Hapijs Hapi 1.10.0 ~~~node.js~~ Version Details Vulnerabilities
89 Application Hapijs Hapi 1.11.0 ~~~node.js~~ Version Details Vulnerabilities
90 Application Hapijs Hapi 1.11.1 ~~~node.js~~ Version Details Vulnerabilities
91 Application Hapijs Hapi 1.12.0 ~~~node.js~~ Version Details Vulnerabilities
92 Application Hapijs Hapi 1.13.0 ~~~node.js~~ Version Details Vulnerabilities
93 Application Hapijs Hapi 1.14.0 ~~~node.js~~ Version Details Vulnerabilities
94 Application Hapijs Hapi 1.15.0 ~~~node.js~~ Version Details Vulnerabilities
95 Application Hapijs Hapi 1.16.0 ~~~node.js~~ Version Details Vulnerabilities
96 Application Hapijs Hapi 1.16.1 ~~~node.js~~ Version Details Vulnerabilities
97 Application Hapijs Hapi 1.17.0 ~~~node.js~~ Version Details Vulnerabilities
98 Application Hapijs Hapi 1.18.0 ~~~node.js~~ Version Details Vulnerabilities
99 Application Hapijs Hapi 1.19.0 ~~~node.js~~ Version Details Vulnerabilities
100 Application Hapijs Hapi 1.19.1 ~~~node.js~~ Version Details Vulnerabilities
101 Application Hapijs Hapi 1.19.2 ~~~node.js~~ Version Details Vulnerabilities
102 Application Hapijs Hapi 1.19.3 ~~~node.js~~ Version Details Vulnerabilities
103 Application Hapijs Hapi 1.19.4 ~~~node.js~~ Version Details Vulnerabilities
104 Application Hapijs Hapi 1.19.5 ~~~node.js~~ Version Details Vulnerabilities
105 Application Hapijs Hapi 1.20.0 ~~~node.js~~ Version Details Vulnerabilities
106 Application Hapijs Hapi 2.0.0 ~~~node.js~~ Version Details Vulnerabilities
107 Application Hapijs Hapi 2.1.0 ~~~node.js~~ Version Details Vulnerabilities
108 Application Hapijs Hapi 2.1.1 ~~~node.js~~ Version Details Vulnerabilities
109 Application Hapijs Hapi 2.1.2 ~~~node.js~~ Version Details Vulnerabilities
110 Application Hapijs Hapi 2.2.0 ~~~node.js~~ Version Details Vulnerabilities
111 Application Hapijs Hapi 2.3.0 ~~~node.js~~ Version Details Vulnerabilities
112 Application Hapijs Hapi 2.4.0 ~~~node.js~~ Version Details Vulnerabilities
113 Application Hapijs Hapi 2.5.0 ~~~node.js~~ Version Details Vulnerabilities
114 Application Hapijs Hapi 2.6.0 ~~~node.js~~ Version Details Vulnerabilities
115 Application Hapijs Hapi 3.0.0 ~~~node.js~~ Version Details Vulnerabilities
116 Application Hapijs Hapi 3.0.1 ~~~node.js~~ Version Details Vulnerabilities
117 Application Hapijs Hapi 3.0.2 ~~~node.js~~ Version Details Vulnerabilities
118 Application Hapijs Hapi 3.1.0 ~~~node.js~~ Version Details Vulnerabilities
119 Application Hapijs Hapi 4.0.0 ~~~node.js~~ Version Details Vulnerabilities
120 Application Hapijs Hapi 4.0.1 ~~~node.js~~ Version Details Vulnerabilities
121 Application Hapijs Hapi 4.0.2 ~~~node.js~~ Version Details Vulnerabilities
122 Application Hapijs Hapi 4.0.3 ~~~node.js~~ Version Details Vulnerabilities
123 Application Hapijs Hapi 4.1.0 ~~~node.js~~ Version Details Vulnerabilities
124 Application Hapijs Hapi 4.1.1 ~~~node.js~~ Version Details Vulnerabilities
125 Application Hapijs Hapi 4.1.2 ~~~node.js~~ Version Details Vulnerabilities
126 Application Hapijs Hapi 4.1.3 ~~~node.js~~ Version Details Vulnerabilities
127 Application Hapijs Hapi 4.1.4 ~~~node.js~~ Version Details Vulnerabilities
128 Application Hapijs Hapi 5.0.0 ~~~node.js~~ Version Details Vulnerabilities
129 Application Hapijs Hapi 5.1.0 ~~~node.js~~ Version Details Vulnerabilities
130 Application Hapijs Hapi 6.0.0 ~~~node.js~~ Version Details Vulnerabilities
131 Application Hapijs Hapi 6.0.1 ~~~node.js~~ Version Details Vulnerabilities
132 Application Hapijs Hapi 6.0.2 ~~~node.js~~ Version Details Vulnerabilities
133 Application Hapijs Hapi 6.1.0 ~~~node.js~~ Version Details Vulnerabilities
134 Application Hapijs Hapi 6.2.0 ~~~node.js~~ Version Details Vulnerabilities
135 Application Hapijs Hapi 6.2.1 ~~~node.js~~ Version Details Vulnerabilities
136 Application Hapijs Hapi 6.2.2 ~~~node.js~~ Version Details Vulnerabilities
137 Application Hapijs Hapi 6.3.0 ~~~node.js~~ Version Details Vulnerabilities
138 Application Hapijs Hapi 6.4.0 ~~~node.js~~ Version Details Vulnerabilities
139 Application Hapijs Hapi 6.5.0 ~~~node.js~~ Version Details Vulnerabilities
140 Application Hapijs Hapi 6.5.1 ~~~node.js~~ Version Details Vulnerabilities
141 Application Hapijs Hapi 6.6.0 ~~~node.js~~ Version Details Vulnerabilities
142 Application Hapijs Hapi 6.7.0 ~~~node.js~~ Version Details Vulnerabilities
143 Application Hapijs Hapi 6.7.1 ~~~node.js~~ Version Details Vulnerabilities
144 Application Hapijs Hapi 6.8.0 ~~~node.js~~ Version Details Vulnerabilities
145 Application Hapijs Hapi 6.8.1 ~~~node.js~~ Version Details Vulnerabilities
146 Application Hapijs Hapi 6.9.0 ~~~node.js~~ Version Details Vulnerabilities
147 Application Hapijs Hapi 6.10.0 ~~~node.js~~ Version Details Vulnerabilities
148 Application Hapijs Hapi 6.11.0 ~~~node.js~~ Version Details Vulnerabilities
149 Application Hapijs Hapi 6.11.1 ~~~node.js~~ Version Details Vulnerabilities
150 Application Hapijs Hapi 7.0.0 ~~~node.js~~ Version Details Vulnerabilities
151 Application Hapijs Hapi 7.0.1 ~~~node.js~~ Version Details Vulnerabilities
152 Application Hapijs Hapi 7.1.0 ~~~node.js~~ Version Details Vulnerabilities
153 Application Hapijs Hapi 7.1.1 ~~~node.js~~ Version Details Vulnerabilities
154 Application Hapijs Hapi 7.2.0 ~~~node.js~~ Version Details Vulnerabilities
155 Application Hapijs Hapi 7.3.0 ~~~node.js~~ Version Details Vulnerabilities
156 Application Hapijs Hapi 7.4.0 ~~~node.js~~ Version Details Vulnerabilities
157 Application Hapijs Hapi 7.5.0 ~~~node.js~~ Version Details Vulnerabilities
158 Application Hapijs Hapi 7.5.1 ~~~node.js~~ Version Details Vulnerabilities
159 Application Hapijs Hapi 7.5.2 ~~~node.js~~ Version Details Vulnerabilities
160 Application Hapijs Hapi 7.5.3 ~~~node.js~~ Version Details Vulnerabilities
161 Application Hapijs Hapi 8.0.0 ~~~node.js~~ Version Details Vulnerabilities
162 Application Hapijs Hapi 8.1.0 ~~~node.js~~ Version Details Vulnerabilities
163 Application Hapijs Hapi 8.2.0 ~~~node.js~~ Version Details Vulnerabilities
164 Application Hapijs Hapi 8.3.0 ~~~node.js~~ Version Details Vulnerabilities
165 Application Hapijs Hapi 8.3.1 ~~~node.js~~ Version Details Vulnerabilities
166 Application Hapijs Hapi 8.4.0 ~~~node.js~~ Version Details Vulnerabilities
167 Application Hapijs Hapi 8.5.0 ~~~node.js~~ Version Details Vulnerabilities
168 Application Hapijs Hapi 8.5.1 ~~~node.js~~ Version Details Vulnerabilities
169 Application Hapijs Hapi 8.5.2 ~~~node.js~~ Version Details Vulnerabilities
170 Application Hapijs Hapi 8.5.3 ~~~node.js~~ Version Details Vulnerabilities
171 Application Hapijs Hapi 8.6.0 ~~~node.js~~ Version Details Vulnerabilities
172 Application Hapijs Hapi 8.6.1 ~~~node.js~~ Version Details Vulnerabilities
173 Application Hapijs Hapi 8.8.0 ~~~node.js~~ Version Details Vulnerabilities
174 Application Hapijs Hapi 8.8.1 ~~~node.js~~ Version Details Vulnerabilities
175 Application Hapijs Hapi 9.0.0 ~~~node.js~~ Version Details Vulnerabilities
176 Application Hapijs Hapi 9.0.1 ~~~node.js~~ Version Details Vulnerabilities
177 Application Hapijs Hapi 9.0.2 ~~~node.js~~ Version Details Vulnerabilities
178 Application Hapijs Hapi 9.0.3 ~~~node.js~~ Version Details Vulnerabilities
179 Application Hapijs Hapi 9.0.4 ~~~node.js~~ Version Details Vulnerabilities
180 Application Hapijs Hapi 9.1.0 ~~~node.js~~ Version Details Vulnerabilities
181 Application Hapijs Hapi 9.2.0 ~~~node.js~~ Version Details Vulnerabilities
182 Application Hapijs Hapi 9.3.0 ~~~node.js~~ Version Details Vulnerabilities
183 Application Hapijs Hapi 9.3.1 ~~~node.js~~ Version Details Vulnerabilities
184 Application Hapijs Hapi 9.5.1 ~~~node.js~~ Version Details Vulnerabilities
185 Application Hapijs Hapi 10.0.0 ~~~node.js~~ Version Details Vulnerabilities
186 Application Hapijs Hapi 10.0.1 ~~~node.js~~ Version Details Vulnerabilities
187 Application Hapijs Hapi 10.1.0 ~~~node.js~~ Version Details Vulnerabilities
188 Application Hapijs Hapi 10.2.1 ~~~node.js~~ Version Details Vulnerabilities
189 Application Hapijs Hapi 10.4.0 ~~~node.js~~ Version Details Vulnerabilities
190 Application Hapijs Hapi 10.4.1 ~~~node.js~~ Version Details Vulnerabilities
191 Application Hapijs Hapi 10.5.0 ~~~node.js~~ Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Hapijs Hapi 191

- References For CVE-2015-9236

https://nodesecurity.io/advisories/45
https://github.com/hapijs/hapi/issues/2840
https://github.com/hapijs/hapi/issues/2850

- Metasploit Modules Related To CVE-2015-9236

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.