CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-9228

In post-new.php in the Photocrati NextGEN Gallery plugin 2.1.10 for WordPress, unrestricted file upload is available via the name parameter, if a file extension is changed from .jpg to .php.
Publish Date : 2017-09-12 Last Update Date : 2017-09-26
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s)
CWE ID 434

- Products Affected By CVE-2015-9228

# Product Type Vendor Product Version Update Edition Language
1 Application Imagely Nextgen Gallery 1.5.0 ~~~wordpress~~ Version Details Vulnerabilities
2 Application Imagely Nextgen Gallery 1.5.1 ~~~wordpress~~ Version Details Vulnerabilities
3 Application Imagely Nextgen Gallery 1.5.2 ~~~wordpress~~ Version Details Vulnerabilities
4 Application Imagely Nextgen Gallery 1.5.3 ~~~wordpress~~ Version Details Vulnerabilities
5 Application Imagely Nextgen Gallery 1.5.4 ~~~wordpress~~ Version Details Vulnerabilities
6 Application Imagely Nextgen Gallery 1.5.5 ~~~wordpress~~ Version Details Vulnerabilities
7 Application Imagely Nextgen Gallery 1.6.0 ~~~wordpress~~ Version Details Vulnerabilities
8 Application Imagely Nextgen Gallery 1.6.1 ~~~wordpress~~ Version Details Vulnerabilities
9 Application Imagely Nextgen Gallery 1.6.2 ~~~wordpress~~ Version Details Vulnerabilities
10 Application Imagely Nextgen Gallery 1.7.0 ~~~wordpress~~ Version Details Vulnerabilities
11 Application Imagely Nextgen Gallery 1.7.1 ~~~wordpress~~ Version Details Vulnerabilities
12 Application Imagely Nextgen Gallery 1.7.2 ~~~wordpress~~ Version Details Vulnerabilities
13 Application Imagely Nextgen Gallery 1.7.3 ~~~wordpress~~ Version Details Vulnerabilities
14 Application Imagely Nextgen Gallery 1.7.4 ~~~wordpress~~ Version Details Vulnerabilities
15 Application Imagely Nextgen Gallery 1.8.0 ~~~wordpress~~ Version Details Vulnerabilities
16 Application Imagely Nextgen Gallery 1.8.1 ~~~wordpress~~ Version Details Vulnerabilities
17 Application Imagely Nextgen Gallery 1.8.2 ~~~wordpress~~ Version Details Vulnerabilities
18 Application Imagely Nextgen Gallery 1.8.3 ~~~wordpress~~ Version Details Vulnerabilities
19 Application Imagely Nextgen Gallery 1.8.4 ~~~wordpress~~ Version Details Vulnerabilities
20 Application Imagely Nextgen Gallery 1.9.0 ~~~wordpress~~ Version Details Vulnerabilities
21 Application Imagely Nextgen Gallery 1.9.1 ~~~wordpress~~ Version Details Vulnerabilities
22 Application Imagely Nextgen Gallery 1.9.2 ~~~wordpress~~ Version Details Vulnerabilities
23 Application Imagely Nextgen Gallery 1.9.3 ~~~wordpress~~ Version Details Vulnerabilities
24 Application Imagely Nextgen Gallery 1.9.5 ~~~wordpress~~ Version Details Vulnerabilities
25 Application Imagely Nextgen Gallery 1.9.6 ~~~wordpress~~ Version Details Vulnerabilities
26 Application Imagely Nextgen Gallery 1.9.7 ~~~wordpress~~ Version Details Vulnerabilities
27 Application Imagely Nextgen Gallery 1.9.8 ~~~wordpress~~ Version Details Vulnerabilities
28 Application Imagely Nextgen Gallery 1.9.10 ~~~wordpress~~ Version Details Vulnerabilities
29 Application Imagely Nextgen Gallery 1.9.11 ~~~wordpress~~ Version Details Vulnerabilities
30 Application Imagely Nextgen Gallery 1.9.12 ~~~wordpress~~ Version Details Vulnerabilities
31 Application Imagely Nextgen Gallery 1.9.13 ~~~wordpress~~ Version Details Vulnerabilities
32 Application Imagely Nextgen Gallery 2.0 ~~~wordpress~~ Version Details Vulnerabilities
33 Application Imagely Nextgen Gallery 2.0.7 ~~~wordpress~~ Version Details Vulnerabilities
34 Application Imagely Nextgen Gallery 2.0.11 ~~~wordpress~~ Version Details Vulnerabilities
35 Application Imagely Nextgen Gallery 2.0.14 ~~~wordpress~~ Version Details Vulnerabilities
36 Application Imagely Nextgen Gallery 2.0.17 ~~~wordpress~~ Version Details Vulnerabilities
37 Application Imagely Nextgen Gallery 2.0.21 ~~~wordpress~~ Version Details Vulnerabilities
38 Application Imagely Nextgen Gallery 2.0.23 ~~~wordpress~~ Version Details Vulnerabilities
39 Application Imagely Nextgen Gallery 2.0.25 ~~~wordpress~~ Version Details Vulnerabilities
40 Application Imagely Nextgen Gallery 2.0.27 ~~~wordpress~~ Version Details Vulnerabilities
41 Application Imagely Nextgen Gallery 2.0.30 ~~~wordpress~~ Version Details Vulnerabilities
42 Application Imagely Nextgen Gallery 2.0.31 ~~~wordpress~~ Version Details Vulnerabilities
43 Application Imagely Nextgen Gallery 2.0.33 ~~~wordpress~~ Version Details Vulnerabilities
44 Application Imagely Nextgen Gallery 2.0.40 ~~~wordpress~~ Version Details Vulnerabilities
45 Application Imagely Nextgen Gallery 2.0.57 ~~~wordpress~~ Version Details Vulnerabilities
46 Application Imagely Nextgen Gallery 2.0.58 ~~~wordpress~~ Version Details Vulnerabilities
47 Application Imagely Nextgen Gallery 2.0.59 ~~~wordpress~~ Version Details Vulnerabilities
48 Application Imagely Nextgen Gallery 2.0.61 ~~~wordpress~~ Version Details Vulnerabilities
49 Application Imagely Nextgen Gallery 2.0.63 ~~~wordpress~~ Version Details Vulnerabilities
50 Application Imagely Nextgen Gallery 2.0.65 ~~~wordpress~~ Version Details Vulnerabilities
51 Application Imagely Nextgen Gallery 2.0.66 ~~~wordpress~~ Version Details Vulnerabilities
52 Application Imagely Nextgen Gallery 2.0.66.16 ~~~wordpress~~ Version Details Vulnerabilities
53 Application Imagely Nextgen Gallery 2.0.66.17 ~~~wordpress~~ Version Details Vulnerabilities
54 Application Imagely Nextgen Gallery 2.0.66.26 ~~~wordpress~~ Version Details Vulnerabilities
55 Application Imagely Nextgen Gallery 2.0.66.27 ~~~wordpress~~ Version Details Vulnerabilities
56 Application Imagely Nextgen Gallery 2.0.66.29 ~~~wordpress~~ Version Details Vulnerabilities
57 Application Imagely Nextgen Gallery 2.0.66.31 ~~~wordpress~~ Version Details Vulnerabilities
58 Application Imagely Nextgen Gallery 2.0.66.33 ~~~wordpress~~ Version Details Vulnerabilities
59 Application Imagely Nextgen Gallery 2.0.71 ~~~wordpress~~ Version Details Vulnerabilities
60 Application Imagely Nextgen Gallery 2.0.74 ~~~wordpress~~ Version Details Vulnerabilities
61 Application Imagely Nextgen Gallery 2.0.76 ~~~wordpress~~ Version Details Vulnerabilities
62 Application Imagely Nextgen Gallery 2.0.77 ~~~wordpress~~ Version Details Vulnerabilities
63 Application Imagely Nextgen Gallery 2.0.78 ~~~wordpress~~ Version Details Vulnerabilities
64 Application Imagely Nextgen Gallery 2.0.78.1 ~~~wordpress~~ Version Details Vulnerabilities
65 Application Imagely Nextgen Gallery 2.0.79 ~~~wordpress~~ Version Details Vulnerabilities
66 Application Imagely Nextgen Gallery 2.1.0 ~~~wordpress~~ Version Details Vulnerabilities
67 Application Imagely Nextgen Gallery 2.1.2 ~~~wordpress~~ Version Details Vulnerabilities
68 Application Imagely Nextgen Gallery 2.1.7 ~~~wordpress~~ Version Details Vulnerabilities
69 Application Imagely Nextgen Gallery 2.1.9 ~~~wordpress~~ Version Details Vulnerabilities
70 Application Imagely Nextgen Gallery 2.1.10 ~~~wordpress~~ Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Imagely Nextgen Gallery 70

- References For CVE-2015-9228

https://wordpress.org/plugins/nextgen-gallery/#developers
https://github.com/cybersecurityworks/Disclosed/issues/6
https://packetstormsecurity.com/files/135061/WordPress-NextGEN-Gallery-2.1.10-Shell-Upload.html
http://www.openwall.com/lists/oss-security/2015/10/27/6

- Metasploit Modules Related To CVE-2015-9228

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.