CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-9220

In Android before 2018-04-05 or earlier security patch level on Qualcomm Snapdragon Mobile and Snapdragon Wear IPQ4019, IPQ8064, MDM9206, MDM9607, MDM9640, MDM9650, QCA4531, QCA6174A, QCA6574AU, QCA6584, QCA6584AU, QCA9377, QCA9378, QCA9379, QCA9558, QCA9880, QCA9886, QCA9980, SD 210/SD 212/SD 205, SD 425, SD 625, SD 810, SD 820, and SDX20, integer overflow occurs when the size of the firmware section is incorrectly encoded in the firmware image.
Publish Date : 2018-04-18 Last Update Date : 2018-05-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Overflow
CWE ID 190

- Products Affected By CVE-2015-9220

# Product Type Vendor Product Version Update Edition Language
1 OS Qualcomm Ipq4019 Firmware - Version Details Vulnerabilities
2 OS Qualcomm Ipq8064 Firmware - Version Details Vulnerabilities
3 OS Qualcomm Mdm9206 Firmware - Version Details Vulnerabilities
4 OS Qualcomm Mdm9607 Firmware - Version Details Vulnerabilities
5 OS Qualcomm Mdm9640 Firmware - Version Details Vulnerabilities
6 OS Qualcomm Mdm9650 Firmware - Version Details Vulnerabilities
7 OS Qualcomm Qca4531 Firmware - Version Details Vulnerabilities
8 OS Qualcomm Qca6174a Firmware - Version Details Vulnerabilities
9 OS Qualcomm Qca6574au Firmware - Version Details Vulnerabilities
10 OS Qualcomm Qca6584 Firmware - Version Details Vulnerabilities
11 OS Qualcomm Qca6584au Firmware - Version Details Vulnerabilities
12 OS Qualcomm Qca9377 Firmware - Version Details Vulnerabilities
13 OS Qualcomm Qca9378 Firmware - Version Details Vulnerabilities
14 OS Qualcomm Qca9379 Firmware - Version Details Vulnerabilities
15 OS Qualcomm Qca9558 Firmware - Version Details Vulnerabilities
16 OS Qualcomm Qca9880 Firmware - Version Details Vulnerabilities
17 OS Qualcomm Qca9886 Firmware - Version Details Vulnerabilities
18 OS Qualcomm Qca9980 Firmware - Version Details Vulnerabilities
19 OS Qualcomm Sd 205 Firmware - Version Details Vulnerabilities
20 OS Qualcomm Sd 210 Firmware - Version Details Vulnerabilities
21 OS Qualcomm Sd 212 Firmware - Version Details Vulnerabilities
22 OS Qualcomm Sd 425 Firmware - Version Details Vulnerabilities
23 OS Qualcomm Sd 625 Firmware - Version Details Vulnerabilities
24 OS Qualcomm Sd 810 Firmware - Version Details Vulnerabilities
25 OS Qualcomm Sd 820 Firmware - Version Details Vulnerabilities
26 OS Qualcomm Sdx20 Firmware - Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Qualcomm Ipq4019 Firmware 1
Qualcomm Ipq8064 Firmware 1
Qualcomm Mdm9206 Firmware 1
Qualcomm Mdm9607 Firmware 1
Qualcomm Mdm9640 Firmware 1
Qualcomm Mdm9650 Firmware 1
Qualcomm Qca4531 Firmware 1
Qualcomm Qca6174a Firmware 1
Qualcomm Qca6574au Firmware 1
Qualcomm Qca6584 Firmware 1
Qualcomm Qca6584au Firmware 1
Qualcomm Qca9377 Firmware 1
Qualcomm Qca9378 Firmware 1
Qualcomm Qca9379 Firmware 1
Qualcomm Qca9558 Firmware 1
Qualcomm Qca9880 Firmware 1
Qualcomm Qca9886 Firmware 1
Qualcomm Qca9980 Firmware 1
Qualcomm Sd 205 Firmware 1
Qualcomm Sd 210 Firmware 1
Qualcomm Sd 212 Firmware 1
Qualcomm Sd 425 Firmware 1
Qualcomm Sd 625 Firmware 1
Qualcomm Sd 810 Firmware 1
Qualcomm Sd 820 Firmware 1
Qualcomm Sdx20 Firmware 1

- References For CVE-2015-9220

http://www.securityfocus.com/bid/103671
BID 103671 Google Android Multiple Qualcomm Components Multiple Unspecified Security Vulnerabilities Release Date:2018-04-05
https://source.android.com/security/bulletin/2018-04-01 CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2015-9220

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.