CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-7971

Xen 3.2.x through 4.6.x does not limit the number of printk console messages when logging certain pmu and profiling hypercalls, which allows local guests to cause a denial of service via a sequence of crafted (1) HYPERCALL_xenoprof_op hypercalls, which are not properly handled in the do_xenoprof_op function in common/xenoprof.c, or (2) HYPERVISOR_xenpmu_op hypercalls, which are not properly handled in the do_xenpmu_op function in arch/x86/cpu/vpmu.c.
Publish Date : 2015-10-30 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 19

- Products Affected By CVE-2015-7971

# Product Type Vendor Product Version Update Edition Language
1 OS XEN XEN 3.2.0 Version Details Vulnerabilities
2 OS XEN XEN 3.2.1 Version Details Vulnerabilities
3 OS XEN XEN 3.2.2 Version Details Vulnerabilities
4 OS XEN XEN 3.2.3 Version Details Vulnerabilities
5 OS XEN XEN 3.3.0 Version Details Vulnerabilities
6 OS XEN XEN 3.3.1 Version Details Vulnerabilities
7 OS XEN XEN 3.3.2 Version Details Vulnerabilities
8 OS XEN XEN 3.4.0 Version Details Vulnerabilities
9 OS XEN XEN 3.4.1 Version Details Vulnerabilities
10 OS XEN XEN 3.4.2 Version Details Vulnerabilities
11 OS XEN XEN 3.4.3 Version Details Vulnerabilities
12 OS XEN XEN 3.4.4 Version Details Vulnerabilities
13 OS XEN XEN 4.0.0 Version Details Vulnerabilities
14 OS XEN XEN 4.0.1 Version Details Vulnerabilities
15 OS XEN XEN 4.0.2 Version Details Vulnerabilities
16 OS XEN XEN 4.0.3 Version Details Vulnerabilities
17 OS XEN XEN 4.0.4 Version Details Vulnerabilities
18 OS XEN XEN 4.1.0 Version Details Vulnerabilities
19 OS XEN XEN 4.1.1 Version Details Vulnerabilities
20 OS XEN XEN 4.1.2 Version Details Vulnerabilities
21 OS XEN XEN 4.1.3 Version Details Vulnerabilities
22 OS XEN XEN 4.1.4 Version Details Vulnerabilities
23 OS XEN XEN 4.1.5 Version Details Vulnerabilities
24 OS XEN XEN 4.1.6.1 Version Details Vulnerabilities
25 OS XEN XEN 4.2.0 Version Details Vulnerabilities
26 OS XEN XEN 4.2.1 Version Details Vulnerabilities
27 OS XEN XEN 4.2.2 Version Details Vulnerabilities
28 OS XEN XEN 4.2.3 Version Details Vulnerabilities
29 OS XEN XEN 4.3.0 Version Details Vulnerabilities
30 OS XEN XEN 4.3.1 Version Details Vulnerabilities
31 OS XEN XEN 4.3.2 Version Details Vulnerabilities
32 OS XEN XEN 4.3.4 Version Details Vulnerabilities
33 OS XEN XEN 4.4.0 Version Details Vulnerabilities
34 OS XEN XEN 4.4.1 - Version Details Vulnerabilities
35 OS XEN XEN 4.5.0 Version Details Vulnerabilities
36 OS XEN XEN 4.5.1 Version Details Vulnerabilities
37 OS XEN XEN 4.6.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
XEN XEN 37

- References For CVE-2015-7971

https://security.gentoo.org/glsa/201604-03
GENTOO GLSA-201604-03
http://www.securityfocus.com/bid/77363
BID 77363 Xen CVE-2015-7971 Denial of Service Vulnerability Release Date:2015-11-19
http://xenbits.xen.org/xsa/advisory-152.html CONFIRM
http://www.securitytracker.com/id/1034035
SECTRACK 1034035
http://www.debian.org/security/2015/dsa-3414
DEBIAN DSA-3414
http://support.citrix.com/article/CTX202404 CONFIRM
http://lists.opensuse.org/opensuse-updates/2015-11/msg00063.html
SUSE openSUSE-SU-2015:1965
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171249.html
FEDORA FEDORA-2015-242be2c240
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171082.html
FEDORA FEDORA-2015-a931b02be2
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171185.html
FEDORA FEDORA-2015-6f6b79efe2

- Metasploit Modules Related To CVE-2015-7971

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.