The vB_Api_Hook::decodeArguments method in vBulletin 5 Connect 5.1.2 through 5.1.9 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via a crafted serialized object in the arguments parameter to ajax/api/hook/decodeArguments.
Published 2015-11-24 20:59:08
Updated 2015-11-25 20:23:18
Source MITRE
View at NVD,   CVE.org
Vulnerability category: Input validation

Exploit prediction scoring system (EPSS) score for CVE-2015-7808

76.05%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 98 %
Percentile, the proportion of vulnerabilities that are scored at or less

Metasploit modules for CVE-2015-7808

  • vBulletin 5.1.2 Unserialize Code Execution
    Disclosure Date: 2015-11-04
    First seen: 2020-04-26
    exploit/multi/http/vbulletin_unserialize
    This module exploits a PHP object injection vulnerability in vBulletin 5.1.2 to 5.1.9 Authors: - Netanel Rubin - cutz - Julien (jvoisin) Voisin

CVSS scores for CVE-2015-7808

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
7.5
HIGH AV:N/AC:L/Au:N/C:P/I:P/A:P
10.0
6.4
NIST

CWE ids for CVE-2015-7808

  • The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2015-7808

Products affected by CVE-2015-7808

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!