CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-2337

TPInt.dll in VMware Workstation 10.x before 10.0.6 and 11.x before 11.1.1, VMware Player 6.x before 6.0.6 and 7.x before 7.1.1, and VMware Horizon Client 3.2.x before 3.2.1, 3.3.x, and 5.x local-mode before 5.4.2 on Windows does not properly allocate memory, which allows guest OS users to execute arbitrary code on the host OS via unspecified vectors.
Publish Date : 2015-06-13 Last Update Date : 2016-12-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.8
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 399

- Products Affected By CVE-2015-2337

# Product Type Vendor Product Version Update Edition Language
1 Application Vmware Fusion 6.0 Version Details Vulnerabilities
2 Application Vmware Fusion 6.0.1 Version Details Vulnerabilities
3 Application Vmware Fusion 6.0.2 Version Details Vulnerabilities
4 Application Vmware Fusion 6.0.3 Version Details Vulnerabilities
5 Application Vmware Fusion 6.0.4 Version Details Vulnerabilities
6 Application Vmware Fusion 6.0.5 Version Details Vulnerabilities
7 Application Vmware Fusion 7.0 Version Details Vulnerabilities
8 Application Vmware Fusion 7.0.1 Version Details Vulnerabilities
9 Application Vmware Horizon Client 3.2.0 Version Details Vulnerabilities
10 Application Vmware Horizon Client 3.3 Version Details Vulnerabilities
11 Application Vmware Horizon View Client 5.4 Version Details Vulnerabilities
12 Application Vmware Horizon View Client 5.4.1 Version Details Vulnerabilities
13 Application Vmware Player 6.0 Version Details Vulnerabilities
14 Application Vmware Player 6.0.1 Version Details Vulnerabilities
15 Application Vmware Player 6.0.2 Version Details Vulnerabilities
16 Application Vmware Player 6.0.3 Version Details Vulnerabilities
17 Application Vmware Player 6.0.4 Version Details Vulnerabilities
18 Application Vmware Player 6.0.5 Version Details Vulnerabilities
19 Application Vmware Player 7.0 Version Details Vulnerabilities
20 Application Vmware Player 7.1 Version Details Vulnerabilities
21 Application Vmware Workstation 10.0 Version Details Vulnerabilities
22 Application Vmware Workstation 10.0.1 Version Details Vulnerabilities
23 Application Vmware Workstation 10.0.2 Version Details Vulnerabilities
24 Application Vmware Workstation 10.0.3 Version Details Vulnerabilities
25 Application Vmware Workstation 10.0.4 Version Details Vulnerabilities
26 Application Vmware Workstation 10.0.5 Version Details Vulnerabilities
27 Application Vmware Workstation 11.0 Version Details Vulnerabilities
28 Application Vmware Workstation 11.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Vmware Fusion 8
Vmware Horizon Client 2
Vmware Horizon View Client 2
Vmware Player 8
Vmware Workstation 8

- References For CVE-2015-2337

http://www.securitytracker.com/id/1032530
SECTRACK 1032530
http://www.vmware.com/security/advisories/VMSA-2015-0004.html CONFIRM
http://www.securitytracker.com/id/1032529
SECTRACK 1032529
http://www.securityfocus.com/bid/75095
BID 75095

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2015-2337

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.