CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-0205

The ssl3_get_cert_verify function in s3_srvr.c in OpenSSL 1.0.0 before 1.0.0p and 1.0.1 before 1.0.1k accepts client authentication with a Diffie-Hellman (DH) certificate without requiring a CertificateVerify message, which allows remote attackers to obtain access without knowledge of a private key via crafted TLS Handshake Protocol traffic to a server that recognizes a Certification Authority with DH support.
Publish Date : 2015-01-08 Last Update Date : 2017-09-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 310

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2015:0066: openssl security update (Moderate) oval:com.redhat.rhsa:def:20150066 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2015-0205

# Product Type Vendor Product Version Update Edition Language
1 Application Openssl Openssl 1.0.0a Version Details Vulnerabilities
2 Application Openssl Openssl 1.0.0l Version Details Vulnerabilities
3 Application Openssl Openssl 1.0.0g Version Details Vulnerabilities
4 Application Openssl Openssl 1.0.0b Version Details Vulnerabilities
5 Application Openssl Openssl 1.0.0m Version Details Vulnerabilities
6 Application Openssl Openssl 1.0.0h Version Details Vulnerabilities
7 Application Openssl Openssl 1.0.0c Version Details Vulnerabilities
8 Application Openssl Openssl 1.0.0n Version Details Vulnerabilities
9 Application Openssl Openssl 1.0.0i Version Details Vulnerabilities
10 Application Openssl Openssl 1.0.0d Version Details Vulnerabilities
11 Application Openssl Openssl 1.0.0o Version Details Vulnerabilities
12 Application Openssl Openssl 1.0.0j Version Details Vulnerabilities
13 Application Openssl Openssl 1.0.0e Version Details Vulnerabilities
14 Application Openssl Openssl 1.0.0k Version Details Vulnerabilities
15 Application Openssl Openssl 1.0.0f Version Details Vulnerabilities
16 Application Openssl Openssl 1.0.1i Version Details Vulnerabilities
17 Application Openssl Openssl 1.0.1c Version Details Vulnerabilities
18 Application Openssl Openssl 1.0.1h Version Details Vulnerabilities
19 Application Openssl Openssl 1.0.1b Version Details Vulnerabilities
20 Application Openssl Openssl 1.0.1g Version Details Vulnerabilities
21 Application Openssl Openssl 1.0.1a Version Details Vulnerabilities
22 Application Openssl Openssl 1.0.1f Version Details Vulnerabilities
23 Application Openssl Openssl 1.0.1e Version Details Vulnerabilities
24 Application Openssl Openssl 1.0.1j Version Details Vulnerabilities
25 Application Openssl Openssl 1.0.1d Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Openssl Openssl 25

- References For CVE-2015-0205

http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html CONFIRM
https://kc.mcafee.com/corporate/index?page=content&id=SB10102 CONFIRM
https://www.openssl.org/news/secadv_20150108.txt CONFIRM
http://marc.info/?l=bugtraq&m=142721102728110&w=2
HP HPSBHF03289
http://marc.info/?l=bugtraq&m=143748090628601&w=2
HP HPSBMU03380
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05150888 CONFIRM
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05158380 CONFIRM
http://www.securityfocus.com/bid/71941
BID 71941 OpenSSL CVE-2015-0205 Man in the Middle Security Bypass Vulnerability Release Date:2016-09-09
http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html CONFIRM
http://marc.info/?l=bugtraq&m=144050205101530&w=2
HP HPSBMU03396
https://kc.mcafee.com/corporate/index?page=content&id=SB10108 CONFIRM
https://exchange.xforce.ibmcloud.com/vulnerabilities/99708
XF openssl-cve20150205-sec-bypass(99708)
https://github.com/openssl/openssl/commit/1421e0c584ae9120ca1b88098f13d6d2e90b83a3 CONFIRM
https://bto.bluecoat.com/security-advisory/sa88 CONFIRM
http://www.securityfocus.com/bid/91787
BID 91787 Oracle July 2016 Critical Patch Update Multiple Vulnerabilities Release Date:2016-10-10
http://www.oracle.com/technetwork/topics/security/cpuoct2015-2367953.html CONFIRM
http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2015:019
MANDRIVA MDVSA-2015:019
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00026.html
SUSE SUSE-SU-2015:0946
http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00037.html
SUSE openSUSE-SU-2015:1277
http://www.mandriva.com/security/advisories?name=MDVSA-2015:062
MANDRIVA MDVSA-2015:062
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20150310-ssl
CISCO 20150310 Multiple Vulnerabilities in OpenSSL (January 2015) Affecting Cisco Products
http://www.debian.org/security/2015/dsa-3125
DEBIAN DSA-3125
http://rhn.redhat.com/errata/RHSA-2015-0066.html
REDHAT RHSA-2015:0066
http://www.securitytracker.com/id/1033378
SECTRACK 1033378
http://marc.info/?l=bugtraq&m=144050297101809&w=2
HP HPSBMU03397
http://marc.info/?l=bugtraq&m=144050254401665&w=2
HP HPSBMU03413
http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html CONFIRM
http://marc.info/?l=bugtraq&m=144050155601375&w=2
HP HPSBMU03409
http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148363.html
FEDORA FEDORA-2015-0601
http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00027.html
SUSE SUSE-SU-2015:0578
http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00021.html
SUSE openSUSE-SU-2015:0130
http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10679 CONFIRM
http://lists.fedoraproject.org/pipermail/package-announce/2015-January/147938.html
FEDORA FEDORA-2015-0512

- Metasploit Modules Related To CVE-2015-0205

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.