sapi/cgi/cgi_main.c in the CGI component in PHP through 5.4.36, 5.5.x through 5.5.20, and 5.6.x through 5.6.4, when mmap is used to read a .php file, does not properly consider the mapping's length during processing of an invalid file that begins with a # character and lacks a newline character, which causes an out-of-bounds read and might (1) allow remote attackers to obtain sensitive information from php-cgi process memory by leveraging the ability to upload a .php file or (2) trigger unexpected code execution if a valid PHP script is present in memory locations adjacent to the mapping.
Published 2015-01-03 02:59:00
Updated 2016-12-31 02:59:15
View at NVD,   CVE.org
Vulnerability category: Overflow

Threat overview for CVE-2014-9427

Top countries where our scanners detected CVE-2014-9427
Top open port discovered on systems with this issue 80
IPs affected by CVE-2014-9427 407,373
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2014-9427!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2014-9427

Probability of exploitation activity in the next 30 days: 10.96%

Percentile, the proportion of vulnerabilities that are scored at or less: ~ 95 % EPSS Score History EPSS FAQ

CVSS scores for CVE-2014-9427

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source
7.5
HIGH AV:N/AC:L/Au:N/C:P/I:P/A:P
10.0
6.4
NIST

CWE ids for CVE-2014-9427

References for CVE-2014-9427

Products affected by CVE-2014-9427

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!