CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-8712

The build_expert_data function in epan/dissectors/packet-ncp2222.inc in the NCP dissector in Wireshark 1.10.x before 1.10.11 and 1.12.x before 1.12.2 does not properly initialize a data structure, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
Publish Date : 2014-11-22 Last Update Date : 2018-01-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 399

- Related OVAL Definitions

Title Definition Id Class Family
DSA-3076-1 -- wireshark security update oval:org.mitre.oval:def:28302 unix
RHSA-2015:1460: wireshark security, bug fix, and enhancement update (Moderate) oval:com.redhat.rhsa:def:20151460 unix
RHSA-2015:2393: wireshark security, bug fix, and enhancement update (Moderate) oval:com.redhat.rhsa:def:20152393 unix
SUSE-SU-2014:1520-1 -- Security update for wireshark (moderate) oval:org.mitre.oval:def:28226 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2014-8712

# Product Type Vendor Product Version Update Edition Language
1 Application Wireshark Wireshark 1.10.0 Version Details Vulnerabilities
2 Application Wireshark Wireshark 1.10.1 Version Details Vulnerabilities
3 Application Wireshark Wireshark 1.10.2 Version Details Vulnerabilities
4 Application Wireshark Wireshark 1.10.3 Version Details Vulnerabilities
5 Application Wireshark Wireshark 1.10.4 Version Details Vulnerabilities
6 Application Wireshark Wireshark 1.10.5 Version Details Vulnerabilities
7 Application Wireshark Wireshark 1.10.6 Version Details Vulnerabilities
8 Application Wireshark Wireshark 1.10.7 Version Details Vulnerabilities
9 Application Wireshark Wireshark 1.10.8 Version Details Vulnerabilities
10 Application Wireshark Wireshark 1.10.9 Version Details Vulnerabilities
11 Application Wireshark Wireshark 1.10.10 Version Details Vulnerabilities
12 Application Wireshark Wireshark 1.12.0 Version Details Vulnerabilities
13 Application Wireshark Wireshark 1.12.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Wireshark Wireshark 13

- References For CVE-2014-8712

http://rhn.redhat.com/errata/RHSA-2015-1460.html
REDHAT RHSA-2015:1460
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=41f6923b3049dfb57bef544a4c580f256f807e85 CONFIRM
http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html CONFIRM
http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html CONFIRM
http://www.securityfocus.com/bid/71071
BID 71071 Wireshark NCP Dissector CVE-2014-8712 Denial of Service Vulnerability Release Date:2016-01-15
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=10628 CONFIRM
http://www.debian.org/security/2014/dsa-3076
DEBIAN DSA-3076
http://www.wireshark.org/security/wnpa-sec-2014-22.html CONFIRM
http://lists.fedoraproject.org/pipermail/package-announce/2014-December/145658.html
FEDORA FEDORA-2014-15320
http://lists.opensuse.org/opensuse-updates/2014-11/msg00104.html
SUSE openSUSE-SU-2014:1503

- Metasploit Modules Related To CVE-2014-8712

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.