CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-3776

Buffer overflow in the "read-u8vector!" procedure in the srfi-4 unit in CHICKEN stable 4.8.0.7 and development snapshots before 4.9.1 allows remote attackers to cause a denial of service (memory corruption and application crash) and possibly execute arbitrary code via a "#f" value in the NUM argument.
Publish Date : 2014-05-20 Last Update Date : 2017-06-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeOverflowMemory corruption
CWE ID 119

- Products Affected By CVE-2014-3776

# Product Type Vendor Product Version Update Edition Language
1 Application Call-cc Chicken 4.8.0.7 Version Details Vulnerabilities
2 Application Call-cc Chicken 4.9.0 ~~~~~development Snapshot Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Call-cc Chicken 2

- References For CVE-2014-3776

https://security.gentoo.org/glsa/201612-54
GENTOO GLSA-201612-54
http://seclists.org/oss-sec/2014/q2/334
MLIST [oss-security] 20140519 Re: CVE request for buffer overrun in CHICKEN Scheme
http://www.securityfocus.com/bid/67468
BID 67468 CHICKEN 'read-u8vector!' Procedure Remote Buffer Overflow Vulnerability Release Date:2017-01-03
http://lists.gnu.org/archive/html/chicken-hackers/2014-05/msg00032.html
MLIST [Chicken-hackers] 20140517 [PATCH] Bound read-u8vector! to dest vector's size when no length is given
http://code.call-cc.org/cgi-bin/gitweb.cgi?p=chicken-core.git;a=commit;h=1d06ce7e21c7e903ca5dca11fda6fcf2cc52de5e CONFIRM
http://seclists.org/oss-sec/2014/q2/328
MLIST [oss-security] 20140518 CVE request for buffer overrun in CHICKEN Scheme
https://bugs.call-cc.org/ticket/1124 CONFIRM
http://lists.gnu.org/archive/html/chicken-announce/2014-05/msg00001.html
MLIST [chicken-announce] 20140518 [SECURITY] Buffer-overrun in some uses of read-u8vect

- Metasploit Modules Related To CVE-2014-3776

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.