The ISO-8859-1 encoder in Resin Pro before 4.0.40 does not properly perform Unicode transformations, which allows remote attackers to bypass intended text restrictions via crafted characters, as demonstrated by bypassing an XSS protection mechanism.
Published 2014-07-26 15:55:04
Updated 2014-07-28 19:00:17
Source CERT/CC
View at NVD,   CVE.org
Vulnerability category: Cross site scripting (XSS)Input validation

Threat overview for CVE-2014-2966

Top countries where our scanners detected CVE-2014-2966
Top open port discovered on systems with this issue 80
IPs affected by CVE-2014-2966 759
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2014-2966!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2014-2966

0.41%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 71 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2014-2966

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
5.0
MEDIUM AV:N/AC:L/Au:N/C:N/I:P/A:N
10.0
2.9
NIST

CWE ids for CVE-2014-2966

  • The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
    Assigned by: nvd@nist.gov (Primary)
  • Assigned by: nvd@nist.gov (Primary)

References for CVE-2014-2966

Products affected by CVE-2014-2966

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!