admin/libraries/view.functions.php in FreePBX 2.9 before 2.9.0.14, 2.10 before 2.10.1.15, 2.11 before 2.11.0.23, and 12 before 12.0.1alpha22 does not restrict the set of functions accessible to the API handler, which allows remote attackers to execute arbitrary PHP code via the function and args parameters to admin/config.php.
Published 2014-02-18 11:55:17
Updated 2019-12-10 16:01:28
Source MITRE
View at NVD,   CVE.org

Threat overview for CVE-2014-1903

Top countries where our scanners detected CVE-2014-1903
Top open port discovered on systems with this issue 5060
IPs affected by CVE-2014-1903 1,178
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2014-1903!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2014-1903

96.52%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 99 %
Percentile, the proportion of vulnerabilities that are scored at or less

Metasploit modules for CVE-2014-1903

  • FreePBX config.php Remote Code Execution
    Disclosure Date: 2014-03-21
    First seen: 2020-04-26
    exploit/unix/webapp/freepbx_config_exec
    This module exploits a vulnerability found in FreePBX version 2.9, 2.10, and 2.11. It's possible to inject arbitrary PHP functions and commands in the "/admin/config.php" parameters "function" and "args". Authors: - i-Hmx - 0x00string - xistence <xistence@0x90.n

CVSS scores for CVE-2014-1903

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
7.5
HIGH AV:N/AC:L/Au:N/C:P/I:P/A:P
10.0
6.4
NIST

CWE ids for CVE-2014-1903

  • Assigned by: nvd@nist.gov (Primary)

Products affected by CVE-2014-1903

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!