CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-1538

Use-after-free vulnerability in the nsTextEditRules::CreateMozBR function in Mozilla Firefox before 30.0, Firefox ESR 24.x before 24.6, and Thunderbird before 24.6 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via unspecified vectors.
Publish Date : 2014-06-11 Last Update Date : 2017-12-27
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeMemory corruption
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
DEPRECATED: ELSA-2014-0742 -- thunderbird security update (important) oval:org.mitre.oval:def:27237 unix
DEPRECATED: ELSA-2014-0741 -- firefox security update (critical) oval:org.mitre.oval:def:27326 unix
DSA-2955-1 iceweasel - security update oval:org.mitre.oval:def:25038 unix
DSA-2960-1 icedove - security update oval:org.mitre.oval:def:24891 unix
ELSA-2014:0741: firefox security update (Critical) oval:org.mitre.oval:def:25005 unix
ELSA-2014:0742: thunderbird security update (Important) oval:org.mitre.oval:def:25198 unix
RHSA-2014:0741: firefox security update (Critical) oval:com.redhat.rhsa:def:20140741 unix
RHSA-2014:0741: firefox security update (Critical) oval:org.mitre.oval:def:24262 unix
RHSA-2014:0742: thunderbird security update (Important) oval:com.redhat.rhsa:def:20140742 unix
RHSA-2014:0742: thunderbird security update (Important) oval:org.mitre.oval:def:24670 unix
SUSE-SU-2014:0824-2 -- Security update for MozillaFirefox oval:org.mitre.oval:def:26137 unix
SUSE-SU-2014:0824-1 -- Security update for MozillaFirefox oval:org.mitre.oval:def:26138 unix
SUSE-SU-2014:0824-3 -- Security update for MozillaFirefox oval:org.mitre.oval:def:25411 unix
SUSE-SU-2014:0905-1 -- Security update for Mozilla Firefox oval:org.mitre.oval:def:26284 unix
Use-after-free vulnerability in the nsTextEditRules::CreateMozBR function in Mozilla Firefox before 30.0, Firefox ESR 24... oval:org.mitre.oval:def:24267 windows
USN-2243-1 -- firefox vulnerabilities oval:org.mitre.oval:def:24900 unix
USN-2250-1 -- thunderbird vulnerabilities oval:org.mitre.oval:def:25064 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2014-1538

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 29.0.1 Version Details Vulnerabilities
2 Application Mozilla Firefox Esr 24.0 Version Details Vulnerabilities
3 Application Mozilla Firefox Esr 24.0.1 Version Details Vulnerabilities
4 Application Mozilla Firefox Esr 24.0.2 Version Details Vulnerabilities
5 Application Mozilla Firefox Esr 24.1.0 Version Details Vulnerabilities
6 Application Mozilla Firefox Esr 24.1.1 Version Details Vulnerabilities
7 Application Mozilla Firefox Esr 24.2 Version Details Vulnerabilities
8 Application Mozilla Firefox Esr 24.3 Version Details Vulnerabilities
9 Application Mozilla Firefox Esr 24.4 Version Details Vulnerabilities
10 Application Mozilla Firefox Esr 24.5 Version Details Vulnerabilities
11 Application Mozilla Thunderbird 24.0 Version Details Vulnerabilities
12 Application Mozilla Thunderbird 24.0.1 Version Details Vulnerabilities
13 Application Mozilla Thunderbird 24.1 Version Details Vulnerabilities
14 Application Mozilla Thunderbird 24.1.1 Version Details Vulnerabilities
15 Application Mozilla Thunderbird 24.2 Version Details Vulnerabilities
16 Application Mozilla Thunderbird 24.3 Version Details Vulnerabilities
17 Application Mozilla Thunderbird 24.4 Version Details Vulnerabilities
18 Application Mozilla Thunderbird 24.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 1
Mozilla Firefox Esr 9
Mozilla Thunderbird 8

- References For CVE-2014-1538

https://security.gentoo.org/glsa/201504-01
GENTOO GLSA-201504-01
https://bugzilla.redhat.com/show_bug.cgi?id=1107421 CONFIRM
https://bugzilla.mozilla.org/show_bug.cgi?id=1005584 CONFIRM
http://www.ubuntu.com/usn/USN-2250-1
UBUNTU USN-2250-1
http://www.ubuntu.com/usn/USN-2243-1
UBUNTU USN-2243-1
http://www.securitytracker.com/id/1030386
SECTRACK 1030386
http://secunia.com/advisories/59486
SECUNIA 59486
http://www.debian.org/security/2014/dsa-2955
DEBIAN DSA-2955
http://www.securitytracker.com/id/1030388
SECTRACK 1030388
http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html CONFIRM
http://www.debian.org/security/2014/dsa-2960
DEBIAN DSA-2960
http://www.mozilla.org/security/announce/2014/mfsa2014-49.html CONFIRM
http://rhn.redhat.com/errata/RHSA-2014-0742.html
REDHAT RHSA-2014:0742
http://secunia.com/advisories/59328
SECUNIA 59328
http://www.securityfocus.com/bid/67976
BID 67976 Mozilla Firefox/Thunderbird CVE-2014-1538 Memory Corruption Vulnerability Release Date:2014-09-15
http://secunia.com/advisories/59425
SECUNIA 59425
http://rhn.redhat.com/errata/RHSA-2014-0741.html
REDHAT RHSA-2014:0741
http://lists.opensuse.org/opensuse-updates/2014-07/msg00004.html
SUSE openSUSE-SU-2014:0858
http://lists.opensuse.org/opensuse-updates/2014-07/msg00001.html
SUSE openSUSE-SU-2014:0855
http://linux.oracle.com/errata/ELSA-2014-0741.html CONFIRM
http://linux.oracle.com/errata/ELSA-2014-0742.html CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2014-06/msg00019.html
SUSE openSUSE-SU-2014:0797
http://lists.opensuse.org/opensuse-security-announce/2014-06/msg00023.html
SUSE SUSE-SU-2014:0824
http://lists.opensuse.org/opensuse-updates/2014-06/msg00040.html
SUSE openSUSE-SU-2014:0819

- Metasploit Modules Related To CVE-2014-1538

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.