CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2014-0240

The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.
Publish Date : 2014-05-27 Last Update Date : 2017-12-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Gain privileges
CWE ID 264

- Related OVAL Definitions

Title Definition Id Class Family
DSA-2937-1 mod-wsgi - security update oval:org.mitre.oval:def:24674 unix
ELSA-2014-0788 -- mod_wsgi security update (important) oval:org.mitre.oval:def:26894 unix
ELSA-2014-1091 -- mod_wsgi security update (important) oval:org.mitre.oval:def:27261 unix
RHSA-2014:0788: mod_wsgi security update (Important) oval:com.redhat.rhsa:def:20140788 unix
RHSA-2014:0788: mod_wsgi security update (Important) oval:org.mitre.oval:def:25138 unix
RHSA-2014:1091: mod_wsgi security update (Important) oval:org.mitre.oval:def:26476 unix
RHSA-2014:1091: mod_wsgi security update (Important) oval:com.redhat.rhsa:def:20141091 unix
USN-2222-1 -- mod-wsgi vulnerabilities oval:org.mitre.oval:def:24742 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2014-0240

# Product Type Vendor Product Version Update Edition Language
1 Application Modwsgi Mod Wsgi 1.0 Version Details Vulnerabilities
2 Application Modwsgi Mod Wsgi 1.1 Version Details Vulnerabilities
3 Application Modwsgi Mod Wsgi 1.2 Version Details Vulnerabilities
4 Application Modwsgi Mod Wsgi 1.3 Version Details Vulnerabilities
5 Application Modwsgi Mod Wsgi 1.4 Version Details Vulnerabilities
6 Application Modwsgi Mod Wsgi 1.5 Version Details Vulnerabilities
7 Application Modwsgi Mod Wsgi 1.6 Version Details Vulnerabilities
8 Application Modwsgi Mod Wsgi 2.0 Version Details Vulnerabilities
9 Application Modwsgi Mod Wsgi 2.1 Version Details Vulnerabilities
10 Application Modwsgi Mod Wsgi 2.2 Version Details Vulnerabilities
11 Application Modwsgi Mod Wsgi 2.3 Version Details Vulnerabilities
12 Application Modwsgi Mod Wsgi 2.4 Version Details Vulnerabilities
13 Application Modwsgi Mod Wsgi 2.5 Version Details Vulnerabilities
14 Application Modwsgi Mod Wsgi 2.6 Version Details Vulnerabilities
15 Application Modwsgi Mod Wsgi 2.7 Version Details Vulnerabilities
16 Application Modwsgi Mod Wsgi 2.8 Version Details Vulnerabilities
17 Application Modwsgi Mod Wsgi 3.0 Version Details Vulnerabilities
18 Application Modwsgi Mod Wsgi 3.1 Version Details Vulnerabilities
19 Application Modwsgi Mod Wsgi 3.2 Version Details Vulnerabilities
20 Application Modwsgi Mod Wsgi 3.3 Version Details Vulnerabilities
21 Application Modwsgi Mod Wsgi 3.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Modwsgi Mod Wsgi 21

- References For CVE-2014-0240

http://www.securityfocus.com/bid/67532
BID 67532 Apache 'mod_wsgi' Module Local Privilege Escalation Vulnerability Release Date:2014-08-27
http://blog.dscpl.com.au/2014/05/security-release-for-modwsgi-version-35.html CONFIRM
http://www.openwall.com/lists/oss-security/2014/05/21/1
MLIST [oss-security] 20140521 Security release for mod_wsgi (version 3.5)
http://rhn.redhat.com/errata/RHSA-2014-0789.html
REDHAT RHSA-2014:0789
http://secunia.com/advisories/59551
SECUNIA 59551
http://secunia.com/advisories/60094
SECUNIA 60094
http://modwsgi.readthedocs.org/en/latest/release-notes/version-3.5.html CONFIRM

- Metasploit Modules Related To CVE-2014-0240

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.