CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2013-6485

Buffer overflow in util.c in libpurple in Pidgin before 2.10.8 allows remote HTTP servers to cause a denial of service (application crash) or possibly have unspecified other impact via an invalid chunk-size field in chunked transfer-coding data.
Publish Date : 2014-02-06 Last Update Date : 2014-03-16
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 119

- Related OVAL Definitions

Title Definition Id Class Family
DEPRECATED: ELSA-2014-0139 -- pidgin security update (moderate) oval:org.mitre.oval:def:27284 unix
DEPRECATED: ELSA-2014:0139: pidgin security update (Moderate) oval:org.mitre.oval:def:22786 unix
DSA-2859-1 pidgin - several oval:org.mitre.oval:def:22474 unix
DSA-2859-2 pidgin - security update oval:org.mitre.oval:def:24323 unix
ELSA-2014:0139: pidgin security update (Moderate) oval:org.mitre.oval:def:24167 unix
RHSA-2014:0139: pidgin security update (Moderate) oval:org.mitre.oval:def:22203 unix
RHSA-2014:0139: pidgin security update (Moderate) oval:com.redhat.rhsa:def:20140139 unix
SUSE-SU-2014:0702-1 -- Security update for finch oval:org.mitre.oval:def:25166 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2013-6485

# Product Type Vendor Product Version Update Edition Language
1 Application Pidgin Pidgin 2.0.0 Version Details Vulnerabilities
2 Application Pidgin Pidgin 2.0.1 Version Details Vulnerabilities
3 Application Pidgin Pidgin 2.0.2 Version Details Vulnerabilities
4 Application Pidgin Pidgin 2.1.0 Version Details Vulnerabilities
5 Application Pidgin Pidgin 2.1.1 Version Details Vulnerabilities
6 Application Pidgin Pidgin 2.2.0 Version Details Vulnerabilities
7 Application Pidgin Pidgin 2.2.1 Version Details Vulnerabilities
8 Application Pidgin Pidgin 2.2.2 Version Details Vulnerabilities
9 Application Pidgin Pidgin 2.3.0 Version Details Vulnerabilities
10 Application Pidgin Pidgin 2.3.1 Version Details Vulnerabilities
11 Application Pidgin Pidgin 2.4.0 Version Details Vulnerabilities
12 Application Pidgin Pidgin 2.4.1 Version Details Vulnerabilities
13 Application Pidgin Pidgin 2.4.2 Version Details Vulnerabilities
14 Application Pidgin Pidgin 2.4.3 Version Details Vulnerabilities
15 Application Pidgin Pidgin 2.5.0 Version Details Vulnerabilities
16 Application Pidgin Pidgin 2.5.1 Version Details Vulnerabilities
17 Application Pidgin Pidgin 2.5.2 Version Details Vulnerabilities
18 Application Pidgin Pidgin 2.5.3 Version Details Vulnerabilities
19 Application Pidgin Pidgin 2.5.4 Version Details Vulnerabilities
20 Application Pidgin Pidgin 2.5.5 Version Details Vulnerabilities
21 Application Pidgin Pidgin 2.5.6 Version Details Vulnerabilities
22 Application Pidgin Pidgin 2.5.7 Version Details Vulnerabilities
23 Application Pidgin Pidgin 2.5.8 Version Details Vulnerabilities
24 Application Pidgin Pidgin 2.5.9 Version Details Vulnerabilities
25 Application Pidgin Pidgin 2.6.0 Version Details Vulnerabilities
26 Application Pidgin Pidgin 2.6.1 Version Details Vulnerabilities
27 Application Pidgin Pidgin 2.6.2 Version Details Vulnerabilities
28 Application Pidgin Pidgin 2.6.3 Version Details Vulnerabilities
29 Application Pidgin Pidgin 2.6.4 Version Details Vulnerabilities
30 Application Pidgin Pidgin 2.6.5 Version Details Vulnerabilities
31 Application Pidgin Pidgin 2.6.6 Version Details Vulnerabilities
32 Application Pidgin Pidgin 2.7.0 Version Details Vulnerabilities
33 Application Pidgin Pidgin 2.7.1 Version Details Vulnerabilities
34 Application Pidgin Pidgin 2.7.2 Version Details Vulnerabilities
35 Application Pidgin Pidgin 2.7.3 Version Details Vulnerabilities
36 Application Pidgin Pidgin 2.7.4 Version Details Vulnerabilities
37 Application Pidgin Pidgin 2.7.5 Version Details Vulnerabilities
38 Application Pidgin Pidgin 2.7.6 Version Details Vulnerabilities
39 Application Pidgin Pidgin 2.7.7 Version Details Vulnerabilities
40 Application Pidgin Pidgin 2.7.8 Version Details Vulnerabilities
41 Application Pidgin Pidgin 2.7.9 Version Details Vulnerabilities
42 Application Pidgin Pidgin 2.7.10 Version Details Vulnerabilities
43 Application Pidgin Pidgin 2.7.11 Version Details Vulnerabilities
44 Application Pidgin Pidgin 2.8.0 Version Details Vulnerabilities
45 Application Pidgin Pidgin 2.9.0 Version Details Vulnerabilities
46 Application Pidgin Pidgin 2.10.0 Version Details Vulnerabilities
47 Application Pidgin Pidgin 2.10.1 Version Details Vulnerabilities
48 Application Pidgin Pidgin 2.10.2 Version Details Vulnerabilities
49 Application Pidgin Pidgin 2.10.3 Version Details Vulnerabilities
50 Application Pidgin Pidgin 2.10.4 Version Details Vulnerabilities
51 Application Pidgin Pidgin 2.10.5 Version Details Vulnerabilities
52 Application Pidgin Pidgin 2.10.6 Version Details Vulnerabilities
53 Application Pidgin Pidgin 2.10.7 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Pidgin Pidgin 53

- References For CVE-2013-6485

http://lists.opensuse.org/opensuse-updates/2014-02/msg00039.html
SUSE openSUSE-SU-2014:0239
https://rhn.redhat.com/errata/RHSA-2014-0139.html
REDHAT RHSA-2014:0139
http://www.ubuntu.com/usn/USN-2100-1
UBUNTU USN-2100-1
http://hg.pidgin.im/pidgin/main/rev/c9e5aba2dafd CONFIRM
http://lists.opensuse.org/opensuse-updates/2014-03/msg00005.html
SUSE openSUSE-SU-2014:0326
http://pidgin.im/news/security/?id=80 CONFIRM
http://www.debian.org/security/2014/dsa-2859
DEBIAN DSA-2859
http://www.securityfocus.com/bid/65243
BID 65243 Pidgin 'process_chunked_data()' Function Heap Buffer Overflow Vulnerability Release Date:2014-08-05

- Metasploit Modules Related To CVE-2013-6485

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.